Introduction

 Top Next

Last update: 30MAY2011

Legal Information

Manual Update History

This Manual has the following sections:

· Embedded Modules
· Boards
· Development Systems
· External Controllers
· Companion Products
· Kits and Accessories

Important notes:

· This manual should be used in conjunction with a "TIDE and Tibbo BASIC Manual" -- a separate manual that documents Tibbo BASIC, TIDE software, hardware "platforms", and everything else required for successful development of Tibbo BASIC applications.
· This manual does not include any information on fixed-function, non-programmable Tibbo devices, such as the original EM100 module or the DS100 serial device server. The data on these devices can be found in the "Serial-over-IP Solutions Manual" -- a separate document.
· Some Tibbo devices are dual-use in nature. Depending on the loaded firmware, any dual-use product can be a fixed-function, serial-over-IP device, or a BASIC-programmable controller. Dual-use devices are documented in the present manual as well as the "Serial-over-IP Solutions Manual". The present manual describes each such device as a BASIC-programmable one, while the "Serial-over-IP Solutions Manual" describes the same device as a serial device server.


Legal Information

 Top Previous Next

Tibbo Technology ("TIBBO") is a Taiwan corporation that designs and/or manufactures a number of hardware products, software products, and applications ("PRODUCTS"). In many cases, Tibbo PRODUCTS are combined with each other and/or third-party products thus creating a PRODUCT COMBINATION.

Whereas you (your Company) wish to purchase any PRODUCT from TIBBO, and/or whereas you (your Company) wish to make use of any documentation or technical information published by TIBBO, and/or make use of any source code published by TIBBO, and/or consult TIBBO and receive technical support from TIBBO or any of its employees acting in an official or unofficial capacity,

You must acknowledge and accept the following disclaimers:

1. Tibbo does not have any branch office, affiliated company, or any other form of presence in any other jurisdiction. TIBBO customers, partners and distributors in Taiwan and other countries are independent commercial entities and TIBBO does not indemnify such customers, partners or distributors in any legal proceedings related to, nor accepts any liability for damages resulting from the creation, manufacture, importation, advertisement, resale, or use of any of its PRODUCT or PRODUCT COMBINATION.
2. BASIC-programmable devices ("PROGRAMMABLE DEVICES") manufactured by TIBBO can run a variety of applications written in Tibbo BASIC ("BASIC APPLICATIONS"). Combining a particular PROGRAMMABLE DEVICE with a specific BASIC APPLICATION, either written by TIBBO or any third party, may potentially create a combinatorial end product ("END PRODUCT") that violates local rules, regulations, and/or infringes an existing patent granted in a country where such combination has occurred or where the resulting END PRODUCT is manufactured, exported, advertised, or sold. TIBBO is not capable of monitoring any activities by its customers, partners or distributors aimed at creating any END PRODUCT, does not provide advice on potential legal issues arising from creating such END PRODUCT, nor explicitly recommends the use of any of its PROGRAMMABLE DEVICES in combination with any BASIC APPLICATION, either written by TIBBO or any third party.
3. TIBBO publishes a number of BASIC APPLICATIONS and segments thereof ("CODE SNIPPETS"). The BASIC APPLICATIONS and CODE SNIPPETS are provided "as is" without warranty of any kind, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The entire risk as to the quality and performance of BASIC APPLICATIONS and CODE SNIPPETS resides with you. BASIC APPLICATIONS and CODE SNIPPETS may be used only as a part of a commercial device based on TIBBO hardware. Modified code does not have to be released into the public domain, and does not have to carry a credit for TIBBO. BASIC APPLICATIONS and CODE SNIPPETS are provided solely as coding aids and should not be construed as any indication of the predominant, representative, legal, or best mode of use for any PROGRAMMABLE DEVICE.
4. BASIC-programmable modules ("PROGRAMMABLE MODULES"), such as the EM1000 device, are shipped from TIBBO in either a blank state (without any BASIC APPLICATION loaded), or with a simple test BASIC APPLICATION aimed at verifying correct operation of PROGRAMMABLE MODULE's hardware. All other BASIC-programmable products including boards, external controllers, and developments systems ("NON-MODULE PRODUCTS"), such as the DS1000 and NB1000, are normally shipped with a BASIC APPLICATION pre-loaded. This is done solely for the convenience of testing by the customer and the nature and function of pre-loaded BASIC APPLICATION shall not be construed as any indication of the predominant, representative, or best mode of use for any such NON-MODULE PRODUCT.
5. All specifications, technical information, and any other data published by TIBBO are subject to change without prior notice. TIBBO assumes no responsibility for any errors and does not make any commitment to update any published information.
6. Any technical advice provided by TIBBO or its personnel is offered on a purely technical basis, does not take into account any potential legal issues arising from the use of such advice, and should not be construed as a suggestion or indication of the possible, predominant, representative, or best mode of use for any Tibbo PRODUCT.
7. Any advance product or business information posted as news or updates of any kind (including Tibbo Blog posts, Tibbo Newsflashes, site news, forum posts and any other timely information posted by Tibbo personnel) shall not be construed as obligatory to TIBBO in any way, shape or form. TIBBO may change or delay any of its plans and product roadmaps without prior notice, and shall not be held liable for such changes to the extent permissible by the applicable law.
8. Neither TIBBO nor its employees shall be held responsible for any damages resulting from the creation, manufacture, or use of any third-party product or system, even if this product or system was inspired, fully or in part, by the advice provided by Tibbo staff (in an official capacity or otherwise) or content published by TIBBO or any other third party.
9. TIBBO may make non-English documentation or other information available at its discretion. Such texts may be the result of work done by third parties, and may not always be reviewed by TIBBO personnel. As such, these are not to be considered official statements by TIBBO. Any apparent inaccuracies, conflicts or differences in meaning between English-language and non-English texts shall always be resolved in favor of the English-language version.
10. TIBBO reserves the right to halt the production or availability of any of its PRODUCTS at any time and without prior notice. The availability of a particular PRODUCT in the past is not an indication of the future availability of this PRODUCT. The sale of the PRODUCT to you is solely at TIBBO's discretion and any such sale can be declined without explanation.
11. TIBBO makes no warranty for the use of its PRODUCTS, other than that expressly contained in the Standard Warranty located on the Company's website. Your use of TIBBO PRODUCTS is at your sole risk. TIBBO PRODUCTS are provided on an "as is" and "as available" basis. TIBBO expressly disclaims the warranties of merchantability, future availability, fitness for a particular purpose and non-infringement. No advice or information, whether oral or written, obtained by you from TIBBO shall create any warranty not expressly stated in the Standard Warranty.
12. LIMITATION OF LIABILITY. BY USING TIBBO PRODUCTS YOU EXPRESSLY AGREE THAT TIBBO SHALL NOT BE LIABLE TO YOU FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, CONSEQUENTIAL OR EXEMPLARY DAMAGES, INCLUDING, BUT NOT LIMITED TO, DAMAGES FOR LOSS OF PROFITS, GOODWILL, OR OTHER INTANGIBLE LOSSES (EVEN IF TIBBO HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES) RESULTING FROM THE USE OR THE INABILITY TO USE OF TIBBO PRODUCTS.
13. "Tibbo" is a registered trademark of Tibbo Technology, Inc.
14. Terms and product names mentioned on TIBBO website or in TIBBO documentation may be trademarks of others.


Embedded Modules

The following embedded modules are currently being offered by Tibbo:

· EM500
· EM1000
· EM1202
· EM1206
· EM200*

Use the module comparison chart to select the module that best suites your application.

* The EM200 module is a dual-use device. For best results, use the EM1000 and EM1202 modules based on the new T1000 ASIC developed by Tibbo.


Module Comparison Table

Generation | 2nd generation: Mature serial-over-IP platform, support for simple Tibbo BASIC applications |  | 3rd generation: Full power of Tibbo BASIC programmability, support for serial-over-IP via available Tibbo BASIC applcation
Device | EM200 | EM203 (SoI manual) | EM1000 | EM1202 | EM1206 | EM500
Highlights | Like the EM120, but with 10/100Base-T Ethernet. | Member of x20x family, mates with the RJ203 jack/magnetics. Combined footprint only 31x19mm. | 2.54mm (0.1") pin pitch – ideal for prototyping. New to Tibbo BASIC? Start your quest with this module! | Stacked design minimizes footprint, device width close to that of a standard RJ45 jack. | Member of x20x family, mates with the RJ203 jack/magnetics. Combined footprint only 34.5x19mm. | Ideal for cost-sensitive applications. Minimal footprint. Width and height close to those of a standard RJ45 jack.
Can work as a serial-to-IP device? | YES |  | YES, through the use of available serial-over-IP Tibbo BASIC application
Ethernet port | 10/100BaseT
Ethernet magnetics | NO (External only)
Wi-Fi port | NO |  | EXTERNAL, requires the GA1000 Wi-Fi add-on module |  |  | YES, in the future
Serial port(s) | 1 |  | 4 |  |  | 1
I/O lines | Up to 9 | Up to 4 | Up to 54 | Up to 32 | Up to 17 | Up to 8
Flash memory | 128KB, for SoI or Tibbo OS (TiOS) firmware, compiled T-Basic app. |  | 512KB or 1024KB, for TiOS firmware, compiled Tibbo BASIC application and its data |  |  | 512KB, for TiOS + BASIC application
Flash disk (FD. object) | NO |  | YES, can take all free space in the flash memory (space not already occupied by TiOS firmware and Tibbo BASIC application) |  |  | In the future, with external flash IC
EEPROM | 2048 bytes, used by SoI firmware to store settings, 2042 bytes available to store T-BASIC app. data |  | 2048 bytes, 2042 bytes available to store Tibbo BASIC application data |  |  | 256 bytes, 200 bytes available to store Tibbo BASIC app. data
RTC (RTC. object) | NO, but you can connect an external RTC |  | YES, with internal or external backup power source | NO, but you can connect an external RTC | YES, with external backup power source | NO, but you can connect an external RTC
Display support (LCD. object) | NO, but you can connect a simple text display |  | YES, supports several models of graphical displays, connected externally |  |  | YES, in the future
Keypad support (KP. object) | NO, but you can connect keys to I/O lines |  | YES, up to 64 keys depending on the availability of I/O lines and keypad configuration |  |  | YES, in the future
Buzzer control output | NO |  | YES, programmable square wave output |  |  | NO
System (a.k.a. MD) button line | YES
Status LED control lines | 2, for green and red status LEDs |  |  |  |  | 2, for green and red dual-function LEDs
Ethernet LED control lines | 2, for link and speed mode indication |  |  |  |  | 1, for link indication
PLL (speed) control | NO |  | YES, through hardware (jumper) or software | YES, through software only |  | NO
Reliable onboard reset | NO, proper external reset circuit is required for correct device operation |  | YES, onboard power-up, brown-out detection, and watchdog circuit |  |  | NO, external reset required
Supply voltage (nominal) | 5V |  | 3.3V, I/O lines are 5V-tolerant
Current consumption (max) | 220mA, with 100BaseT link |  | 230mA, with PLL on and 100BaseT link |  |  | 260mA, at 100BaseT
Dimensions (LxWxH) | 32.1x18.5x7.3mm | 30.1x18.1x5.5mm | 38.4x28.4x5.5mm | 19.1x17.1x14.6mm | 33.2x18.1x5.5mm | 18.5x16.0x6.5mm
Firmware upgrades | YES, through a serial port or network |  |  |  |  | YES, serial/network, including "cold upgrade"


EM500 BASIC-programmable Ethernet Module

Introduction

The EM500 is a miniature stand-alone BASIC-programmable embedded module, designed to be used in combination with a standard LED/magnetics RJ45 jack. The combined footprint of the EM500 and a standard jack is only 28.5x18.5mm.

The module's hardware mix, which includes 10/100BaseT Ethernet port, a serial port, and 8 I/O lines, has been carefully tailored to address the basic needs of lightweight network-enabled control devices. If your application has a need to store data, an external flash IC can be connected to the EM500. The EM500 also supports Wi-Fi communications (using the GA1000 add-on board).

Compact dimensions, a space-saving "vertical slice" mechanical design, low power consumption, and innovative dual-function LED control lines make the module an excellent fit for miniature, cost-sensitive designs.

The EM500 is fully supported by TIDE software and a dedicated EM500 platform that covers all hardware facilities of the module (see "TIDE and Tibbo BASIC Manual"). For convenient testing and evaluation Tibbo offers the EM500EV development system.

The EM500 can be ordered standalone or in combination with an industry-standard RJ45 jack and/or other discrete components required to complete a working circuit.

Hardware features

· Based on a second-generation Tibbo ASIC (T2000).
· 10/100BaseT auto-MDIX Ethernet port (no magnetics).
· Optional Wi-Fi interface (requires GA1000 add-on module to be connected).
· One serial port (CMOS-level):

- Baudrates of up to 460'800bps;

- None/even/odd/mark/space parity modes;

- 7/8 bits/character modes;

- Full-duplex mode with optional flow control;

- Half-duplex mode with direction control;

- Encoding and decoding of Wiegand and clock/data streams.

· 512KB flash memory; 256KB available for compiled Tibbo BASIC application; an external flash IC can be connected if data storage is required.
· 208 bytes of EEPROM space for data storage.
· 8 general-purpose I/O lines (including 2 interrupt lines) and excluding TX and RX lines of the serial port.
· Control lines for two external dual-function status LEDs.
· Additional control line for a dedicated Ethernet link LED.
· RST input for an external reset source (which is required).
· Power: 260mA @ 3.3V.
· "Vertical slice" construction; dimensions: 18.5x16.0x6.5mm.
· Firmware is upgradeable through the serial port or network (including "cold upgrade" firmware uploads through the network).

Programming features

· Variable Types: Byte, char, integer (word), short, dword, long, real, string, plus ser-defined arrays and structures.
· Function Groups: Strings functions (21 in total!), date/time conversion functions, and hash calculation functions (md5 and sha1).
· Platform objects:

- Sock — socket communications (up to 16 UDP, TCP, and HTTP sessions);

- Net — controls Ethernet port;

- Ser — in charge of serial ports (UART, Wiegand, and clock/data modes);

- Io — handles I/O lines, ports, and interrupts;

- Fd* — manages flash memory file system and direct sector access.

- Stor — provides access to the EEPROM;

- Romfile — facilitates access to resource files (fixed data);

- Pat — "plays" patterns on up to five LED pairs;

- Button — monitors MD line (setup button);

- Sys — in charge of general device functionality.

- The following will be available at a later date:

- Wln — handles Wi-Fi interface (requires GA1000 add-on module);

- Lcd — controls graphical display panels (several types supported);

- Kp — scans keypads of matrix and "binary" types;

* Fully supported with the exception of fd.copyfirmware; requires an externally connected flash IC.


I/O Pin Assignment and Pin Functions

em500- pin assignment

See these topics for more information on various hardware facilities of the EM500:

· Serial Port and General-purpose I/O Lines
· Ethernet Port Lines
· Flash and EEPROM Memory
· LED Lines
· Power, Reset, and Mode Selection Lines

I/O pin assignment

Pin # | Function | Description
1 (1,2,3) | GPIO0/P0.0/INT0 | General-purpose I/O line 0 (P0.0); interrupt line 0.
2 (1,2,3) | GPIO1/P0.1/INT1 | General-purpose I/O line 1 (P0.1); interrupt line 1; for flash disk operation, connect to SI and SO of external flash .
3 (1,2) | GPIO2/P0.2 | General-purpose I/O line 2 (P0.2).
4 (1,2) | GPIO3/P0.3 | General-purpose I/O line 3 (P0.3); for flash disk operation, connect to CLK of external flash , also connect to 5.1K pull-up resistor to VCC (3.3V).
5 (1,2) | GPIO4/P0.4 | General-purpose I/O line 4 (P0.4); for flash disk operation, connect to CS of external flash .
6 (1,2) | GPIO5/P0.5 | General-purpose I/O line 5 (P0.5); for Wi-Fi operation, connect to DI and DO of GA1000.
7 (1,2) | GPIO6/P0.6 | General-purpose I/O line 6 (P0.6); for Wi-Fi operation, connect to CLK of GA1000, also to reset-generating logic (NAND gates).
8 (1,2) | GPIO7/P0.7 | General-purpose I/O line 7 (P0.7); for Wi-Fi operation, connect to CS of GA1000, also to reset-generating logic (NAND gates).
9 (1) | RX | RX, W1, and din input of the serial port.
10 (1) | TX | TX, W1, and dout output of the serial port.
11 | GND | System ground.
12 | MD | Mode selection pin.
13 | RST | Reset input, active low. Proper external reset is a must.
14 | SE | Link status LED control line.
15 | SR | Dual-function red status LED control line.
16 | SG | Dual-function green status LED control line.
17 | RX- | Ethernet port, negative line of the differential input signal pair.
18 | RX+ | Ethernet port, positive line of the differential input signal pair.
19 | TX- | Ethernet port, negative line of the differential output signal pair.
20 | TX+ | Ethernet port, positive line of the differential output signal pair.
21 | AVCC | "Clean" power output for magnetics circuitry.
22 | VCC | Positive power input, 3.3V nominal, +/- 5%, max. current consumption 260mA.

Notes:

1. This line is 5V-tolerant and can be interfaced to 5V CMOS devices directly.
2. This line can serve as an RTS/Wout/cout line of a serial port (provided that this does not interfere with any other function).
3. This line can serve as a CTS/W0&1in/cin line of a serial port (provided that this does not interfere with any other function).


Serial Port and General-purpose I/O Lines

The EM500 has eight general-purpose I/O lines GPIO0-7 grouped into a single 8-bit GPIO port P0, plus one serial port.

GPIO0 and GPIO1 lines double as interrupt inputs INT0 and INT1.

The serial port has four I/O lines: RX, TX, CTS, and RTS. TX and RX lines belong exclusively to the serial port and are separate from the GPIO lines. CTS and RTS lines do not exist independently. Rather, either GPIO0/INT0 or GPIO1/INT1 can be selected to serve as the CTS line, while any of the GPIO0-7 lines can be selected to serve as the RTS line.

The serial port of the EM500 can work in one of the three modes: UART, Wiegand, or clock/data. TX, RX, CTS, and CTS lines have different names and functions in the Wiegand and clock/data modes. Serial port operation is described in detail in the documentation for the serial (ser.) object found inside the "TIDE and Tibbo BASIC Manual". Additionally, see the Platform-dependent Programming Information section inside the EM500 platform documentation (same manual).

In total, the EM500 has ten I/O lines (GPIO0-7, TX, RX). The simplified structure of one such I/O line is shown on the circuit diagram below. All lines are "quasi-bidirectional" and can be viewed as open collector outputs with weak pull-up resistors. There is no explicit direction control. To "measure" an external signal applied to a GPIO line, set this line to HIGH first, then read the state of the pin. It is OK to drive the pin LOW externally when the pin outputs HIGH internally.

Each I/O line has a weak pull-up resistor that prevents the line from floating when the output transistor is closed. All I/O lines are 3.3V, CMOS, 5V-tolerant. The maximum load current for each line is 10mA.

I/O line control is described in detail in the documentation for the I/O (io.) object found inside the "TIDE and Tibbo BASIC Manual".


Ethernet Port Lines

The EM500 has a 10/100BaseT Ethernet port. The onboard electronics of the EM500 do not include Ethernet magnetics, so magnetics circuitry must be connected externally to pins TX+, TX-, RX+, RX-, and AVCC. The AVCC pin outputs clean power for the magnetics circuitry, which is very sensitive to noise.

Please, note the following:

· The AVCC is an output!
· Do not combine the AVCC with the VCC (main power) pin.

You can use either a standalone magnetics part, or an RJ45 jack with integrated magnetics (recommended). Here is a circuit diagram based on the UDE RT7-114A1A1A part:

It is important to make the PCB wire connections between the pins of the EM500 and RJ45 jack (magnetics circuitry) as short as possible. Making the wires too long may cause the noise level generated by your PCB surpass the maximum radiated emission limits stipulated by FCC/CE regulations. Additionally, longer Ethernet lines on the PCB will make Ethernet operation less stable.

Note that the circuit above shows an RJ45 jack with two LEDs. Further information on the use of these LEDs can be found in the LED Lines topic.


Flash and EEPROM Memory

The EM500 has 512KBytes of internal flash memory and 208 bytes of EEPROM memory (see Specifications and Ordering Info).

The first 256 KBytes of the internal flash memory are used to store the TiOS firmware. When you are performing a firmware upgrade it is this memory you are saving the firmware binary into.

The rest of this flash memory is available to your Tibbo BASIC application. The internal flash memory cannot be used as a flash disk. The fd. object (see "TIDE and Tibbo BASIC Manual") requires an external flash IC.

As shown on the schematic diagram below, this flash IC is ATMEL AT45DB041. When connected, this flash IC is used exclusively by the fd. object and provides 1MB of storage.

The 5.1K pull-up resistor is needed to "sharpen" SPI clock signal. EM500's bidirectional GPIOs allow interconnecting SI and SO lines (this saves one GPIO line!).

The EEPROM is almost fully available to your application, save for a small 8-byte area called "special configuration area". The EEPROM is accessed through the stor. object (see "TIDE and Tibbo BASIC Manual"). Details on the special configuration area are provided in the Platform-dependent Programming Information section inside the EM500 platform documentation (same manual).


LED Lines

The EM500 has three LED control lines -- SG, SR, SE. All lines have the same internal structure and the LEDs should be connected as shown on the schematic diagram below. The maximum load for each line is 10mA. For a small LED, a 330 Ohm series resistor will provide sufficient brightness.

The SG and SR lines are used to control two status LEDs found on Tibbo products. These LEDs can show various flashing patterns indicating current device state (see Appendix 1: Status LEDs). On the EM500, there is an added twist: the same pair of status LEDs also indicates current Ethernet link status through LED brightness.

When a "live" Ethernet cable is not plugged into the RJ45 jack, flashing patterns displayed by the status LEDs are "dimmed". That is, LEDs turn on at around 20% of their nominal brightness. When a "live" Ethernet cable is plugged into the RJ45 jack, flashing patterns are displayed at full brightness.

This dual functionality was designed into the EM500 for an important reason: Many popular RJ45 jacks have two internal LEDs. With the EM500, it is possible to use these LEDs both for the module state indication, and for Ethernet link indication. This eliminates the need for any additional LEDs.

The third LED control line -- SE -- is a separate line for Ethernet link indication. The SE LED will be on when the Ethernet interface is in the linked state.

There is no indication of the Ethernet link speed on the EM500. That is, there is no LED control line to indicate whether the link is established in the 10BaseT or 100BaseT mode. Many networked devices have such an LED, but its existence has become meaningless: it is actually very difficult to find any old-style 10Mb Ethernet equipment in active use these days.


Power, Reset, and Mode Selection Lines

The EM500 should be powered from a stabilized DC power supply with a nominal output voltage of 3.3V (+/- 5% tolerance). The module's current consumption is approximately 260mA. Providing an adequate power supply is very important -- a poorly built circuit may affect the EM500's operation. We recommend that you use a switching power supply. One example of such a circuit is shown below.

Proper external reset is a must! Reset pulse should be active LOW. We strongly advise against using low-cost RC circuits and other unreliable methods of generating reset pulses. Reset should be applied for as long as the power supply voltage is below 2.9V. We recommend using a dedicated reset IC, such as the MCP130-300 device from Microchip. This part has a trip point at ~2.95V -- perfect for the EM500.

If the EM500 is to serve as a communications co-processor in a larger system that has its own CPU (microcontroller) it is also OK to control the RST line through a general-purpose I/O pin of this CPU. Reset pulses for the EM500 can then be generated programmatically, by setting the I/O pin of the CPU to LOW and then to HIGH.

The function of the MD line is described in Appendix 2: Setup Button (MD line).

Power supply circuit

Many power supply circuits will work well. The one below is being used by Tibbo. This circuit can handle input voltages in the 9-24V range.

Notes:

· U1 (AP1501-33) is a popular power IC manufactured by Anachip (now Diodes Incorporated, www.diodes.com)
· C1 and C2 capacitors: Do not use SMD capacitors -- use regular through-hole aluminum capacitors. This really helps reduce the noise produced by the power supply.
· This is an analog circuit, so layout matters. Apply reasonable "good layout" effort.

Ideally, one should use an oscilloscope to see what sort of "square wave" the power supply generates, both at low and high input voltages, as well as light and heavy loads. There are no recipes here -- just try and see what works for your circuit.


Mechanical Dimensions

H | Max. | 16.0 | Module height
W | Max. | 18.5 | Module width
T | Max. | 6.5 | Module thickness
I | Min. | 5.5 | Lead length
p | Aver. | 1.27 | Pin pitch
s1 | Max. | 3.7 | Module footprint dimension
s2 | Max. | 2.8 | Module footprint dimension
s3 | Aver. | 1.0 | Module footprint dimension

Dimensions are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


Ordering Info and Specifications

The EM500 has a single version available: EM500-00.

Hardware specifications

Ethernet interface | 10/100BaseT Ethernet, Auto-MDIX, magnetics not built-in
Serial ports | 1 port, CMOS-level.
UART capabilities | Baudrates up to 460'800bps; none/even/odd/mark/space parity and 7/8 bits/character.
Number of I/O lines | 8 lines (this does not include the TX and RX lines of the serial port); all lines are 5V-tolerant; all 8 lines are combined into an 8-bit port; 2 lines can be used as interrupt lines.
Max. load current for each I/O line | 10mA
Flash memory | 512 KBytes, 320KBytes are available to store a compiled Tibbo BASIC application; this memory cannot be used as a flash disk.
EEPROM memory | 208 bytes, 200 bytes are available to store application data
Nominal power supply voltage (VCC pin) | DC 3.3V, +/- 5%
Required external reset circuit trip voltage | 2.9-3.0V
Operating current (VCC pin) | 260mA
Operating temperature | -40 to +80 degrees C
Operating relative humidity | 10-90%
Mechanical dimensions (excl. leads) | 18.5x16.0x6.5mm
Pin diameter | 0.4mm
Packaging | Tray, 30 modules/tray

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


EM1000 BASIC-programmable Ethernet Module

Please be sure to read the following topic: EM1000-00 and -01.

Introduction

The EM1000 is Tibbo's most powerful and versatile BASIC-programmable embedded module.

The module's hardware is a potent combination that includes 100Base/T Ethernet, four serial ports, onboard flash, EEPROM, RTC with onboard backup power, and abundant I/O lines (up to 54!) to interface with external LCD, keypad, buzzer, and card readers. Thus, the EM1000 is perfect for designing data collection and automation such as access control panels, time and attendance terminals, inventory control systems, factory floor automation terminals, and the like.

The EM1000 is also excellent for prototyping your projects -- its pin pitch is standard 2.54mm (0.1).

The EM1000 is fully supported by TIDE software and a dedicated EM1000 platform that covers all hardware facilities of the module (see "TIDE and Tibbo BASIC Manual"). For convenient testing and evaluation Tibbo offers EM1000TEV and EM1000EV development systems. The EM1000 can also support Wi-Fi communications (this requires GA1000 add-on board).

Hardware features

· Based on a high-performance purpose-built 88-MHz T1000 ASIC.
· 10/100BaseT auto-MDIX Ethernet port (automatic detection of "straight" and "cross" cables). Standard Ethernet magnetics are NOT integrated into the module.
· Optional Wi-Fi interface (requires GA1000 add-on module to be connected).
· Four high-speed serial ports (CMOS-level):

- Baudrates of up to 921,600bps;

- None/even/odd/mark/space parity modes;

- 7/8 bits/character modes;

- Full-duplex mode with optional flow control;

- Half-duplex mode with direction control;

- Encoding and decoding of Wiegand and clock/data streams.

· 512K or 1024KB flash memory for firmware, application, and data storage.
· 2KB EEPROM for data storage.
· RTC with dedicated backup power input (optional onboard supercapacitor).
· Up to 54 general-purpose I/O lines. Among them:

- 8 interrupt lines;

- Serial port lines;

- 40 lines that are combined into five 8-bit ports;

- Square wave output (6Hz - 22'1184MHz), which can be used to control external buzzer.

· Supports external LCD and keypad.
· Four control lines for status LEDs:

- 2 lines for green and red status LED control;

- 2 lines for Ethernet status LED control.

· Software- and hardware-controlled onboard PLL to select the clock frequency of the device: 11.0592MHz with PLL off, 88.4736MHz with PLL on.
· Reliable power-on/ brown-out reset circuit; no additional external reset circuitry required. Master reset input also provided.
· Power: 230mA @ 3.3V (100BaseT mode, PLL on).
· Dimensions: 38.4x28.4x5.5mm.
· Firmware and Tibbo BASIC application are upgradeable through the serial port or network.
· Tibbo BASIC application can be debugged through the network and no additional debugging hardware, such as in-circuit emulator, is required.

Programming features

· Variable Types: Byte, char, integer (word), short, dword, long, real, string, plus ser-defined arrays and structures.
· Function Groups: Strings functions (21 in total!), date/time conversion functions, and hash calculation functions (md5 and sha1).
· Platform objects:

- Sock — socket communications (up to 16 UDP, TCP, and HTTP sessions);

- Net — controls Ethernet port;

- Wln — handles Wi-Fi interface (requires GA1000 add-on module);

- Ser — in charge of serial ports (UART, Wiegand, and clock/data modes);

- Io — handles I/O lines, ports, and interrupts;

- Lcd — controls graphical display panels (several types supported);

- Kp — scans keypads of matrix and "binary" types;

- Rtc — keeps track of date and time;

- Fd — manages flash memory file system and direct sector access;

- Stor — provides access to the EEPROM;

- Romfile — facilitates access to resource files (fixed data);

- Pat — "plays" patterns on up to five LED pairs;

- Beep — generates buzzer patterns;

- Button — monitors MD line (setup button);

- Sys — in charge of general device functionality.


EM1000-00 and -01

Small hardware changes were made to the EM1000 since its first release. Currently Tibbo supplies version "-01" of the module. The first version ever produced was "-00". The main difference is in the Ethernet IC: the EM1000-...-00 used Davicom's DM9000 while the EM1000-...- 01 features newer DM9000A. This change reduced module's current consumption and operating temperature. Unfortunately, this transition requires certain alterations to the way Ethernet magnetics and RJ45 are wired to the module. Tibbo apologizes for any inconvenience caused!

Throughout this document, differences between hardware versions of the module are highlighted in pink. Please, note that from the programming standpoint there are no functional differences between the EM1000-...- 00 and EM1000-...- 00.

Pictures below show the original EM1000-...- 00 and the EM1000-...- 01.

This is how the original EM1000-...- 00 looks like:

And this is how the EM1000-...- 01 looks like:


I/O Pin Assignment and Pin Functions

em1000- pin assignment v2

See these topics for more information on various hardware facilities of the EM1000:

· General-purpose I/O Lines
· SPI Port Connector
· Ethernet Port Lines
· Serial Ports
· Square Wave Generator
· Flash and EEPROM Memory
· Real-time Counter
· LED Lines
· Power, Reset, PLL Control, and Mode Selection Lines

I/O pin assignment

Pin # | Function | Description
1 (1,2) | GPIO0/P0.0 | General-purpose I/O line 0 (P0.0).
2 (1,2) | GPIO1/P0.1 | General-purpose I/O line 1 (P0.1).
3 (1,2) | GPIO2/P0.2 | General-purpose I/O line 2 (P0.2).
4 (1,2) | GPIO3/P0.3 | General-purpose I/O line 3 (P0.3).
5 (1,2) | GPIO4/P0.4 | General-purpose I/O line 4 (P0.4).
6 (1,2) | GPIO5/P0.5 | General-purpose I/O line 5 (P0.5).
7 (1,2) | GPIO6/P0.6 | General-purpose I/O line 6 (P0.6).
8 (1,2) | GPIO7/P0.7 | General-purpose I/O line 7 (P0.7).
9 (1,2) | GPIO8/P1.0/RX0 | General-purpose I/O line 8 (P1.0); RX, W1, and din input of the serial port 0.
10 (1,2) | GPIO9/P1.1/TX0 | General-purpose I/O line 9 (P1.1); TX, W1, and dout output of the serial port 0.
11 (1,2) | GPIO10/P1.2/RX1 | General-purpose I/O line 10 (P1.2); RX, W1, and din input of the serial port 1.
12 (1,2) | GPIO11/P1.3/TX1 | General-purpose I/O line 11 (P1.3); TX, W1, and dout output of the serial port 1.
13 (1,2) | GPIO12/P1.4/RX2 | General-purpose I/O line 12 (P1.4); RX, W1, and din input of the serial port 2.
14 (1,2) | GPIO13/P1.5/TX2 | General-purpose I/O line 13 (P1.5); TX, W1, and dout output of the serial port 2.
15 (1,2) | GPIO14/P1.6/RX3 | General-purpose I/O line 14 (P1.6); RX, W1, and din input of the serial port 3.
16 (1,2) | GPIO15/P1.7/TX3 | General-purpose I/O line 15 (P1.7); TX, W1, and dout output of the serial port 3.
17 (1,2,3) | GPIO16/P2.0/INT0 | General-purpose I/O line 16 (P2.0); interrupt line 0.
18 (1,2,3) | GPIO17/P2.1/INT1 | General-purpose I/O line 17 (P2.1); interrupt line 1.
19 (1,2,3) | GPIO18/P2.2/INT2 | General-purpose I/O line 18 (P2.2); interrupt line 2.
20 (1,2,3) | GPIO19/P2.3/INT3 | General-purpose I/O line 19 (P2.3); interrupt line 3.
21 (1,2,3) | GPIO20/P2.4/INT4 | General-purpose I/O line 20 (P2.4); interrupt line 4.
22 (1,2,3) | GPIO21/P2.5/INT5 | General-purpose I/O line 21 (P2.5); interrupt line 5.
23 (1,2,3) | GPIO22/P2.6/INT6 | General-purpose I/O line 22 (P2.6); interrupt line 6.
24 (1,2,3) | GPIO23/P2.7/INT7 | General-purpose I/O line 23 (P2.7); interrupt line 7.
25 (1,2) | GPIO40 | General-purpose I/O line 40 (does not belong to any 8-bit port).
26 (1,2) | GPIO41 | General-purpose I/O line 41 (does not belong to any 8-bit port).
27 (1,2) | GPIO42 | General-purpose I/O line 42 (does not belong to any 8-bit port).
28 (1,2) | GPIO43 | General-purpose I/O line 43 (does not belong to any 8-bit port).
29 | GND | System ground.
30 (1,2) | GPIO44 | General-purpose I/O line 44.
31 (1,2) | GPIO25/P3.1 | General-purpose I/O line 25 (P3.1).
32 (1,2) | GPIO24/P3.0 | General-purpose I/O line 24 (P3.0).
33 (1,2) | GPIO27/P3.3 | General-purpose I/O line 27 (P3.3).
34 (1,2) | GPIO26/P3.2 | General-purpose I/O line 26 (P3.2).
35 (1,2) | GPIO29/P3.5 | General-purpose I/O line 29 (P3.5).
36 (1,2) | GPIO28/P3.4 | General-purpose I/O line 28 (P3.4).
37 (1,2) | GPIO31/P3.7 | General-purpose I/O line 31 (P3.7).
38 (1,2) | GPIO30/P3.6 | General-purpose I/O line 30 (P3.6).
39 (1,2) | GPIO33/P4.1 | General-purpose I/O line 33 (P4.1).
40 (1,2) | GPIO32/P4.0 | General-purpose I/O line 32 (P4.0).
41 (1,2) | GPIO35/P4.3 | General-purpose I/O line 35 (P4.3).
42 (1,2) | GPIO34/P4.2 | General-purpose I/O line 34 (P4.2).
43 (1,2) | GPIO37/P4.5 | General-purpose I/O line 37 (P4.5).
44 (1,2) | GPIO36/P4.4 | General-purpose I/O line 36 (P4.4).
45 (1,2) | GPIO39/P4.7 | General-purpose I/O line 39 (P4.7).
46 (1,2) | GPIO38/P4.6 | General-purpose I/O line 38 (P4.6).
47 | MD | Mode selection pin.
48 | <TEST PIN> | Leave this pin unconnected.
49 | RST | Reset line, active high.
50 | PM | PLL control line (HIGH- PLL ON, LOW- PLL OFF).
51 | SR | Red status LED control line.
52 | SG | Green status LED control line.
53 (1,2) | GPIO46 | General-purpose I/O line 46.
54 (1,2) | GPIO45/CO | General-purpose I/O line 45 (does not belong to any 8-bit port); square wave output line.
55 (1,2) | GPIO48 | General-purpose I/O line 48 (does not belong to any 8-bit port).
56 (1,2) | GPIO47 | General-purpose I/O line 47 (does not belong to any 8-bit port).
57 | DBGRX | RX line of debug serial port (details to be published).
58 | VCCB | Backup power for the real-time counter; connect to 3.3V through a 50 Ohm resistor.
59 | DBGTX | TX line of debug serial port (details to be published).
60 | VCC | Positive power input, 3.3V nominal, +/- 5%, max. current consumption 230mA (100BaseT, PLL on).
61 | TX- | Ethernet port, negative line of the differential output signal pair.
62 | AVCC | "Clean" power output for magnetics circuitry: EM1000-...- 00: 3.3V (not in production) EM1000-...- 01: 2.5V (currently in production).
63 | TX+ | Ethernet port, positive line of the differential output signal pair.
64 | EY | Yellow Ethernet status LED control line.
65 | EM1000-...- 00: --- EM1000-...- 01: SCAP | EM1000-...- 00: --- EM1000-...- 01: external supercapacitor input.
66 | EG | Green Ethernet status LED control line.
67 | RX- | Ethernet port, negative line of the differential input signal pair.
68 | EM1000-...- 00: --- EM1000-...- 01: AGND | EM1000-...- 00: --- EM1000-...- 01: analog ground.
69 | RX+ | Ethernet port, positive line of the differential input signal pair.
70 | EM1000-...- 00: --- EM1000-...- 01: AGND | EM1000-...- 00: --- EM1000-...- 01: analog ground.
71 (4) | GND | System ground.
72 (4) | VCC | 3.3V power available on this pin. Do not connect to the power source. To avoid current loops, only use pin #60 to power the device.
73 (1,2,4) | GPIO49 | General-purpose I/O line 49 (does not belong to any 8-bit port).
74 (4) | SPIDI | SPI port, data in.
75 (1,2,4) | GPIO50 | General-purpose I/O line 50 (does not belong to any 8-bit port).
76 (4) | SPIDO | SPI port, data out.
77 (1,2,4) | GPIO51 | General-purpose I/O line 51 (does not belong to any 8-bit port).
78 (1,2,4) | SPICLK | SPI port, clock line.
79 (1,2,4) | GPIO52 | General-purpose I/O line 52 (does not belong to any 8-bit port).
80 (1,2,4) | GPIO53 | General-purpose I/O line 53 (does not belong to any 8-bit port).

Notes:

1. This line is 5V-tolerant and can be interfaced to 5V CMOS devices directly.
2. This line can serve as an RTS/Wout/cout line of a serial port (provided that this does not interfere with any other function).
3. This line can serve as a CTS/W0&1in/cin line of a serial port (provided that this does not interfere with any other function).
4. This pin is on the SPI connector. "-A" option device modification has SPI connector header soldered in and "available" to the host PCB. "T" option devices have a female SPI connector. Other EM1000 versions do not have the SPI connector.


General-purpose I/O Lines

The EM1000 has 54 general-purpose I/O lines (GPIO0 - GPIO53). All lines are 3.3V, CMOS, 5V-tolerant lines. Maximum load current for each I/O line is 10mA. 49 of these lines are always present. Remaining 5 lines are located on the SPI port connector. This connector is "available" to the host PCB only on option "-A" EM1000 devices.

40 of the I/O lines are combined into five 8-bit ports.

Simplified structure of one I/O line of the EM1000 is shown on the circuit diagram below. Each line has an independent output buffer control. When the EM1000 powers up all I/O lines have their output buffers tri-stated (in other words, all I/O lines are configured as inputs). You need to explicitly enable the output buffer of a certain I/O line if you want this line to become an output.

Many I/O lines of the EM1000 also serve as inputs or outputs of special function modules, such as serial ports. Majority of those lines need to be correctly configured as inputs or outputs -- this won't happen automatically. Several lines -- such as TX and RX lines of the serial port when in the UART mode -- are configured as outputs and inputs automatically when the serial port (or some other hardware block) is enabled. For details see "Platform-dependent Programming Information inside the EM1000 platform documentation ("TIDE and Tibbo BASIC Manual").

Each I/O line has a weak pull-up resistor that prevents the line from floating when the output buffer is tri-stated.

I/O line control is described in detail in the documentation for the I/O (io.) object found inside the "TIDE and Tibbo BASIC Manual".


SPI Port Connector

The SPI (serial peripheral interface) is a bus which can support several devices at the same time. The flash memory of the EM1000 is attached to this bus. Additionally, slave SPI modules (such as the GA1000) connect to the same SPI bus.

The SPI port of the EM1000 is located on a separate 10-pin connector. Depending on the EM1000 model, this connector may or may not be present.

The SPI port carries several standard signals -- clock (SPICLK), data out (SPIDO), and data in (SPIDI). Additionally, there are 5 general-purpose I/O lines. These lines may be used independently or in conjunction with the SPI port to provide additional signals (such as CS) required by the SPI device.

EM1000 versions and the SPI port

Standard EM1000 devices do not have the SPI port connector and the "landing" PCB area for the connector is left empty.

Slave SPI modules, such as the GA1000, can optionally be soldered into the SPI port pads of the EM1000. This is the case when the "EM1000G" ordering code is used to purchase a set of modules consisting of the EM1000 module and GA1000 module.

Option "-A" EM1000 devices feature a 10-pin SPI port pin header. The pins on this header are identical to all other pins of the EM1000 and, like the latter, face the host PCB. This way the SPI port of the EM1000 can be connected to some other circuitry on the host PCB. For example, instead of mounting the GA1000 module on top of the EM1000, the latter can be connected directly to the host PCB. Option "-A" EM1000 module is then required to facilitate a connection between the EM1000 and the GA1000.

Finally, option "-T" devices have a female SPI port connector soldered in. Slave SPI modules can be plugged into this female connector. EM1000 modules of "-T" variety are intended for convenient SPI slave module testing and are not recommended for use in production devices.

For further information on available EM1000 versions see Mechanical Dimensions and Specifications and Ordering Info topics.


Ethernet Port Lines

ATTENTION! There are two different Ethernet magnetics arrangements: one for original EM1000-...- 00, another one -- for the EM1000-...- 01.

Ethernet port of the EM1000 is of 100BaseT type. Onboard electronics of the EM1000 do not include Ethernet magnetics, so magnetics circuitry must be connected externally to pins TX+, TX-, RX+, RX-, and AVCC. The AVCC pin outputs clean power for the magnetics circuitry, which is very sensitive to noise. The voltage on the AVCC depends on the EM1000 version: 3.3V for EM1000-...- 00, 2.5V for the EM1000-...- 01. Separate AGND analog ground pins have been added on the EM1000-...- 01. For the EM1000-...- 00 there is no separate analog ground. Please, note the following:

· The AVCC is an output!
· Do not combine AVCC with the VCC (main power) pin. On the EM1000-...- 00 this is counter-productive, and on the EM1000-...- 01 this will apply wrong voltage to the AVCC pin. Doing so appears to be causing no immediate permanent damage to the EM1000-...- 01, but the circuit will not work and the effects of prolonged over-voltage on the AVCC line are not known.

You can use either a standalone magnetics part (such as YCL-PH163112) or RJ45 connector with integrated magnetics (i.e. YCL-PTC1111-01G). Here are two connection diagrams based on the YCL-PTC1111-01G -- one for the EM1000-...- 00, another one - for the EM1000-...- 01.

Once again, the EM1000-...- 00 is a legacy part that has been replaced with the EM1000-...- 01. In case you have already made the PCB based on the EM1000-...- 00 specifications and are not willing to change it, you can easily modify it to accommodate the EM1000-...- 01 (see diagram below):

· Do not install four 50 Ohm resistors (they are crossed out on the diagram).
· Connect a wire between pins 4 and 7 of the RJ45 connector (pin numbers are for YCL-PTC1111-01G).
· If possible, find a way to install a 220uF capacitor. The circuit will still work even if you don't have this capacitor but you may have FCC/CE certification issues.
· Notice that one of the 0.1 capacitors becomes redundant but that's OK.
· All of the above is based on the assumption that your host PCB was designed correctly and the AVCC output of the EM1000 is not joined together with the main VCC line. If you erroneously had AVCC and VCC combined together then you will need to separate them as well: pin AVCC outputs 2.5V on the EM1000-...- 01 and this is different from the main power on the VCC pin, which is 3.3V. Applying 3.3V to pin AVCC of the EM1000-...- 01 appears to be causing no immediate permanent damage to the device, but the circuit will not work and the effects of prolonged over-voltage on the AVCC line are not known.

It is important to make the PCB wire connections between the Ethernet port pins of the EM1000 and external magnetics circuitry as short as possible. Making the wires too long may cause the noise level generated by your PCB to surpass the maximum radiated emission limits stipulated by FCC/CE regulations. Additionally, longer Ethernet lines on the PCB will make your board more susceptible to the damage from the ESD (electrostatic discharge).

The EM1000 also has two Ethernet status LED control lines- see here for details.


Serial Ports

The EM1000 has four serial ports that can work in one of the three modes: UART, Wiegand, or clock/data. All three modes are described in detail in the documentation for the serial (ser.) object found inside the "TIDE and Tibbo BASIC Manual". Additionally, see the Platform-dependent Programming Information section inside the EM1000 platform documentation (same manual).


Square Wave Generator

The square wave generator can produce a square wave output on pin GPIO45/CO of the EM1000. This output is primarily intended for generating audio signals using buzzer and is covered in the beep (beep.) object -- see the "TIDE and Tibbo BASIC Manual".


Flash and EEPROM Memory

The EM1000 has 512KBytes or 1024KBytes of flash memory and 2KBytes of EEPROM memory (see Specifications and Ordering Info).

The first 64KBytes of flash memory are used to store the TiOS firmware. When you are performing a firmware upgrade it is this memory you are saving the firmware binary into.

The rest of this flash memory is available to your Tibbo BASIC application and its data. Whatever memory space is left after the compiled application is loaded can be used as a flash disk (see fd. object documentation in the "TIDE and Tibbo BASIC Manual").

The EEPROM is almost fully available to your application, save for a small 8-byte area called "special configuration area". The EEPROM is accessed through the stor. object (see "TIDE and Tibbo BASIC Manual"). Details on the special configuration area are provided in the Platform-dependent Programming Information section inside the EM1000 platform documentation (same manual).


Real-time Counter

The real-time counter (RTC) of the EM1000 is a free-running 40-bit register that increments at a rate of 128Hz.

As a source of backup power, the EM1000 can rely on a supercapacitor. Option "-S" of the EM1000 (see Specifications and Ordering Info) has an onboard supercapacitor. To enable charging, connect 3.3V power to the VCCB pin of the EM1000, preferably through a current-limiting resistor (50 Ohm is a good value). A fully discharged supercapacitor creates a nearly short-circuit current inrush when it starts charging and this can damage the power supply of the host board.

The EM1000-...-S carries the supercapacitor on the bottom side of its PCB (see Mechanical Dimensions). With this supercapacitor present, it is impossible to solder the module into the host PCB directly and the module can only be installed on a socket. If this is not acceptable you can use a "plain" EM1000 (non- "-S") and connect an external supercapacitor to the SCAP pin of the EM1000. This option is only available on the newer EM1000-...- 01 device (EM1000-...- 00 does not have the SCAP input).

The supercapacitor has many advantages- it charges almost instantly and has virtually unlimited lifespan. The disadvantage is that the supercapacitor is only able to sustain the RTC of the EM1000 for several days at most (about 6 days for the 5F supercapacitor of the EM1000-...-S), which may appear to be insufficient. Remember, however, that the EM1000 is often used in a "connected" product. As such, it can always synchronize its clock with an Internet time server or a master clock on the main server of your system. Therefore, the role of the supercapacitor is to provide backup power during relatively short periods of power interruption, for example when the device is unplugged and moved to another location, or when the device is powered off over the weekend.

It is also possible to use a 3V lithium battery to power the RTC (in this case, do not use the EM1000 with "-S"). Connect the battery to the VCCB pin through a small Schottky diode. This diode is necessary to slightly reduce the voltage on the VCCB pin. You can calculate the time the battery will be able to sustain the EM1000 from the average backup current, which is ~13uA. Note that the VCCB pin cosumes a much larger current (~1mA) when the Vcc is applied and the EM1000 is running. Therefore, your battery-based backup circuit should be designed in a way that does not drain the battery while the Vcc is applied.

The RTC will continue to function with backup power on the VCCB pin as low as 2.2V. Make sure that the voltage on this pin does not exceed 3.3V. Failure to observe this limit may cause permanent damage to the EM1000.

Your Tibbo BASIC application can access the RTC through the RTC (rtc.) object, which is documented in the "TIDE and Tibbo BASIC Manual".


LED Lines

The EM1000 has four LED control lines -- SG, SR, EG, and EY. All lines have the same internal structure and the LEDs should be connected to these lines as shown on the schematic diagram below. Maximum load for each line is 10mA.

Further information on status LEDs can be found in Appendix 1: Status LEDs.


Power, Reset, PLL Control, and Mode Selection Lines

The EM1000 should be powered from a stabilized DC power supply with nominal output voltage of 3.3V (+/- 5% tolerance). This power should be applied to the pin #60. "-A" modification of the EM1000 has the second VCC pin -- #72. To prevent "current loops", only use either pin #60, or pin #72 to supply the power to the device.

Current consumption of the EM1000 is approximately 230mA (PLL on, 100BaseT mode). This does not include the power consumption of the slave SPI module, such as the GA1000. The slave module, depending on its type, can add significantly to the power consumed by the EM1000. Therefore, providing an adequate power supply is very important -- poorly built circuit may affect EM1000 operation. We recommend that you use a switching power supply. One (but not the only) example of such circuit is shown below.

Please, do not forget that the VCCB pin should not be left unconnected (see Real-time Counter).

Proper external reset is not required. The EM1000 has a reliable power-on reset circuit with brown-out detection. Optionally, you can connect a reset button or some other reset-generating circuit to the RST pin of the EM1000. This will allow you to generate "external" resets. The RST line has active HIGH polarity. If you are not using the RST pin you can leave it unconnected.

The main clock frequency of the EM1000 is generated by the an 11.0592MHz crystal connected to the onboard PLL circuit. When the PLL is off, the EM1000 is clocked at 11.0592MHz. When the PLL is on, the main clock is eight times higher- 88.4736MHz. Naturally, with PLL turned on the EM1000 works 8 times faster and consumers more current (230mA with PLL on against 110mA with PLL off). Main clock frequency also affects the baudrates of serial ports when in the UART mode, as well as the frequency produced by the square wave generator.

The PLL cannot be switched off and on while the EM1000 is running. This is because when the PLL mode changes its output needs some time to stabilize. For this reason, the PLL mode of the EM1000 can only be changed on reset. A special internal delay circuit will hold the EM1000 in reset while PLL frequency stabilizes.

The state of the PM pin at power-on or external reset (i.e. reset pulse on the RST line) defines whether the EM1000 will run with PLL on or off. To have the PLL on, leave the PM pin unconnected. To disable PLL and run at lower clock frequency, ground the PM pin.

Your Tibbo BASIC application can also change the PLL mode programmatically. The Tibbo BASIC application can check the current PLL mode through the system (sys.) object (see "TIDE and Tibbo BASIC Manual"). If the PLL mode needs to be changed, the application can set new mode and then perform an internal reset (again, through the system object). The internal reset is identical to the power-on or external reset with one difference: the PLL mode is set basing not on the PM pin but on the PLL mode requested by the application prior to the reset.

The function of the MD line is described in Appendix 2: Setup Button (MD line).

Power supply circuit

Many power supply circuits will work well. The one below is being used by Tibbo. The circuit can handle input voltages in the 9-24V range.

Notes:

· U1 (AP1501-33) is a popular power IC manufactured by Anachip (now Diodes Incorporated, www.diodes.com)
· C1 and C2 capacitors: Do not use SMD capacitors -- use regular through-hole aluminum capacitors. This really helps reduce noise produced by the power supply.
· This is an analog circuit, so layout matters. Apply reasonable "good layout" effort.

Ideally, one should use an oscilloscope to see what sort of "square wave" the power supply generates, both at low and high input voltages, as well as light and heavy loads. There are no recipes here -- just try and see what works for your circuit.


Mechanical Dimensions

Notes:

Standard EM1000 devices do not have an SPI port connector and the "landing" PCB area for the connector is left empty (cross-section A).

Compatible slave SPI modules (such as the GA1000 Wi-Fi module) can optionally be soldered into the SPI connector pads (cross-section B).

Option "-A" EM1000 devices feature a 10-pin SPI port pin header (cross-section C). The pins on this header are identical to all other pins of the EM1000 and, like the latter, face the host PCB. This way the SPI port of the EM1000 can be connected to some other circuitry on the host PCB. For example, instead of piggy-backing the GA1000 onto the EM1000, you can opt to place it on the host PCB. The EM1000 "-A" module is then required to facilitate a connection between the EM1000 and the GA1000.

Finally, option "-T" devices have a female SPI port connector soldered in. Slave SPI modules, such as the GA1000, can be plugged into this female connector. EM1000 modules of "-T" variety are intended for convenient slave module testing and are not recommended for use in production devices.

L | Max. | 38.4 | Module length
W | Max. | 28.4 | Module width
H | Max. | 5.5 | Module height
H' | Max. | 11.0 | Module height with the GA1000 module installed on top of the EM1000 module
h | Max. | 4 | Additional height added by the supercapacitor ("-S" option devices only)
I | Min. | 6.0 | Lead length
p | Aver. | 2.54 | Pin pitch

Dimensions are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


Ordering Info and Specifications

The EM1000 has several versions available. Device numbering scheme is as follows:

EM1000 numbering system

Examples of valid model numbers

Model number | Description
EM1000-512K-01 | EM1000 module with 512KBytes of flash memory
EM1000-1024K-S-01 | EM1000 module with 1024KBytes of flash memory and the supercapacitor (backup power source for the RTC)
EM1000-512K-SA-01 | EM1000 module with 512KBytes of flash memory, supercapacitor, and SPI port header soldered in

Earlier EM1000 modification -- EM1000-...-00 -- is no longer in production and have been superseded by newer "-01" devices.

Ordering an EM1000+GA1000 module combination

The EM1000 can also be ordered in combination with the GA1000 module. To simplify ordering, use the "EM1000G" ordering code. This code means that the EM1000 module will be supplied with the GA1000 module soldered into it (resulting mechanical structure is presented as "option B" on the Mechanical Dimensions drawing). Additional EM1000 "features" can be specified in the normal manner. For example, ordering code "EM1000G-1024K-S-01" means that you will receive a set of two modules, one being "EM1000-1024K-S-01" (EM1000 with 1024K flash and supercapacitor), and another one being "GA1000", soldered together.

Hardware specifications

Ethernet interface | 10/100BaseT Ethernet, Auto-MDIX, magnetics not built-in
Serial ports | 4 ports, CMOS-level.
UART capabilities | Baudrates up to 921'600bps; none/even/odd/mark/space parity and 7/8 bits/character.
Number of I/O lines | "Regular" EM1000: 49 lines; option "-A" device: 53 lines; all lines are 5V-tolerant; 40 of I/O lines are combined into five 8-bit ports; 8 lines can be used as interrupt lines.
Max. load current for each I/O line | 10mA
Square wave generator | 6Hz - 22'1184MHz, primarily intended for buzzer control
Real-time counter (RTC) | 40 bit, increments at 128Hz, has its own backup power input
RTC backup power source | Supercapacitor, supports RTC for app. 6 days ("-S" version only); alternatively, external supercapacitor or backup battery can be connected.
Clock frequency | 11.0592MHz with PLL off 88.4736MHz with PLL on
Flash memory | 512KBytes or 1024KBytes, entire memory minus 64KB is available to store Tibbo BASIC application and data
EEPROM memory | 2048 bytes, 2040 bytes available to store application data
Nominal power supply voltage (VCC pin) | DC 3.3V, +/- 5%
Reset circuit trip voltage (VCC pin) | 3.0V on power-up (i.e. when the voltage on VCC is rising) 2.9V on brown-out (i.e. when the voltage on VCC is dropping)
Operating current (VCC pin), not including hardware consumed by an add-on modules plugged into the EM1000 | 40mA with PLL off, Ethernet cable unplugged 50mA with PLL off, 10BaseT mode 110mA with PLL off, 100BaseT mode 160mA with PLL on, Ethernet cable unplugged 170mA with PLL on, 10BaseT mode 230mA with PLL on, 100BaseT mode
Backup power voltage range (VCCB pin)(1) | 2.2V - 3.3V (option without "-S" only)
Backup current (VCCB pin) | 1mA when the EM1000 is running (3.3V on VCC) 13uA when the EM1000 is not powered (0V on VCC)
Operating temperature | -20 to +70 degrees C
Operating relative humidity | 10-90%
Mechanical dimensions (excl. leads) | "Plain" EM1000: 38.4x28.4x5.5 mm EM1000-...-S(2): 38.4x28.4x9.5 mm EM1000W: 38.4x28.4x11.0 mm EM1000W-...-S(2): 38.4x28.4x15.0 mm
Pin diameter | 0.64mm
Packaging | EM1000-...-S and EM1000-...-T devices: tray, 30 modules/tray EM1000G module combination: tray, 30 modules/tray All other devices (without "-S" and "-T" options): tube, 10 modules/tube

Notes:

1. The RTC will not lose its data and will keep running as long as the backup voltage stays within this range.
2. The EM1000-xxxK-S device cannot be installed on the PCB directly. This is because it has a supercapacitor mounted on the bottom side of the module. This device must be be mounted on a socket.

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


 EM1202

EM1202

Introduction

While occupying miniscule 19x17mm on your PCB, the EM1202 BASIC-programmable embedded module retains most features of the much larger EM1000 device. These include 100Base/T Ethernet, four serial ports, onboard flash, EEPROM, and 24 I/O lines that can be used to interface with external LCD, keypad, buzzer, and card readers.

Thanks to its miniature dimensions, the EM1202 can be conveniently used as a network front-end in automation, security, and data collection systems.

The EM1202 is fully supported by TIDE software and a dedicated EM1202 platform that covers all hardware facilities of the module (see "TIDE and Tibbo BASIC Manual"). For convenient testing and evaluation Tibbo offers EM1202EV evaluation board. The EM1202 can also support Wi-Fi communications (this requires GA1000 add-on board).

Hardware features

· Based on a high-performance purpose-built 88-MHz T1000 ASIC.
· 10/100BaseT auto-MDIX Ethernet port (automatic detection of "straight" and "cross" cables). Standard Ethernet magnetics are NOT integrated into the module.
· Optional Wi-Fi interface (requires GA1000 add-on module to be connected).
· Four high-speed serial ports (CMOS-level):

- Baudrates of up to 921,600bps;

- None/even/odd/mark/space parity modes;

- 7/8 bits/character modes;

- Full-duplex mode with optional flow control;

- Half-duplex mode with direction control;

- Encoding and decoding of Wiegand and clock/data streams.

· 512K or 1024KB flash memory for firmware, application, and data storage.
· 2KB EEPROM for data storage.
· Up to 32 general-purpose I/O lines. Among them:

- 8 interrupt lines;

- Serial port lines;

- 24 lines that are combined into three 8-bit ports;

- Square wave output (6Hz - 22'1184MHz), which can be used to control external buzzer.

· Supports external LCD and keypad.
· Four control lines for status LEDs:

- 2 lines for green and red status LED control;

- 2 lines for Ethernet status LED control.

· Software- controlled onboard PLL to select the clock frequency of the device: 11.0592MHz with PLL off, 88.4736MHz with PLL on.
· Reliable power-on/ brown-out reset circuit; no additional external reset circuitry required. Master reset input also provided.
· Power: 230mA @ 3.3V (100BaseT mode, PLL on).
· Dimensions: 17.1x19.1x14.6mm.
· Firmware and Tibbo BASIC application are upgradeable through the serial port or network.
· Tibbo BASIC application can be debugged through the network and no additional debugging hardware, such as in-circuit emulator, is required.

Programming features

· Variable Types: Byte, char, integer (word), short, dword, long, real, string, plus ser-defined arrays and structures.
· Function Groups: Strings functions (21 in total!), date/time conversion functions, and hash calculation functions (md5 and sha1).
· Platform objects:

- Sock — socket communications (up to 16 UDP, TCP, and HTTP sessions);

- Net — controls Ethernet port;

- Wln — handles Wi-Fi interface (requires GA1000 add-on module);

- Ser — in charge of serial ports (UART, Wiegand, and clock/data modes);

- Io — handles I/O lines, ports, and interrupts;

- Lcd — controls graphical display panels (several types supported);

- Kp — scans keypads of matrix and "binary" types;

- Fd — manages flash memory file system and direct sector access;

- Stor — provides access to the EEPROM;

- Romfile — facilitates access to resource files (fixed data);

- Pat — "plays" patterns on up to five LED pairs;

- Beep — generates buzzer patterns;

- Button — monitors MD line (setup button);

- Sys — in charge of general device functionality.


I/O Pin Assignment and Pin Function

em1202- pin assignment v2

See these topics for more information on various hardware facilities of the EM1202:

· General-purpose I/O Lines
· Ethernet Port Lines
· Serial Ports
· Square Wave Generator
· Flash and EEPROM Memory
· LED Lines
· Power, Reset, and Mode Selection Lines

I/O pin assignment

Pin # | Function | Description
1 (1,2) | GPIO28 | General-purpose I/O line 28 (does not belong to any 8-bit port).
2 (1,2) | GPIO27 | General-purpose I/O line 27 (does not belong to any 8-bit port).
3 (1,2) | GPIO26 | General-purpose I/O line 26 (does not belong to any 8-bit port).
4 (1,2) | GPIO25 | General-purpose I/O line 25 (does not belong to any 8-bit port).
5 (1,2) | GPIO24 | General-purpose I/O line 24 (does not belong to any 8-bit port).
6 (1,2) | GPIO7/P0.7 | General-purpose I/O line 7 (P0.7).
7 (1,2) | GPIO6/P0.6 | General-purpose I/O line 6 (P0.6).
8 (1,2) | GPIO5/P0.5 | General-purpose I/O line 5 (P0.5).
9 (1,2) | GPIO4/P0.4 | General-purpose I/O line 4 (P0.4).
10 (1,2) | GPIO3/P0.3 | General-purpose I/O line 3 (P0.3).
11 (1,2) | GPIO2/P0.2 | General-purpose I/O line 2 (P0.2).
12 (1,2) | GPIO1/P0.1 | General-purpose I/O line 1 (P0.1).
13 (1,2) | GPIO0/P0.0 | General-purpose I/O line 0 (P0.0).
14 | <No connection> | This pin must be left unconnected.
15 | GND | System ground.
16 (1,2) | GPIO30 | General-purpose I/O line 30 (does not belong to any 8-bit port).
17 | VCC | Positive power input, 3.3V nominal, +/- 5%, max. current consumption 300mA (100BaseT, PLL on).
18 (1,2) | GPIO29/CO | General-purpose I/O line 29 (does not belong to any 8-bit port); square wave output line.
19 (1,2) | GPIO31 | General-purpose I/O line 31 (does not belong to any 8-bit port).
20 | SG | Green status LED control line.
21 | RST | Reset line, active high.
22 | SR | Red status LED control line.
23 | MD | Mode selection pin.
24 (1,2) | GPIO8/P1.0/RX0 | General-purpose I/O line 8 (P1.0); RX, W1, and din input of the serial port 0.
25 (1,2,3) | GPIO16/P2.0/INT0 | General-purpose I/O line 16 (P2.0); interrupt line 0.
26 (1,2) | GPIO9/P1.1/TX0 | General-purpose I/O line 9 (P1.1); TX, W1, and dout output of the serial port 0.
27 (1,2,3) | GPIO17/P2.1/INT1 | General-purpose I/O line 17 (P2.1); interrupt line 1.
28 (1,2) | GPIO10/P1.2/RX1 | General-purpose I/O line 10 (P1.2); RX, W1, and din input of the serial port 1.
29 (1,2,3) | GPIO18/P2.2/INT2 | General-purpose I/O line 18 (P2.2); interrupt line 2.
30 (1) | GPIO11/P1.3/TX1 | General-purpose I/O line 11 (P1.3); TX, W1, and dout output of the serial port 1.
31 (1,2,3) | GPIO19/P2.3/INT3 | General-purpose I/O line 19 (P2.3); interrupt line 3.
32 (1,2) | GPIO12/P1.4/RX2 | General-purpose I/O line 12 (P1.4); RX, W1, and din input of the serial port 2.
33 (1,2,3) | GPIO20/P2.4/INT4 | General-purpose I/O line 20 (P2.4); interrupt line 4.
34 (1,2) | GPIO13/P1.5/TX2 | General-purpose I/O line 13 (P1.5); TX, W1, and dout output of the serial port 2.
35 (1,2,3) | GPIO21/P2.5/INT5 | General-purpose I/O line 21 (P2.5); interrupt line 5.
36 (1,2) | GPIO14/P1.6/RX3 | General-purpose I/O line 14 (P1.6); RX, W1, and din input of the serial port 3.
37 (1,2,3) | GPIO22/P2.6/INT6 | General-purpose I/O line 22 (P2.6); interrupt line 6.
38 (1,2) | GPIO15/P1.7/TX3 | General-purpose I/O line 15 (P1.7); TX, W1, and dout output of the serial port 3.
39 (1,2,3) | GPIO23/P2.7/INT7 | General-purpose I/O line 23 (P2.7); interrupt line 7.
40 | AVCC | "Clean" 2.5V power output for magnetics circuitry.
41 | TX- | Ethernet port, negative line of the differential output signal pair.
42 | EG | Green Ethernet status LED control line.
43 | TX+ | Ethernet port, positive line of the differential output signal pair.
44 | EY | Yellow Ethernet status LED control line.
45 | RX- | Ethernet port, negative line of the differential input signal pair.
46 | AGND | Analog ground.
47 | RX+ | Ethernet port, positive line of the differential input signal pair.

Notes:

1. This line is 5V-tolerant and can be interfaced to 5V CMOS devices directly.
2. This line can serve as an RTS/Wout/cout line of a serial port (provided that this does not interfere with any other function).
3. This line can serve as a CTS/W0&1in/cin line of a serial port (provided that this does not interfere with any other function).


General-purpose I/O Lines

The EM1202 has 32 general-purpose I/O lines (GPIO0 - GPIO31). 24 of these lines are combined into three 8-bit ports. All lines are 3.3V, CMOS, 5V-tolerant. Maximum load current for each I/O line is 10mA.

Simplified structure of one I/O line of the EM1202 is shown on the circuit diagram below. Each line has an independent output buffer control. When the EM1202 powers up all I/O lines have their output buffers tri-stated (in other words, all I/O lines are configured as inputs). You need to explicitly enable the output buffer of a certain I/O line if you want this line to become an output.

Many I/O lines of the EM1202 also serve as inputs or outputs of special function modules, such as serial ports. Majority of those lines need to be correctly configured as inputs or outputs -- this won't happen automatically. Several lines -- such as TX and RX lines of the serial port when in the UART mode -- are configured as outputs and inputs automatically when the serial port (or some other hardware block) is enabled. For details see Platform-dependent Programming Information inside the EM1202 platform documentation ("TIDE and Tibbo BASIC Manual").

Each I/O line has a weak pull-up resistor that prevents the line from floating when the output buffer is tri-stated.

\

I/O line control is described in detail in the documentation for the I/O (io.) object found inside the "TIDE and Tibbo BASIC Manual".


Ethernet Port Lines

Ethernet port of the EM1202 is of 100BaseT type. Onboard electronics of the EM1202 do not include Ethernet magnetics, so magnetic circuitry must be connected externally to pins TX+, TX-, RX+, RX-, and AVCC. The AVCC pin outputs clean 2.5V power for the magnetics circuitry, which is very sensitive to noise. Separate AGND analog ground is also provided. Please, note the following:

· The AVCC is an output!
· Do not combine AVCC with the VCC (main power) pin. This will apply wrong voltage to the AVCC pin. Doing so appears to be causing no immediate permanent damage to the EM1202, but the circuit will not work and the effects of prolonged over-voltage on the AVCC line are not known.

You can use either a standalone magnetics part (such as YCL-PH163112) or RJ45 connector with integrated magnetics (i.e. YCL-PTC1111-01G). Here is a connection diagram for the YCL-PTC1111-01G jack with integrated magnetics.

It is important to make the PCB wire connections between the Ethernet port pins of the EM1202 and external magnetics circuitry as short as possible. Making the wires too long may cause the noise level generated by your PCB to surpass the maximum radiated emission limits stipulated by FCC/CE regulations. Additionally, longer Ethernet lines on the PCB will make your board more susceptible to the damage from the ESD (electrostatic discharge). Follow these three recommendations:

· Route TX+, TX-, RX+, RX- in such a way that they do not cross each other. Try to avoid using vias (keep on the same board side).
· Keep more or less uniform distance between "+" and "-" traces of each pair.

The EM1202 also has two Ethernet status LED control lines- see here for details.


Serial Ports

The EM1202 has four serial ports that can work in one of the three modes: UART, Wiegand, or clock/data. All three modes are described in detail in the documentation for the serial (ser.) object found inside the "TIDE and Tibbo BASIC Manual". Additionally, see the Platform-dependent Programming Information section inside the EM1202 platform documentation (same manual).


Square Wave Generator

The square wave generator can produce a square wave output on pin GPIO29/CO of the EM1202. This output is primarily intended for generating audio signals using buzzer and is covered in the beep (beep.) object -- see the "TIDE and Tibbo BASIC Manual".


Flash and EEPROM Memory

The EM1202 has 512KBytes or 1024KBytes of flash memory and 2KBytes of EEPROM memory.

The first 64KBytes of flash memory are used to store the TiOS firmware. When you are performing a firmware upgrade it is this memory you are saving the firmware binary into.

The rest of this flash memory is available to your Tibbo BASIC application and its data. Whatever memory space is left after the compiled application is loaded can be used as a flash disk (see fd. object documentation in the "TIDE and Tibbo BASIC Manual").

The EEPROM is almost fully available to your application, save for a small 8-byte area called "special configuration area". The EEPROM is accessed through the stor. object (see "TIDE and Tibbo BASIC Manual"). Details on the special configuration area are provided in the Platform-dependent Programming Information section inside the EM1202 platform documentation (same manual).


LED Lines

The EM1202 has four LED control lines -- SG, SR, EG, and EY. All lines have the same internal structure and the LEDs should be connected to these lines as shown on the schematic diagram below. Maximum load for each line is 10mA.

Further information on status LEDs can be found in Appendix 1: Status LEDs.


Power, Reset, and Mode Selection Lines

The EM1202 should be powered from a stabilized DC power supply with nominal output voltage of 3.3V (+/- 5% tolerance). Current consumption of the EM1202 is approximately 230mA (PLL on, 100BaseT mode). Providing an adequate power supply is very important -- poorly built circuit may affect EM1000 operation. We recommend that you use a switching power supply. One (but not the only) example of such circuit is shown below.

Proper external reset is not required. The EM1202 has a reliable power-on reset circuit with brown-out detection. Optionally, you can connect a reset button or some other reset-generating circuit to the RST pin of the EM1202. This will allow you to generate "external" resets. The RST line has active HIGH polarity. If you are not using the RST pin you can leave it unconnected.

The main clock frequency of the EM1202 is generated by an 11.0592MHz crystal connected to the onboard PLL circuit. When the PLL is off, the EM1202 is clocked at 11.0592MHz. When the PLL is on, the main clock is eight times higher- 88.4736MHz. Naturally, with PLL on the EM1202 works 8 times faster and consumers more current (230mA with PLL on against 110mA with PLL off). Main clock frequency also affects the baudrates of serial ports when in the UART mode, as well as the frequency produced by the square wave generator.

The PLL cannot be switched off and on while the EM1202 is running. This is because when PLL mode changes its output needs some time to stabilize. For this reason, the PLL mode of the EM1202 can only be changed on reset. A special internal delay circuit will hold the EM1202 in reset while PLL frequency stabilizes.

Unlike the EM1000, the EM1202 does not have a hardware pin to control the state of the PLL. On power up, the PLL is always enabled. Your Tibbo BASIC application can change the PLL mode programmatically. The application can check the current PLL mode through the system (sys.) object (see "TIDE and Tibbo BASIC Manual"). If the PLL mode needs to be changed, the application can set new mode and then perform an internal reset (again, through the system object). The internal reset is identical to the power-on or external reset with one difference: the PLL mode will not default to "PLL on" but instead will be set as requested by the application prior to the reset.

The function of the MD line is described in Appendix 2: Setup Button (MD line).

Power supply circuit

Many power supply circuits will work well. The one below is being used by Tibbo. The circuit can handle input voltages in the 9-24V range.

Notes:

· U1 (AP1501-33) is a popular power IC manufactured by Anachip (now Diodes Incorporated, www.diodes.com)
· C1 and C2 capacitors: Do not use SMD capacitors -- use regular through-hole aluminum capacitors. This really helps reduce noise produced by the power supply.
· This is an analog circuit, so layout matters. Apply reasonable "good layout" effort.

Ideally, one should use an oscilloscope to see what sort of "square wave" the power supply generates, both at low and high input voltages, as well as light and heavy loads. There are no recipes here -- just try and see what works for your circuit.


Mechanical Dimensions

L | Max. | 17.1 | Module length
W | Max. | 19.1 | Module width
H | Max. | 14.6 | Module height (option without supercapacitor)
I | Min. | 2.5 | Lead length
p | Aver. | 1.27 | Pin pitch

Dimensions are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


Ordering Info and Specifications

Device numbering scheme is as follows:

EM1202 numbering system

Examples of valid model numbers

Model number | Description
EM1202-512K-01 | EM1202 module with 512KBytes of flash memory
EM1202-1024K-01 | EM1202 module with 1MB of flash memory

Hardware specifications

Ethernet interface | 10/100BaseT Ethernet, Auto-MDIX, magnetics not built-in
Serial ports | 4 ports, CMOS-level.
UART capabilities | Baudrates up to 921'600bps; none/even/odd/mark/space parity and 7/8 bits/character.
Number of I/O lines | 32 lines, all lines are 5V-tolerant; 24 of I/O lines are combined into five 8-bit ports; 8 lines can be used as interrupt lines.
Max. load current for each I/O line | 10mA
Square wave generator | 6Hz - 22'1184MHz, primarily intended for buzzer control
Clock frequency | 11.0592MHz with PLL off 88.4736MHz with PLL on
Flash memory | 512KBytes or 1024KBytes, entire memory minus 64KB is available to store Tibbo BASIC application and data
EEPROM memory | 2048 bytes, 2040 bytes available to store application data
Nominal power supply voltage (VCC pin) | DC 3.3V, +/- 5%
Reset circuit trip voltage (VCC pin) | 3.0V on power-up (i.e. when the voltage on VCC is rising) 2.9V on brown-out (i.e. when the voltage on VCC is dropping)
Operating current (VCC pin), not including hardware consumed by an add-on modules plugged into the EM1000 | 40mA with PLL off, Ethernet cable unplugged 50mA with PLL off, 10BaseT mode 110mA with PLL off, 100BaseT mode 160mA with PLL on, Ethernet cable unplugged 170mA with PLL on, 10BaseT mode 230mA with PLL on, 100BaseT mode
Operating temperature | -20 to +70 degrees C
Operating relative humidity | 10-90%
Mechanical dimensions (excl. leads) | 17.1x19.1x14.6mm
Pin diameter | 0.4mm
Packaging | Tray, 30 modules/tray

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


EM1206

Introduction

The EM1206 is a miniature BASIC-programmable embedded module. This device is a member of the x20x family of embedded modules and takes full advantage of unique mechanical concept of x20x devices. The module can be used with any suitable jack and magnetics, or with our patent-pending RJ203 jack/magnetics module. The combined PCB footprint of the EM1206 and RJ203 is only 34.5x19mm.

The module's hardware mix, which includes 100Base/T Ethernet, four serial ports, flash disk, EEPROM, and RTC, has been carefully tailored to address the typical needs of network-enabled control applications. This makes the EM1206 especially suitable for "connected" edge products such as sensors, network-enabled card readers, actuators, and other lightweight devices.

The EM1206 is fully supported by TIDE software and a dedicated EM1206 platform that covers all hardware facilities of the module (see "TIDE and Tibbo BASIC Manual"). For convenient testing and evaluation Tibbo offers the EM1206EV evaluation board. The EM1206 can also support Wi-Fi communications (this requires GA1000 add-on board), as well as external LCD, keypad, and buzzer.

Hardware features

· Based on a high-performance purpose-built 88-MHz T1000 ASIC.
· 10/100BaseT auto-MDIX Ethernet port (automatic detection of "straight" and "cross" cables). Standard Ethernet magnetics are NOT integrated into the module:

- Connect any suitable external jack and magnetics; or

- Combine the EM1206 with Tibbo's patent-pending RJ203 module to achieve minimal PCB footprint.

· Optional Wi-Fi interface (requires GA1000 add-on module to be connected).
· Four high-speed serial ports (CMOS-level):

- Baudrates of up to 921,600bps;

- None/even/odd/mark/space parity modes;

- 7/8 bits/character modes;

- Full-duplex mode with optional flow control;

- Half-duplex mode with direction control;

- Encoding and decoding of Wiegand and clock/data streams.

· 512K or 1024KB flash memory for firmware, application, and data storage.
· 2KB EEPROM for data storage.
· RTC with dedicated backup power input.
· Up to 17 general-purpose I/O lines. Among them:

- 8 interrupt lines;

- Serial port lines;

- 16 lines that are combined into two 8-bit ports;

- Square wave output (6Hz - 22'1184MHz), which can be used to control external buzzer.

· Supports external LCD and keypad.
· Control lines for two external status LEDs.
· Four LEDs onboard:

- Green and red status LEDs;

- Green and yellow Ethernet status LEDs.

· Software-controlled onboard PLL to select the clock frequency of the device: 11.0592MHz with PLL off, 88.4736MHz with PLL on.
· Reliable power-on/ brown-out reset circuit; no additional external reset circuitry required. Master reset input also provided.
· Power: 230mA @ 3.3V (100BaseT mode, PLL on).
· Dimensions: 33.2x18.1x5.5mm.
· Firmware and Tibbo BASIC application are upgradeable through the serial port or network.
· Tibbo BASIC application can be debugged through the network and no additional debugging hardware, such as in-circuit emulator, is required.

Programming features

· Variable Types: Byte, char, integer (word), short, dword, long, real, string, plus ser-defined arrays and structures.
· Function Groups: Strings functions (21 in total!), date/time conversion functions, and hash calculation functions (md5 and sha1).
· Platform objects:

- Sock — socket communications (up to 16 UDP, TCP, and HTTP sessions);

- Net — controls Ethernet port;

- Wln — handles Wi-Fi interface (requires GA1000 add-on module);

- Ser — in charge of serial ports (UART, Wiegand, and clock/data modes);

- Io — handles I/O lines, ports, and interrupts;

- Kp — scans keypads of matrix and "binary" types;

- Rtc — keeps track of date and time;

- Fd — manages flash memory file system and direct sector access;

- Stor — provides access to the EEPROM;

- Romfile — facilitates access to resource files (fixed data);

- Pat — "plays" patterns on up to five LED pairs;

- Beep — generates buzzer patterns;

- Button — monitors MD line (setup button);

- Sys — in charge of general device functionality.


I/O Pin Assignment and Pin Functions

The EM1206 has three connectors: main connector, additional connector, and magnetics connector. Depending on the EM1206 version, magnetics connector can be soldered facing up or down, as described in the Mechanical Dimensions topic.

See these topics for more information on various hardware facilities of the EM1206:

· General-purpose I/O Lines
· Ethernet Port Lines
· Serial Ports
· Square Wave Generator
· Flash and EEPROM Memory
· Real-time Counter
· LED Lines
· Power, Reset, and Mode Selection Lines

Main connector

Pin # | Function | Description
1 | VCCB | Backup power for the real-time counter. Do not connect to 3.3V directly!
2 | MD | Mode selection pin.
3 | RST | Reset line, active high.
4 (1,2,3) | GPIO5/P0.5/TX2/INT5 | General-purpose I/O line 5 (P0.5); TX, W1, dout output of the serial port 2; Interrupt line 5.
5 (1,2,3) | GPIO4/P0.4/RX2/INT4 | General-purpose I/O line 4 (P0.4); RX, W1, din input of the serial port 2; Interrupt line 4.
6 (1,2,3) | GPIO6/P0.6/RX3/INT6 | General-purpose I/O line 6 (P0.6); RX, W1, din input of the serial port 3; Interrupt line 6.
7 (1,2,3) | GPIO7/P0.7/TX3/INT7 | General-purpose I/O line 7 (P0.7); TX, W1, dout output of the serial port 3; Interrupt line 7.
8 | VCC | Positive power input, 3.3V nominal, +/- 5%, max. current consumption 230mA (100BaseT, PLL on).
9 | GND | System ground.
10 (1,2,3) | GPIO0/P0.0/RX0/INT0 | General-purpose I/O line 0 (P0.0); RX, W1, din input of the serial port 0; Interrupt line 0.
11 (1,2,3) | GPIO1/P0.1/TX0/INT1 | General-purpose I/O line 1 (P0.1); TX, W1, dout output of the serial port 0; Interrupt line 1.
12 (1,2,3) | GPIO2/P0.2/RX1/INT2 | General-purpose I/O line 2 (P0.2); RX, W1, din input of the serial port 1; Interrupt line 2.
13 (1,2,3) | GPIO3/P0.3/TX1/INT3 | General-purpose I/O line 3 (P0.3); TX, W1, dout output of the serial port 1; Interrupt line 3.

Notes:

1. This line is 5V-tolerant and can be interfaced to 5V CMOS devices directly.
2. This line can serve as an RTS/Wout/cout line of a serial port (provided that this does not interfere with any other function).
3. This line can serve as a CTS/W0&1in/cin line of a serial port (provided that this does not interfere with any other function).

Additional connector

Pin # | Function | Description
1 | SG | Green status LED control line.
2 | SR | Red status LED control line.
3 (1,2) | GPIO16/CO | General-purpose I/O line 16 (does not belong to any port); square wave output line.
4 (1,2) | GPIO8/P1.0 | General-purpose I/O line 8 (P1.0).
5 (1,2) | GPIO9/P1.1 | General-purpose I/O line 9 (P1.1).
6 (1,2) | GPIO10/P1.2 | General-purpose I/O line 10 (P1.2).
7 (1,2) | GPIO11/P1.3 | General-purpose I/O line 11 (P1.3).
8 (1,2) | GPIO12/P1.4 | General-purpose I/O line 12 (P1.4).
9 (1,2) | GPIO13/P1.5 | General-purpose I/O line 13 (P1.5).
10 (1,2) | GPIO14/P1.6 | General-purpose I/O line 14 (P1.6).
11 (1,2) | GPIO15/P1.7 | General-purpose I/O line 15 (P1.7).

Notes:

1. This line is 5V-tolerant and can be interfaced to 5V CMOS devices directly.
2. This line can be assigned to serve as an RTS/Wout/cout line of a serial port.

Magnetics connector

Pin # | Function | Description
#1 | RX+ | Ethernet port, positive line of the differential input signal pair.
#2 | RX- | Ethernet port, negative line of the differential input signal pair.
#3 | AVCC | "Clean" 1.8V power output for magnetics circuitry.
#4 | --- | ---
#5 | --- | ---
#6 | AGND | Analog ground.
#7 | TX+ | Ethernet port, positive line of the differential output signal pair.
#8 | TX- | Ethernet port, negative line of the differential output signal pair.


General-purpose I/O Lines

The EM1206 has 17 general-purpose I/O lines (GPIO0 - GPIO16). All lines are 3.3V, CMOS, 5V-tolerant. Maximum load current for each line is 10mA. Out of seventeen available lines, sixteen are combined into two 8-bit ports.

The simplified structure of one I/O line of the EM1206 is shown on the circuit diagram below. Each line has an independent output buffer control. When the EM1206 powers up all I/O lines have their output buffers tri-stated (in other words, all I/O lines are configured as inputs). You need to explicitly enable the output buffer of a certain I/O line if you want this line to become an output.

Each I/O line has a weak pull-up resistor that prevents the line from floating when the output buffer is tri-stated. I/O line control is described in the io. object documentation ("TIDE and Tibbo BASIC Manual").

Many I/O lines of the EM1206 have alternative functions and serve as inputs or outputs of special function modules: On the EM1206, the special function modules are four serial ports and the square wave generator. When any special function module is enabled, its I/O lines seize to work as inputs/outputs and are controlled by this special function module directly. Depending on the nature of an alternative function a given I/O line is to perform, your application may still have to manually configure this line for input or output. The table below details which special function module lines require manual configuration:

RX lines of serial ports | Automatically configured as inputs when a corresponding serial port is enabled, revert to previous state when this port is disabled.
TX lines of serial ports | Automatically configured as outputs when a corresponding serial port is enabled, revert to previous state when this port is disabled.
CTS lines of serial ports | Must be configured as inputs by your application. Note that CTS lines can be "remapped".
RTS lines of serial ports | Must be configured as outputs by your application. Note that RTS lines can be "remapped".
CO (square wave output) | Automatically configured as output when the square wave is being generated, reverts to previous state when the square wave output stops.


Ethernet Port Lines

Ethernet port of the EM1206 is of 100BaseT type. Onboard electronics of the EM1206 do not include Ethernet magnetics, so magnetic circuitry must be connected externally to pins TX+, TX-, RX+, RX-, and AVCC. The AVCC pin outputs clean 2.5V power for the magnetics circuitry, which is very sensitive to noise. Separate AGND analog ground is also provided. Please, note the following:

· The AVCC is an output!
· Do not combine AVCC with the VCC (main power) pin. This will apply wrong voltage to the AVCC pin. Doing so appears to cause no immediate permanent damage to the EM1206, but the circuit will not work and the effects of prolonged over-voltage on the AVCC line are not known.

You can use either a standalone magnetics part (such as YCL-PH163112) or an RJ45 connector with integrated magnetics (i.e. YCL-PTC1111-01G). Here is a connection diagram for the YCL-PTC1111-01G jack with integrated magnetics.

Alternatively, you can use the EM1206 in combination with the RJ203 jack/magnetics module. Unique patent-pending design of the RJ203 "tucks" the EM1206 under the RJ203 thus minimizing required host PCB space. For more information see RJ203 documentation (mechanical drawing of the EM1206+RJ203 module combination can be found here).


Serial Ports

The EM1206 has four serial ports that can work in one of the three modes: UART, Wiegand, or clock/data. All three modes are described in detail in the ser. object documentation ("TIDE and Tibbo BASIC Manual"). Additionally, see the Platform-dependent Programming Information section inside the EM1206 platform documentation (same manual).


Square Wave Generator

The square wave generator can produce a square wave output on pin GPIO16/CO of the EM1206. This output is primarily intended for generating audio signals using buzzer and is covered in the beep. object documentation ("TIDE and Tibbo BASIC Manual").


Flash and EEPROM Memory

The EM1206 has 512KBytes or 1024KBytes of flash memory and 2KBytes of EEPROM memory.

The first 64KBytes of flash memory are used to store the TiOS firmware. When you are performing a firmware upgrade it is this memory you are saving the firmware binary into.

The rest of this flash memory is available to your Tibbo BASIC application and its data. Whatever memory space is left after the compiled application is loaded can be used as a flash disk (see fd. object documentation in the "TIDE and Tibbo BASIC Manual").

The EEPROM is almost fully available to your application, save for a small 8-byte area called "special configuration area". The EEPROM is accessed through the stor. object (see "TIDE and Tibbo BASIC Manual"). Details on the special configuration area are provided in the Platform-dependent Programming Information section inside the EM1206 platform documentation (same manual).


Real-time Counter

The real-time counter (RTC) of the EM1206 is a free-running 40-bit register that increments at a rate of 128Hz.

As a source of backup power, the EM1206 can rely on a supercapacitor. Suggested schematic diagram is shown below. The resistor is used for current limiting: a fully discharged supercapacitor creates a nearly short-circuit current inrush when it starts charging and this can damage the power supply of your host board.

The supercapacitor has many advantages- it charges almost instantly and has virtually unlimited lifespan. The disadvantage is that the supercapacitor is only able to sustain the RTC of the EM1206 for about 5-6 days, which may appear to be insufficient. Remember, however, that the EM1206 is a "connected" product. As such, it can always synchronize its clock with an Internet time server or a master clock on the main server of your system. Therefore, the role of the supercapacitor is to provide backup power during relatively short periods of power interruption, for example when the device is unplugged and moved to another location, or when the device is powered off over the weekend.

It is also possible to use a 3V lithium battery for backup power. Remember, however, that the voltage on the VCCB pin should not exceeed 2.5V. Therefore, you need to use several diodes in series between the battery and the VCCB input. You can calculate the time the battery will be able to sustain the EM1206 from the average backup current, which is ~13uA. Note that the VCCB pin cosumes a much larger current (~1mA) when the Vcc is applied and the EM1206 is running. Therefore, your battery-based backup circuit should be designed in a way that does not drain the battery while the Vcc is applied.

Your Tibbo BASIC application can access the RTC through the rtc. object (see "TIDE and Tibbo BASIC Manual").


LED Lines

The EM1206 has two LED control lines -- Status Green (SG), and Status Red (SR). Both lines have the same internal structure and the LEDs should be connected to these lines as shown on the schematic diagram below. The use of an external gate is recommended because the EM1206 has its own onboard status LEDs, and those are driven by SG and SR lines as well. The combined load of the internal and external LED on the same line is too "heavy".

Further information on status LEDs can be found in Appendix 1: Status LEDs.


Power, Reset, and Mode Selection Lines

The EM1206 should be powered from a stabilized DC power supply with nominal output voltage of 3.3V (+/- 5% tolerance). Current consumption of the EM1206 is approximately 230mA (PLL on, 100BaseT mode). Providing an adequate power supply is very important -- poorly built circuit may affect EM1206 operation. We recommend that you use a switching power supply. One (but not the only) example of such circuit is shown below.

Proper external reset is not required. The EM1206 has a reliable power-on reset circuit with brown-out detection. Optionally, you can connect a reset button or some other reset-generating circuit to the RST pin of the EM1206. This will allow you to generate "external" resets. The RST line has active HIGH polarity. If you are not using the RST pin you can leave it unconnected.

The main clock frequency of the EM1206 is generated by an 11.0592MHz crystal connected to the onboard PLL circuit. When the PLL is off, the EM1206 is clocked at 11.0592MHz. When the PLL is on, the main clock is eight times higher- 88.4736MHz. Naturally, with PLL on the EM1206 works 8 times faster and consumers more current (230mA with PLL on against 110mA with PLL off). Main clock frequency also affects the baudrates of serial ports when in the UART mode, as well as the frequency produced by the square wave generator.

The PLL cannot be switched off and on while the EM1206 is running. This is because when PLL mode changes its output needs some time to stabilize. For this reason, the PLL mode of the EM1206 can only be changed on reset. A special internal delay circuit will hold the EM1206 in reset while PLL frequency stabilizes.

Unlike the EM1000, the EM12062 does not have a hardware pin to control the state of the PLL. On power up, the PLL is always enabled. Your Tibbo BASIC application can change the PLL mode programmatically. The application can check the current PLL mode through the sys. object (see "TIDE and Tibbo BASIC Manual"). If the PLL mode needs to be changed, the application can set new mode and then perform an internal reset (again, through the sys. object). The internal reset is identical to the power-on or external reset with one difference: the PLL mode will not default to "PLL on" but instead will be set as requested by the application prior to the reset.

The function of the MD line is described in Appendix 2: Setup Button (MD line).

Power supply circuit

Many power supply circuits will work well. The one below is being used by Tibbo. The circuit can handle input voltages in the 9-24V range.

Notes:

· U1 (AP1501-33) is a popular power IC manufactured by Anachip (now Diodes Incorporated, www.diodes.com)
· C1 and C2 capacitors: Do not use SMD capacitors -- use regular through-hole aluminum capacitors. This really helps reduce noise produced by the power supply.
· This is an analog circuit, so layout matters. Apply reasonable "good layout" effort.

Ideally, one should use an oscilloscope to see what sort of "square wave" the power supply generates, both at low and high input voltages, as well as light and heavy loads. There are no recipes here -- just try and see what works for your circuit.


Onboard LEDs

The EM1206 features four onboard status LEDs. The LEDs are strategically positioned on the edge of the module's board. Your product can have a small window or opening on its cover to make the LEDs of the EM1206 visible from the outside. When the EM1206 is used in combination with the RJ203 module, the status LEDs are visible through a transparent portion of the RJ203's housing.

Further information on status LEDs can be found in Appendix 1: Status LEDs.


Thermal considerations

The DM9000B Ethernet controller of the EM1206 can become very hot during normal module operation. To aid the module in dissipating excess heat, a special heat-conductive sticker is applied to the top of the DM9000B. The protective paper of the sticker MUST BE REMOVED prior to installing the module on the host PCB.

To further lower the operating temperature of the EM1206 we advise you to arrange a copper area on the host PCB and in contact with the heat-conductive sticker. Best results are achieved when the copper area is larger, and also when two copper areas are provided on both sides of the host PCB and interconnected by a number of large vias.


Mechanical Dimensions

L | Max. | 33.4 | Length
W | Max. | 18.1 | Width
H | Max. | 4.2 | Height
l1 | Aver. | 14.4 | Length of the narrower part of the board
w | Max. | 16.7 | Width at the narrower part of the board
p | Aver. | 1.27 | Pin pitch
s1 | Aver. | 32.15 | Distance from the edge of the board to the pins of the main connector
s2 | Aver. | 27.2 | Distance from the edge of the board to the pins of the magnetics connector
s3 | Aver. | 3.8 | Distance from the edge of the board to the pins of the additional connector
l | Min. | 4.0 | Connector pin length

All dimensions are in millimeters. Dimensions are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


Ordering Info and Specifications

The EM1206 has several versions available. Device numbering scheme is as follows:

Examples of valid model numbers

Model number | Description
EM1206-512K-00 | 512KB flash, connector configured to mate with the RJ203 jack/magnetics module
EM1206-1024K-D-00 | 1024KB flash, connectors configured to mate with the host PCB

Ordering the EM1206 and RJ203 module combination

The EM1206 can also be ordered in combination with the RJ203 module. To receive these two modules pre-assembled together, please specify "RJ203+EM1206" on your order.

Hardware specifications

Ethernet interface | 10/100BaseT Ethernet, Auto-MDIX, magnetics not built-in
Serial ports | 4 ports, CMOS-level.
UART capabilities | Baudrates up to 921'600bps; none/even/odd/mark/space parity and 7/8 bits/character.
Number of I/O lines | 17 lines, all lines are 5V-tolerant; 16 lines are combined into five 8-bit ports; 8 lines can be used as interrupt lines.
Max. load current for each I/O line | 10mA
Square wave generator | 6Hz - 22'1184MHz, primarily intended for buzzer control
Real-time counter (RTC) | 40 bit, increments at 128Hz, has its own backup power input
Clock frequency | 11.0592MHz with PLL off 88.4736MHz with PLL on
Flash memory | 1024KBytes, entire memory minus 64KB is available to store Tibbo BASIC application and data
EEPROM memory | 2048 bytes, 2040 bytes available to store application data
Nominal power supply voltage (VCC pin) | DC 3.3V, +/- 5%
Reset circuit trip voltage (VCC pin) | 3.0V on power-up (i.e. when the voltage on VCC is rising) 2.9V on brown-out (i.e. when the voltage on VCC is dropping)
Operating current (VCC pin), excluding hardware consumed by an add-on modules plugged into the EM1000 | 40mA with PLL off, Ethernet cable unplugged 50mA with PLL off, 10BaseT mode 110mA with PLL off, 100BaseT mode 160mA with PLL on, Ethernet cable unplugged 170mA with PLL on, 10BaseT mode 230mA with PLL on, 100BaseT mode
Nominal backup voltage (VCCB pin) | 2.5V
Backup current (VCCB pin) | 1mA when the EM1000 is running (3.3V on VCC) 13uA when the EM1000 is not powered (0V on VCC)
Operating temperature | -20 to +70 degrees C
Operating relative humidity | 10-90%
Mechanical dimensions (excl. leads) | 33.4x18.1x4.2mm
Pin diameter | 0.4mm
Packaging | Tray, 30 modules/tray

* Implemented in (supported through) firmware.

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


EM200

em200-small

Important notices:

1. This device is also supplied with a non-programmable, fixed-function, ready-to-use serial device server firmware. Refer to the "Serial-over-IP Solutions Manual" for more information.

Introduction

The EM200 is a BASIC-programmable embedded module that can serve as a networking coprocessor of your "connected" device. The firmware of the EM200, called TiOS, features a virtual machine that executes your application written in Tibbo BASIC. The EM200 has no pre-defined functionality whatsoever -- programmability in Tibbo BASIC means that you can create your own unique EM200 applications!

Each hardware faculty of the EM200 is supported by a sophisticated programming "object" which you interact with from the Tibbo BASIC application. Together, objects form a "platform" that defines EM200 capabilities from the programming point of view.

The EM200 platform, along with the Tibbo BASIC language and TIDE software is described in the "TIDE and Tibbo BASIC Manual".

Hardware features

· Very compact dimensions (32.1 x 18.5 x 7.3 mm).
· One 100/10BaseT Ethernet port. Standard Ethernet magnetics are NOT integrated into the module.
· One serial ports (CMOS-level):

- The port can work in the UART, Wiegand, or clock/data mode. Support of Wiegand and clock/data interfaces is a unique feature of Tibbo devices.

- UART supports:

- baudrates of up to 115'200bps;

- none/even/odd/mark/space parity modes;

- 7/8 bits/character modes;

- full-duplex mode with optional flow control, half-duplex mode with automatic direction control.

· 128KBytes of flash memory. First 64KB are used to store device firmware (TiOS). The rest is available to your Tibbo BASIC application.
· 2KBytes of EEPROM memory.
· 9 general-purpose I/O lines.
· The following lines are additionally available:

- 2 lines for green and red status LED control;

- 2 lines for Ethernet status LED control;

- 1 line to connect the "system" button.

- External reset input.

· Device firmware can be upgraded through the serial port or Ethernet.
· Tibbo BASIC application can be uploaded and debugged through the Ethernet.

Programming features

· The following data types and related functions are supported:

- Byte and char (occupy 1 byte);

- Integer (word) and short (occupy 2 bytes);

- String, can be up to 255 characters long;

· The following function groups are supported:

- Conversion to and from strings: asc, chr, val, str, left, mid, right, len, instr, etc. (16 function in total);

· The following objects form the EM200 platform:

- Sockets (sock.) object -- supports up to 16 simultaneous UDP or TCP connections, or HTTP sessions;

- Ethernet (net.) object -- controls Ethernet interface;

- Serial (ser.) object -- supports UART, Wiegand, and clock/data modes;

- Input/output (io.) object -- handles I/O lines;

- EEPROM (stor.) object -- facilitates access to the EEPROM memory;

- ROM data (romfile.) object -- provides access to the fixed ("ROM") data of your Tibbo BASIC application;

- LED pattern (pat.) object -- "plays" patterns on Green and Red Status LEDs;

- System button (btn.) object -- handles special system (MD) button;

- System (sys.) object -- controls general device functionality.


I/O Pin Assignment and Pin Functions

EM200- pin assignment

The information on various hardware faculties of the EM200 can be found in the following topics:

· Ethernet Port Lines
· Serial Port and General-purpose I/O Lines
· Flash and EEPROM Memory
· LED Lines
· Power, Reset, and Mode Selection Lines

I/O pin assignment

Pin # | Function | Description
1 | EG | Green Ethernet status LED control line.
2 | EY | Yellow Ethernet status LED control line.
3 | RX+ | Ethernet port, positive line of the differential input signal pair.
4 | RX- | Ethernet port, negative line of the differential input signal pair.
5 | 3.3Vout | "Clean" 3.3V power for magnetics circuitry.
6 | TX+ | Ethernet port, positive line of the differential output signal pair.
7 | TX- | Ethernet port, negative line of the differential output signal pair.
8 | GPIO8 | General-purpose I/O line 8.
9 | GPIO7 | General-purpose I/O line 7.
10 | GPIO6 | General-purpose I/O line 6.
11 | GPIO1 | General-purpose I/O line 1.
12 | GPIO0 | General-purpose I/O line 0.
13 | VCC | Positive power input, 5V nominal, +/- 5%, max. current consumption 50mA
14 | GND | System ground.
15 | GPIO3/DTR(1) | General-purpose I/O line 3; conventionally also DTR output line of the serial port.
16 | GPIO2/DSR(2) | General-purpose I/O line 2; conventionally also DSR output line of the serial port.
17 | TX/W1out/dout(1) | TX, W1, and dout output of the serial port.
18 | RX/W1in/din(1) | RX, W1, and din input of the serial port.
19 | GPIO4/CTS/W0&1in/cin(1) | General-purpose I/O line 4; also CTS, W0&1, and cin input of the serial port.
20 | GPIO5/RTS/W0out/cout(1) | General-purpose I/O line 5; also RTS, W0, and cout output of the serial port.
21 | SG | Green status LED control line.
22 | SR | Red status LED control line.
23 | RST | Reset line, active high.
24 | MD | Mode selection pin.


Ethernet Port Lines

Ethernet port of the EM200 is of 100/10BaseT type. Onboard electronics of the EM200 do not include Ethernet magnetics, so magnetic circuitry must be connected externally. You can use either a standalone magnetics part (such as YCL-PH163112) or RJ45 connector with integrated magnetics (for example, YCL-PTC1111-01G). Drawings below show circuit diagrams for both parts.

Please, note the following:

· The 3.3Vout is an output that provides clean power for the magnetics circuitry, which is very sensitive to noise.
· Do not combine 3.3Vout with the VCC (main power) pin. This is counter-productive and will cause FCC/CE certification issues.

It is important to make the PCB traces connecting the Ethernet port pins of the EM200 to the magnetics circuitry as short as possible. Making the wires too long may cause the noise level generated by your PCB to surpass the maximum radiated emission limits stipulated by the FCC and CE regulations. Additionally, longer Ethernet lines on the PCB will make your board more susceptible to the ESD (electrostatic discharge) damage.


Serial Port and General-purpose I/O Lines

The EM200 features a serial port (RX, TX lines), plus nine general-purpose I/O lines (GPIO0-8). All of the above lines are of CMOS type. Maximum load current for each I/O line is 10mA.

The serial port of the EM200 can work in one of the three modes: UART, Wiegand, or clock/data. All three modes are described in detail in the documentation for the serial (ser.) object found inside the "TIDE and Tibbo BASIC Manual". Additionally, see the Platform-dependent Programming Information" section inside the EM200 platform documentation (same manual).

Simplified structure of EM200's I/O lines is shown on the circuit diagram below. All lines are "quasi-bidirectional" and can be viewed as open collector outputs with weak pull-up resistor. There is no explicit direction control. To "measure" an external signal applied to a pin the OUT line must first be set to HIGH. It is OK to drive the pin LOW externally when the pin outputs HIGH internally.

I/O line control is described in detail in the documentation for the I/O (io.) object found inside the "TIDE and Tibbo BASIC Manual".


Flash and EEPROM Memory

The EM200 has 128KBytes of flash memory and 2KBytes of EEPROM memory.

Half of the flash memory (64KB) is used to store the TiOS firmware. When you are performing a firmware upgrade it is this memory you are saving the firmware binary into.

The second half of the flash (64KB) is available to your Tibbo BASIC application.

The EEPROM is almost fully available to your application, save for a small 8-byte area called "special configuration area". The EEPROM is accessed through the storage (stor.) object (see "TIDE and Tibbo BASIC Manual"). Details on the special configuration area are provided in the Platform-dependent Programming Information section inside the EM200 platform documentation (same manual).


LED Lines

The EM200 has four LED control lines -- SG, SR, EG, and EY. All lines have the same internal structure and the LEDs should be connected to these lines as shown on the schematic diagram below. Maximum load for each line is 10mA.

Further information on status LEDs can be found in Appendix 1: Status LEDs.


Power, Reset, and Mode Selection Lines

The EM200 should be powered from a stabilized DC power supply with nominal output voltage of 5V (+/- 5% tolerance). Current consumption of the EM200 is approximately 220mA (in 100BaseT mode). Providing an adequate power supply is very important -- poorly built circuit may affect EM200 operation. We recommend that you use a switching power supply circuit. One (but not the only) example of such circuit is shown below.

Proper external reset is a must! Reset pulse should be an active HIGH. We strongly advise against using low-cost RC-networks and other unreliable methods of generating reset pulse. Reset should be applied for as long as the power supply voltage is below 4.6V. We recommend using a dedicated reset IC with brownout detection, such as MAX810. Reset pulse length should be no less than 50ms, counting from the moment the power supply voltage exceeds 4.6V.

If the EM200 is used to serve as a communications co-processor in a larger system that has its own CPU it is also OK to control the RST line of the EM200 through a general-purpose I/O pin of the "host" microcontroller. I/O pins of many microcontrollers default to HIGH after the powerup and this means that proper reset will be applied to the EM200 when the host device is switched on. All the host microcontroller has to do is release the EM200 from reset at an appropriate time by switching the state of the I/O line to LOW.

The function of the MD line is described in Appendix 2: Setup Button (MD line).

Power supply circuit

Many power supply circuits will work well. The one below is being used by Tibbo. The circuit can handle input voltages in the 9-30V range.

Notes:

· U1 (MC35063) is a very popular power IC manufactured by ON Semiconductor.
· R1 is very important. It is just 1 (one!) Ohm, but we really do not recommend the user to omit it.
· R2 and R3 are "1% tolerance" (high-precision) because they define the output voltage of the power supply.
· C1 and C3 capacitors: Do not use SMD capacitors -- use regular through-hole aluminum capacitors. This really helps reduce noise produced by the power supply.
· This is an analog circuit, so layout matters. Apply reasonable "good layout" effort.

Ideally, one should use an oscilloscope to see what sort of "square wave" the power supply generates, both at low and high input voltages, as well as light and heavy loads. R1 can be adjusted to achieve a better (cleaner) square wave signal on a particular PCB layout. There are no recipes here -- just try and see what works for your circuit.


Mechanical Dimensions

L | Max. | 32.1 | Module length
W | Max. | 18.5 | Module width
H | Max. | 7.3 | Module height
I | Min. | 2.2 | Lead length
m | Max. | 0.5 | Lead "flash"
d | Aver. | 28.0 | Distance between lead rows
p | Aver. | 1.27 | Pin pitch

Dimensions are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


Ordering Info and Specifications

The EM200 has two sub-models in circulation- the EM200-00 and EM200-01. The EM200-01 is a RoHS-compliant version of the EM200-00. There are no other differences between these two versions. Currently, only the EM200-01 is being manufactured.

Specifications

Ethernet interface | 100/10BaseT Ethernet, magnetics not built-in
Serial ports | 1 port; UART, Wiegand(1), and clock/data(1) modes
UART capabilities | Baudrates up to 115'200bps; none/even/odd/mark/space parity and 7/8 bits/char.; full-duplex UART mode with optional flow control(1) and half-duplex UART mode with automatic direction control(1); RX, TX, RTS(1), CTS(1), DTR(1), and DSR(1) lines provided.
Number of I/O lines | 9 (TX and RX lines of the serial port are not included into this count)
Max. load current for each I/O line | 10mA
Flash memory | 128KBytes, 64KB available for your Tibbo BASIC application
EEPROM memory | 2048 bytes, 2040 bytes available to store application data
Supported network protocols(1) | UDP(1), TCP(1), ICMP (ping)(1), and HTTP(1). Other protocols (such as DHCP) are implemented as Tibbo BASIC functions.
Number of simultaneous UDP or TCP (HTTP) connections(1) | 16(1)
Nominal power supply voltage (VCC pin) | DC 5V, +/- 5%
Max. operating current | 220mA
Device temperature during operation(2) | 55 degrees C
Operating temperature | -10 to +70 degrees C
Operating relative humidity | 10-90%
Mechanical dimensions (excl. leads) | 32.1x18.5x7.3mm
Pin diameter | 0.4mm
Packaging | EM200-01: tube, 10 modules/tube EM200-B-01: tray, 30 modules/tray

Notes:

1. Actually a feature of TiOS firmware.
2. Measured at 22 degrees C ambient temperature, in the non-enclosed environment.

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


Boards

The following boards and board families are currently being offered by Tibbo:

· NB10x0 and IB100x Boards
· DS1206N
· EM1202EV
· EM1206EV
· EM120/EM200-EV


NB10x0 and IB100x Boards

The NB10x0 and IB100x boards offered by Tibbo allow you to quickly create a BASIC-programmable communication, control, or data acquisition system from a set of standard components. A pair of boards -- one network board ("NB"), and one interface board ("IB") -- form a complete system, as shown on the drawing below. Both boards have the same outline dimensions.

The "NB" hosts the EM1000 BASIC-programmable embedded module and acts as a "connected brain" of your system. The network board carries a 3.3V switching power regulator. This 3.3V power is provided to the interface board as well.

The "IB" implements all necessary I/O functionality. You can choose a standard board manufactured by Tibbo or create your own interface board containing just the right mix of I/O circuitry required for your project.

The network board and the interface board are joined together by an IC1000 interboard cable. The wiring of this cable is standard and allows you to connect any "NB" board to any "IB" board. One IC1000 cable is provided with each "NB" board (but not with "IB" boards).

Where the required I/O components cannot fit on the interface board alone, a supplementary board ("SB") is used. The supplementary board sits on top of the interface board and can be almost as large as the latter (see here for mechanical spec). Connections (connectors) between the interface board and the supplementary board are not standardized and are implemented as needed for a particular "IB" + "SB" combination. There is no direct connection between the supplementary board and the network board.

To indicate various system states, there are LB100x LED boards. Each LB100x board accommodates up to 11 LEDs. A typical system uses two standard LED boards -- the LB1000 on the "NB" side, and the LB1001 on the "IB" side. LED boards connect to "NB" and "LB" boards by a flat LC1000 cable. Network and interface boards have mounting holes for optionally attaching LB100x boards to them. A custom-made "brass offset" part BP1000 is used for the purpose. LED boards can also be mounted independently. Ordering any "NB" or "IB" board also gets you an LED board and LC1000 cable, which will come attached to said "NB" or "LB" board.

Tibbo NB10x0 and IB100x boards can be used "as is" or with a stylish, industrial-grade housing -- the DS10xx series industrial controllers are based on these boards as well. Same boards are also used in the EM1000-EV evaluation kit.


NB10x0 Network Boards

At the moment, only one model of the network board is being offered:

· NB1000


NB1000 Board

The NB1000 board is based on the EM1000 embedded module.

The NB1000 product includes the LB1000 LED board. The NB1000 and the LB1000 come assembled together and interconnected by the LC1000 cable. Additionally, the NB1000 comes with the IC1000 interboard cable. Therefore, you don't need to order the LB1000, LC1000, or IC1000 separately when purchasing the NB1000 board.


NB1000 Connectors and Controls

Refer to the following topics to learn more about the NB1000:

· Power Jack, Terminals, and Power Regulator
· Ethernet Jack
· Jumpers, Buttons, and LEDs
· External LED Control
· Buzzer


Power Jack, Terminals and Power Regulator

Power jack of the NB1000 accepts "small" power connectors with 3.5mm diameter. Use 12VDC/1A APR-P0008 (APR-P0009, or APR-P0010) power adaptor supplied by Tibbo or similar adaptor. On the power jack, the ground is "on the outside", as shown on the figure below.

Another way to connect power is through the power terminals located next to the power jack. Ground and "+" terminal positions are shown on the general NB1000 drawing. Acceptable supply power range is 10-18VDC (12VDC nominal).

The NB1000 carries an onboard 3.3V switching power regulator that provides stabilized power to the NB1000 itself and to an IB100x interface board, connected to the NB1000 via the IC1000 interboard cable.

Note, that the IC1000 interboard cable also has lines that carry "raw" input power (Vin lines). The IB100x board you are using may have its own power supply.


Ethernet Jack

RJ45 Ethernet jack has the standard pin assignment:

#1 | TX+
#2 | TX-
#3 | RX+
#4 | <No connection>
#5 | <No connection>
#6 | RX-
#7 | <No connection>
#8 | <No connection>


Jumpers, Buttons and LEDs

PLL jumper

Leave this jumper open if you want the EM1000 onboard the NB1000 to run at full speed (88.4736MHz). Close the jumper if you want the EM1000 to run at 1/8th the full speed (11.0592MHz). Notice, that the jumper state is only recognized after the power-up or external reset (caused by pressing the reset button). The PLL mode can also be changed programmatically. For more information see Power, Reset, PLL Control, and Mode Selection Lines topic of the EM1000 documentation.

MD jumper and mode button

The function of the mode button is described in Appendix 2: Setup Button (MD line). On the NB1000 board, MD jumper is connected in parallel with the button.

US jumper

This jumper selects the serial port of the EM1000 that will be used for firmware upgrades. When the jumper is opened, serial port 1 is used (pins RX0 and TX0 of the EM1000). When the jumper is closed, debug serial port is used (pins DBGRX and DBGTX of the EM1000). TX0 and RX0 lines of the EM1000 go straight to the IC1000 interboard cable connector. The NB100x board must implement necessary serial port hardware to make serial upgrades through the serial port 1 possible (NB100x boards usually do have this hardware). DBGRX and DBGTX lines are available on the debug serial port connector of the NB1000 (not documented yet). These lines are of 3.3V CMOS type (5V tolerant), so they can't be connected to your PC's serial port directly.

Reset button

This button is connected to the RST pin of the EM1000. Pressing this button causes an "external" reset.

Ethernet Status LEDs

These are yellow and green LEDs connected to the EY and EG pins of the EM1000. Further information on status LEDs can be found in Appendix 1: Status LEDs.


External LED Control

The NB1000 is intended to be used with the LB1000 board. This board provides:

· Green and red LED pair.
· Green and yellow LED pair.
· LED bar comprising five yellow LEDs.

Green and red LED pair -- system status indication

These LEDs are controlled by the SG and SR pins of the EM1000. Further information on status LEDs can be found in Appendix 1: Status LEDs.

Green and yellow LED pair -- Ethernet status indication

These LEDs are connected to the same EG and EY lines of the EM1000 that control green and yellow LEDs on the NB1000 board itself.

LED bar -- wireless signal strength indication

Five yellow LEDs of the LED bar are intended primarily for the indication of the RF signal strength (i.e. when the GA1000 Wi-Fi add-on module board is installed). These LEDs are controlled through three GPIO lines of the EM1000- GPIO46, GPIO47, and GPIO48.

GPIO46 is the reset line of the LED bar. Clearing this line sets all five outputs to LOW and this turns all LEDs ON. GPIO47 is a clock line- a positive (LOW-to-HIGH) transition on this line "shifts in" the data on the GPIO48 line. The circuit that controls the LEDs is shown below. LED numbers correspond to numbers shown on the LB100x drawing.

led bar control

If you want to switch an LED ON then set the data line LOW. The data bit for the LED#1 (indicating the highest signal strength) is clocked in first. That's the short explanation. In further detail, we can say:

· GPIO 48 is the Data line; set it to the state that you wish the LED to be in, LOW = ON, HIGH = OFF.
· When you then pull GPIO 47 (Clock line) from its normal state (HIGH) to LOW and then back to HIGH, the state of the Data line is read in and used for LED1.
· If you want to turn on LED2 (for example) you have to set GPIO 48 to LOW, toggle the clock once (HIGH-LOW-HIGH) which would set LED1 ON, set GPIO48 to HIGH (because you want LED1 off) and then just toggle the clock again (HIGH-LOW-HIGH). At this point, the state of LED1 would shift to LED2 (so LED2 would light up).

So assuming that all LEDs are OFF and each row means that we have toggled through one clock cycle:

Clock cycle | Data | LED1 | LED2 | LED3 | LED4 | LED5
1 | LOW | ON | OFF | OFF | OFF | OFF
2 | LOW | ON | ON | OFF | OFF | OFF
3 | HIGH | OFF | ON | ON | OFF | OFF
4 | LOW | ON | OFF | ON | ON | OFF
5 | HIGH | OFF | ON | OFF | ON | ON

As you can see, each clock cycle sets a new state for LED1 which directly corresponds to the state of the Data line, and shifts all previous LED states.


Buzzer

The buzzer of the NB1000 is connected to the GPIO45/CO line of the onboard EM1000.

Your application can control the buzzer through the "beeper" (beep.) object (see "TIDE and Tibbo BASIC Manual"). Recommended value for the beep.divider property is 21600.


Ordering Info and Specifications

Model number | Description
NB1000-04 | The NB1000 board with the EM1000-1024K-S module, IB1000 interboard connector, and LB1000 LED board mounted on the NB1000 and connected to the latter with the LC1000 cable.

Hardware specifications

Ethernet interface | 10/100BaseT Ethernet, Auto-MDIX, magnetics not built-in
Supply voltage range | 10-18VDC
Operating temperature | -30 to +80 degrees C
Operating relative humidity | 10-90%
Board dimensions | 76x85mm

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


IB100x Interface Boards

The following IB100x series interface boards are currently available:

· IB1000 (4 RS232 ports)
· IB1002 (4 RS232/422/485 ports)
· IB1003 (4 isolated RS232/422/485 ports)
· IB1004 + SB1004 (8 A/D inputs, 4 D/A outputs, 2 low-power relays, 1 RS232/485 port)
· IB1005 + SB1005 (8 opto-isolated digital inputs, 6 high-power relays, 1 RS232/485 port)


IB1000, IB1002, and IB1003 (4 Serial Ports)

The IB1000, IB1002, and IB1003 interface boards provide 4 RS232 ports:

· The IB1000 has 4 non-isolated RS232 ports.
· The IB1002 has 4 non-isolated universal ports that can work in RS232, RS422, and RS485 modes.
· The IB1003 (shown below) has 4 electrically isolated universal ports that can work in RS232, RS422, and RS485 modes.

These boards can optionally be used with the TB1000 terminal block adaptor.


Connectors and Headers

IB1000/2/3 boards carry two DB9-M connectors onboard. Two additional connectors attach (via cables) to two 2x5 pin headers located on the boards.

DB-9M connectors

Pin # | RS232 mode | RS422 mode (IB1002/3 only) | RS485 mode (IB1002/3 only)
1 | --- | RTS- (output) | ---
2 | RX (input) | RX- (input) | RX- (input)
3 | TX (output) | TX+ (output) | TX+ (output)
4 | DTR (output) | TX- (output) | TX- (output)
5 | SYSTEM GROUND | SYSTEM GROUND | SYSTEM GROUND
6 | DSR (input) | RX+ (input) | RX+ (input)
7 | RTS (output) | RTS+ (output) | ---
8 | CTS (input) | CTS+ (input) | ---
9 | --- | CTS- (input) | ---

Pin headers

Pin # | RS232 mode | RS422 mode (IB1002/3 only) | RS485 mode (IB1002/3 only)
1 | --- | RTS- (output) | ---
2 | RX (input) | RX- (input) | RX- (input)
3 | TX (output) | TX+ (output) | TX+ (output)
4 | DTR (output) | TX- (output) | TX- (output)
5 | SYSTEM GROUND | SYSTEM GROUND | SYSTEM GROUND
6 | DSR (input) | RX+ (input) | RX+ (input)
7 | RTS (output) | RTS+ (output) | ---
8 | CTS (input) | CTS+ (input) | ---
9 | --- | CTS- (input) | ---
10 | --- | --- | ---


Serial Ports

The serial ports of the IB1000/2/3 are controlled by the EM1000 module (located on the NB10x0 network board).

Tibbo BASIC application running on the EM1000 works with serial ports through a "serial" (ser.) object (see "TIDE and Tibbo BASIC Manual"). The object takes care of the data transmission through the TX line as well as data reception through the RX line. When the flow control of a serial port is enabled (ser.flowcontrol= 1- ENABLED), the serial object also handles RTS and CTS lines of this port automatically.

With flow control disabled, the CTS and RTS lines can be controlled by the application as general-purpose I/O lines (GPIO). The DTR and DSR lines of ports are always treated as GPIO, the serial object does not "touch" them. Actually, even TX and RX lines of each port can be controlled as GPIO lines, but this is only possible when the corresponding serial port is "closed" (ser.enabled= 0- NO). I/O line control is effected through another object called the "I/O" (io.) object.

The IB1002 and IB1003 boards have universal RS232/422/485 ports. Two interface selection lines -- HD/FD and RS_MODE -- are provided for each port and connected to GPIO lines of the EM1000:

· The HD/FD line selects half-duplex (LOW) or full-duplex (HIGH) mode for the serial port.
· The RS_MODE line selects "physical" signal mode: RS232 (LOW) or RS422/485 (HIGH).

To select RS232, RS422, or RS485 mode for a serial port, setup the HD/FC and RS_MODE lines as shown in the table below. Ser.interface property of the serial object must also be set correctly:

Mode | HD/FD | RS_MODE | ser.interface
RS232 | HIGH | LOW | 0- PL_SER_SI_FULLDUPLEX
RS422 | HIGH | HIGH | 0- PL_SER_SI_FULLDUPLEX
RS485 | LOW | HIGH | 1- PL_SER_SI_HALFDUPLEX

The RS485 mode is half-duplex, which means that only the transmission or reception can occur at any given time. In this mode, the RTS line is used for direction control, which is handled by the EM1000 automatically. The RTS line should be LOW for data input, and HIGH for data output. This is achieved by setting the ser.dircontrol= 0- PL_SER_DCP_LOWFORINPUT.

Do not forget that all lines of the EM1000 are configured as inputs by default. Any line that should work as an output must be configured as such. This is done through the io.enabled property of the i/o object. The only exceptions are the TX and RX lines. The TX line automatically becomes an output, and the RX line automatically becomes an output once the serial port is enabled (ser.enabled= 1- YES).

The HD/FD and RS_MODE lines have pull-up and pull-down resistors respectively. On startup the HD/FD line defaults to HIGH (full-duplex mode), and the RS_MODE line defaults to LOW (RS232 mode).

Serial port 1

Line | Corresponding EM1000 I/O | IC1000 cable line
RX (input) | GPIO8/RX0 | 17
TX (output) | GPIO9/TX0 | 19
CTS (input) | GPIO16/CTS0 | 33
RTS (output) | GPIO0/RTS0 | 1
DSR (input) | GPIO20/DSR0 | 41
DTR (output) | GPIO4/DTR0 | 9
HD/FD* | GPIO32 | 30
RS_MODE* | GPIO33 | 28

*IB1002 and IB1003 boards only

Serial port 2

Line | Corresponding EM1000 I/O | IC1000 cable line
RX (input) | GPIO10/RX1 | 21
TX (output) | GPIO11/TX1 | 23
CTS (input) | GPIO17/CTS1 | 35
RTS (output) | GPIO1/RTS1 | 3
DSR (input) | GPIO21/DSR1 | 43
DTR (output) | GPIO5/DTR1 | 11
HD/FD* | GPIO34 | 26
RS_MODE* | GPIO35 | 24

*IB1002 and IB1003 boards only

Serial port 3

Line | Corresponding EM1000 I/O | IC1000 cable line
RX (input) | GPIO12/RX2 | 25
TX (output) | GPIO13/TX2 | 27
CTS (input) | GPIO18/CTS2 | 37
RTS (output) | GPIO2/RTS2 | 5
DSR (input) | GPIO22/DSR2 | 45
DTR (output) | GPIO6/DTR2 | 13
HD/FD* | GPIO36 | 22
RS_MODE* | GPIO37 | 20

*IB1002 and IB1003 boards only

Serial port 4

Line | Corresponding EM1000 I/O | IC1000 cable line
RX (input) | GPIO14/RX3 | 29
TX (output) | GPIO15/TX3 | 31
CTS (input) | GPIO19/CTS3 | 39
RTS (output) | GPIO3/RTS3 | 7
DSR (input) | GPIO23/DSR3 | 47
DTR (output) | GPIO7/DTR3 | 15
HD/FD* | GPIO38 | 18
RS_MODE* | GPIO39 | 16

*IB1002 and IB1003 boards only


LED Control

The IB1000 works with the standard LB1001 LED board and controls the LEDs through 8 general-purpose I/O (GPIO) lines of the EM1000 module (installed on the NB10x0 network board). To turn the LED on, set the corresponding line LOW. Do not forget to configure LED control lines as outputs. This is done through the io.enabled property of the .io object (see "TIDE and Tibbo BASIC Manual").

LED #, color (LB1001) | Corresponding EM1000 I/O | IC1000 cable line
#8, red | GPIO24 | 46
#7, green | GPIO25 | 44
#6, red | GPIO26 | 42
#5, green | GPIO27 | 40
#4, red | GPIO28 | 38
#3, green | GPIO29 | 36
#2, red | GPIO30 | 34
#1, green | GPIO31 | 32


Ordering Info and Specifications

Model number | Description
IB1000-02 | The IB1000 board and LB1001 LED board mounted on the IB1000 and connected to the latter with the LC1000 cable. The TB1000 terminal block adaptor is not included with this product.
IB1002-00 | The IB1002 board and LB1001 LED board mounted on the IB1002 and connected to the latter with the LC1000 cable. Also included is the TB1000 terminal block adaptor.
IB1003-00 | The IB1002 board and LB1001 LED board mounted on the IB1002 and connected to the latter with the LC1000 cable. Also included is the TB1000 terminal block adaptor.

Hardware specifications

Serial port lines | RS232 mode: RX, TX, CTS, RTS, DSR, DTR RS422 mode (IB1002/3): RX+/-, TX+/-, CTS+/-, RTS+/- RS485 mode (IB1002/3): RX+/-, TX+/-
Baudrate | Up to 460800bps
Operating temperature | -30 to +80 degrees C
Operating relative humidity | 10-90%
Board dimensions | 76x85mm

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


IB1004 and SB1004 (Analog I/O)

Featuring 8 analog inputs and 4 analog outputs, the IB1004 + SB1004 board combination is ideally suited for industrial (building) control and data acquisition applications. Additional relays and the RS232/485 serial port further expand product capabilities. To improve reliability and conversion precision, the A/D and D/A portions each have their own power/ground domains that are fully isolated from the rest of the circuitry.

The IB1004 is the main board in the pair, and is connected to an NB10x0 network board by the IB1000 interboard cable. The SB1004 is a supplementary board, it exists because a single IB1004 would not be able to accommodate all required circuitry and terminal blocks. In the board pair, the IB1004 carries the A/D converter, while the SB1004 contains the D/A converter, RS232/485 port, and 2 low-power relays.

The IB1004 and SB1004 are not meant to be used separately and should always be ordered together.

The IB1004 product includes the LB1001 LED board. The IB1004 and the LB1001 come assembled together and interconnected by the LC1000 cable. Therefore, you don't need to order the LB1001 and LC1000 separately when purchasing the IB1004 board.

All I/O lines of the IB1004 + SB1004 are grouped into four terminal blocks (two per board), with 9 terminals in each block. The boards are controlled by the EM1000 module located on the NB10x0 board. More information on specific IB1004 + SB1004 functionality is found in the Detailed Information section.

To simplify testing and evaluation of the product use the TB1004 test board.


Terminal blocks

The IB1004 and the SB1004 have four terminal blocks in total, two on each board. There are nine terminals in each terminal block.

· All A/D inputs are grouped into terminal blocks 1 and 2.
· All D/A outputs are on terminal block 3.
· Relay outputs and the serial port are on terminal block 4.

Terminal block 1

Terminal # | Function
9 | A/D channel 4, negative input (-)
8 | A/D channel 4, positive input (+)
7 | A/D channel 3, negative input (-)
6 | A/D channel 3, positive input (+)
5 | A/D channel 2, negative input (-)
4 | A/D channel 2, positive input (+)
3 | A/D channel 1, negative input (-)
2 | A/D channel 1, positive input (+)
1 | A/D GROUND (isolated from the rest of the device)

Terminal block 2

Terminal # | Function
9 | A/D channel 8, negative input (-)
8 | A/D channel 8, positive input (+)
7 | A/D channel 7, negative input (-)
6 | A/D channel 7, positive input (+)
5 | A/D channel 6, negative input (-)
4 | A/D channel 6, positive input (+)
3 | A/D channel 5, negative input (-)
2 | A/D channel 5, positive input (+)
1 | A/D GROUND (isolated from the rest of the device)

Terminal block 3

Terminal # | Function
9 | D/A channel 4, current output
8 | D/A channel 4, voltage output
7 | D/A channel 3, current output
6 | D/A channel 3, voltage output
5 | D/A channel 2, current output
4 | D/A channel 2, voltage output
3 | D/A channel 1, current output
2 | D/A channel 1, voltage output
1 | D/A GROUND (isolated from the rest of the device)

Terminal block 4

Terminal # | Function
9 | Relay 2, normally opened line
8 | Relay 2, normally closed line
7 | Relay 2, common line
6 | Relay 1, normally opened line
5 | Relay 1, normally closed line
4 | Relay 1, common line
3 | Serial port: TX (RS232); TX/RX+ (RS485)
2 | Serial port: RX (RS232); TX/RX- (RS485)
1 | SYSTEM (COMMON) GROUND


Control Lines

The following lines of the EM1000 module (located on the NB10x0 network board) are used to control the IB1004 + SB1004.

In the tables below, "output" means an output of the EM1000, and "input" means an input of the EM1000.

A/D converter control

For more information see A/D Converter.

Line | Function | Corresponding EM1000 I/O | IC1000 cable line
DI (input) | Serial data in | GPIO12 | 25
DO (output) | Serial data out | GPIO13 | 27
CLOCK (output) | Serial clock (LOW idle state) | GPIO2 | 5
C/D (output) | Register selection: HIGH - data register LOW - control register | GPIO40 | 6
RFS (output) | Receive frame sync (Active LOW) | GPIO32 | 30
TFS (output) | Transmit frame sync (active LOW) | GPIO33 | 28
CHS0 (output) | Channel selection, bit 0 | GPIO41 | 8
CHS1 (output) | Channel selection, bit 1 | GPIO42 | 10
CHS2 (output) | Channel selection, bit 2 | GPIO43 | 12

D/A converter control

For more information see D/A Converter.

Line | Function | Corresponding EM1000 I/O | IC1000 cable line
DATA (output) | Serial data out | GPIO11 | 23
CLOCK (output) | Serial clock (LOW idle state) | GPIO1 | 3
WR (output) | Data latch strobe (active LOW) | GPIO34 | 26
EN (output) | Output enable: HIGH (or input*) - disabled LOW - enabled | GPIO35 | 24

*GPIO line configured as input (default state)

Relay control

For more information see Relays.

Line | Function | Corresponding EM1000 I/O | IC1000 cable line
RELAY1 (output) | Relay 1 control: HIGH (or input*) - relay off LOW - relay on | GPIO36 | 22
RELAY2 (output) | Relay 2 control: HIGH (or input*) - relay off LOW - relay on | GPIO37 | 20

*GPIO line configured as input (default state)

RS232/485 port control

For more information see RS232/485 Port.

Line | Function | Corresponding EM1000 I/O | IC1000 cable line
RX (input) | Receive line of the serial port | GPIO8/RX0 | 17
TX (output) | Transmit line of the serial port | GPIO9/TX0 | 19
MODE (output) | Mode selection: HIGH - RS485 LOW (or input*) - RS232 | GPIO44 | 14
DIR (output) | Direction control in RS485 mode: HIGH - output LOW - input | GPIO0/RTS0 | 1

*GPIO line configured as input (default state)

LED control

For all LED control lines:

HIGH (or input*) - LED off

LOW - LED on

For more information see LED Control.

LED #, color (LB1001) | Corresponding EM1000 I/O | IC1000 cable line
#8, red | GPIO24 | 46
#7, green | GPIO25 | 44
#6, red | GPIO26 | 42
#5, green | GPIO27 | 40
#4, red | GPIO28 | 38
#3, green | GPIO29 | 36
#2, red | GPIO30 | 34
#1, green | GPIO31 | 32

*GPIO line configured as input (default state)


Detailed Information

The IB1004 + SB1004 include the following blocks:

· A/D converter (8 channels, 24 bits, based on the 24-bit AD7712 converter).
· D/A converter (4 channels, 14 bits, with separate voltage and current outputs, based on the 14-bit AD7836 converter).
· Two low-current mechanical relays (both normally-opened and normally-closed terminals are provided).
· RS232/485 port (RX/TX signals for the RS232, TX/RX+ and TX/RX- for the RS485).
· Control lines for 8 LEDs on the LB1001 board.


A/D Converter

The A/D converter is based on the Analog Devices' 24-bit AD7712 chip and has 8 independent channels.

Each channel has two differential input lines. Maximum input range is +/-10V. The range can be adjusted to 1/2, 1/4, ... 1/128 of that by programming the internal gain of the A/D circuit to 2, 4, ...128. With the gain of 1 and with bipolar mode selected , applying +10V to the A/D input produces the conversion result of "all 1's". Applying -10V produces "all 0's". Applying 0V produces "1" followed by 0's (this is a "middle" value). Of course, this explanation is idealized as it doesn't take into account inevitable conversion errors.

The A/D converter is designed for relatively slow, but highly accurate measurements. With recommended configuration (see below), the converter will produce 250 measurements/second for any selected channel. Only one channel can be selected at any given time.

The A/D converter has full galvanic isolation from the rest of the IB1004 + SB1004 circuitry: the power for the A/D section is generated by an isolated switching power supply, all control lines use opto-couplers.

A/D inputs

The A/D converter inputs are available on terminal blocks 1 and 2.

Terminal block 1:

Terminal # | Function
9 | A/D channel 4, negative input (-)
8 | A/D channel 4, positive input (+)
7 | A/D channel 3, negative input (-)
6 | A/D channel 3, positive input (+)
5 | A/D channel 2, negative input (-)
4 | A/D channel 2, positive input (+)
3 | A/D channel 1, negative input (-)
2 | A/D channel 1, positive input (+)
1 | A/D GROUND (isolated from the rest of the device)

Terminal block 2:

Terminal # | Function
9 | A/D channel 8, negative input (-)
8 | A/D channel 8, positive input (+)
7 | A/D channel 7, negative input (-)
6 | A/D channel 7, positive input (+)
5 | A/D channel 6, negative input (-)
4 | A/D channel 6, positive input (+)
3 | A/D channel 5, negative input (-)
2 | A/D channel 5, positive input (+)
1 | A/D GROUND (isolated from the rest of the device)

A/D control lines

Nine lines of the EM1000 (located on the NB10x0 network board) control the A/D converter. In the table below, "output" means an output of the EM1000, and "input" means an input of the EM1000:

Line | Function | Corresponding EM1000 I/O | IC1000 cable line
DO (output) | Serial data out | GPIO13 | 27
DI (input) | Serial data in | GPIO12 | 25
CLOCK (output) | Serial clock (LOW idle state) | GPIO2 | 5
C/D (output) | Register selection: HIGH - data register LOW - control register | GPIO40 | 6
RFS (output) | Receive frame sync (Active LOW) | GPIO32 | 30
TFS (output) | Transmit frame sync (active LOW) | GPIO33 | 28
CHS0 (output) | Channel selection, bit 0 | GPIO41 | 8
CHS1 (output) | Channel selection, bit 1 | GPIO42 | 10
CHS2 (output) | Channel selection, bit 2 | GPIO43 | 12

The A/D converter has a 24-bit configuration register, and a 24-bit data register that contains the A/D conversion result. These registers are accessed through the serial interface consisting of 5 I/O lines:

· Two lines -- RFS and TFS -- are used for selecting the transaction type. Inactive state for these signals is HIGH. The RFS line must be set LOW prior to the read transaction and remain LOW for the entire transaction duration. The TFS line must be set LOW prior to the write transaction and remain LOW for the entire transaction duration.
· The CLOCK line is used both for writing to and reading from the converter. The inactive state for this line is LOW. Each read and write "transaction" consists of 24 clock pulses, after which the clock returns to the LOW state. Alternatively, the IC can be programmed for 16-bit resolution, in which case each transaction will consist of 16 pulses.
· The DO line is for sending the data to the converter (writing to the configuration register). Each data bit must be placed on the DO line while the CLOCK is LOW. This means that the first, most significant bit, of data must be placed on the DO line before the first clock pulse of the transaction. Switching the CLOCK from LOW to HIGH will latch the bit into the converter.
· The DI line serves double purpose. Before the RFS line is brought LOW, the DI input indicates whether new measurement data is ready. The DI line is HIGH while the converter is not ready, and goes LOW when the new data becomes available. After the RFS line is brought LOW, the DI is used to receive the data from the converter (read the data register). The most significant bit of the readout is present on the DI line right after the RFS becomes LOW. The converter will output next data bit on every HIGH to LOW transition on the CLOCK line. We recommend that your application records the data while the CLOCK line is HIGH.
· The C/D line defines whether the data is exchanged with the configuration register (C/D is LOW), or data register that contains the conversion result (C/D is HIGH). The C/D line must remain stable (HIGH or LOW) for the entire duration of the transaction.

Read and write "transactions" are illustrated on the diagram below.

The A/D converter has 8 inputs and three control lines -- CHS2, CHS1, and CHS0 -- are used to select the channel. Only one channel can be selected at any given time.

Preparing to communicate with the A/D converter

Before you start exchanging data with the A/D converter you need to configure certain GPIO lines of the EM1000 as outputs. These lines are CLOCK, DO, C/D, TFS, RFS, CHS0, CHS1, and CHS2. In other words, all lines except DI must be configured as outputs.

Writing to the configuration register

Follow these steps to write to the configuration register:

· Set the C/D line LOW to indicate that the configuration register access will take place.
· Set the TFS line LOW to indicate that this will be a write operation (RFS must remain HIGH).
· Place the value of the most significant bit of the configuration word on the DO line.
· Set the CLOCK line HIGH.
· Set the CLOCK line LOW. This will conclude the first clock pulse.
· Generate 23 additional clock pulses, every time setting the next bit on the DO line while the CLOCK is at LOW.
· Set the TFS line HIGH. The write is complete.

A/D converter initialization

If you refer to the data sheet for the AD7712 you will find that there are many configuration options. Without resorting to reprinting the data sheet, we provide the following brief info:

bit23 | bit22 | bit21 | bit20 | bit19 | bit18 | bit17 | bit16 | bit15 | bit14 | bit13 | bit12
MD2 | MD1 | MD0 | G2 | G1 | G0 | CH | PD | WL | X | BO | BU
bit11 | bit10 | bit9 | bit8 | bit7 | bit6 | bit5 | bit4 | bit3 | bit2 | bit1 | bit0
FS11 | FS10 | FS9 | FS8 | FS7 | FS6 | FS5 | FS4 | FS3 | FS2 | FS1 | FS0

· The MD2-0 field is set to 000 for normal operation or 001 for self-calibration. There are also other configuration modes available, but they are not supported by the IB1004.
· The G2-0 field defines the gain of the A/D. The signal measured by the A/D is pre-amplified according to this gain. Writing 000 will select the gain of 1, 001- the gain of 2,... 111- the gain if 128.
· The CH field selects the channel and has to be set to 1 for the IB1004 to work properly. This channel selection should not be confused with the IB1004 input channel selector described above.
· The PD power down bit should be at 0.
· The WL word length bit should be at 0 for 16-bit resolution (sufficient for most applications), or at 1 for 24-bit resolution.
· The BO burnout current bit should be at 0.
· The B/U bit should be at 0 to select bipolar operation.
· The FS11-0 filter selection bits that should be set according to the requirements of your application. We often use the value of 4E Hex. Read page 10 of the IC's datasheet and you will find out that this corresponds with the data rate of 250Hz (times/second) and the effective resolution of 15 bits. We choose this as a good compromise between the speed and resolution. We choose the resolution of 15 bits because the D/A portion of the product has the resolution of 14 bits.

To initialize the A/D converter, write the desired configuration word on startup. For the 15-bit effective resolution described above write the hex value of 22004E. This will set up the converter and kick-off a self-calibration process (see below).

Optional self-calibration

The A/D converter will operate at a better precision if you calibrate it first. Set bits MD2-0 of the configuration register to 001 to start self-calibration. Self-calibration, as the name implies, is an automatic process that does not require any external intervention. The calibration takes time. To determine when the calibration is over, poll the DI line after writing to the configuration register:

· Once the TFS line goes HIGH marking the end of the write transaction, the DI line starts indicating the status of the converter.
· The DI line will be HIGH while the converter is still busy.
· The DI line will become LOW when the calibration is finished.

There is no need to set MD2-0= 000 after the calibration -- this happens automatically. So, in effect, your entire A/D converter setup may consist of writing 22004E Hex (or other suitable configuration word) and waiting for the DI to become LOW.

Changing channels

Follow these steps to change the channel:

· If the desired channel is not selected yet, select it by manipulating control lines CHS2-0. Code 000 selects the channel 1, 001- channel 2, ... 111- channel 8.
· After the channel change, discard the results of the first conversion. This is because the channel change may result in the wrong measurement. The second measurement will contain correct data. Alternatively, your program can wait the time equal to two A/D measurement periods. Conversion period is related to the filter setting. For the filter set at 250Hz, the conversion period is 1/250Hz=4ms. So, the application needs to wait for 8ms before correct data for the newly selected channel becomes available.

Receiving A/D conversion result

The data register of the A/D converter is updated at the conversion rate (for our recommended setting, 1/250Hz=4ms). So, the new measurement result is available every 4ms. You are always reading the most recent conversion result.

The readout can only start when the A/D converter is ready. Starting the read transaction when the converter is not ready will produce invalid data (you will read "all zeroes" or "all ones"). Follow this algorithm to perform the read:

· While the RFS line is at HIGH, read the state of the DI line. If the line is HIGH, then the A/D converter is not ready and you need to wait.
· Keep polling the DI line until it becomes LOW. This will indicate that the read transaction can be started.
· Set C/D line HIGH to indicate that the data register access will take place.
· Set the RFS line LOW to indicate that this will be a read operation (TFS must remain HIGH).
· Set the CLOCK line HIGH and record the state of the DI line -- this is the value of the most significant bit.
· Set the CLOCK LOW -- this concludes the first clock cycle.
· Perform 23 or 15 more clock cycles (depending on the value you set in the WL bit of the configuration register), every time recording the state of the DI line when the CLOCK is it HIGH.
· Set the RFS line HIGH. The read is complete.

Remember that the "effective resolution" discussed above has nothing to do with the number of bits you are supposed to read from the converter. This number is either 24 or 16, depending on the WL bit of the configuration register.

Clock speed limitations

The A/D converter is optically isolated from the rest of the device, so there are opto-couplers on all interface lines. Opto-couplers are relatively slow devices. This imposes a limit on how fast the clock line can be toggled. The minimum clock period is 200us. Both half-periods must be at least 100uS long. This means, that the conversion result can be obtained in 200uS*24=4.8ms or 200uS*16=3.2ms.


D/A Converter

The D/A converter is based on the Analog Devices' 14-bit AD7836 chip and has 4 independent output channels with 14-bit resulution. Each of the four channels have independent voltage and current output lines (both can be used at the same time if needed).

Each channel has two outputs: one voltage and one current output. The voltage outputs have +/-10V range (20mA max load). Writing all 1's (14 of them) into the D/A channel produces the maximum positive level on the voltage output (+10V nominal), writing all 0's produces the maximum negative level on the voltage output (-10V nominal). Writing a "middle" binary value of "10000000000000" (that's 1 followed by 13 zeroes) produces a 0V output. Of course, this explanation is idealized as it doesn't take into account inevitable conversion errors.

The output current range on the current output is 0-20mA. An external 4-15V power source is required for current outputs to work. Writing all 1's into the D/A channel results the maximum output current. Writing a middle value (10000000000000B) results in zero current. Writing any value below that still produces zero current. Hence, the actual resolution of the current output is not 14, but 13 bits.

The D/A converter has full galvanic isolation from the rest of the IB1004 + SB1004 circuitry: the power for the D/A section is generated by an isolated switching power supply, all control lines use opto-couplers.

D/A outputs

All D/A-related lines are available on a 9-pin terminal block #3:

Terminal # | Function
9 | D/A channel 4, current output
8 | D/A channel 4, voltage output
7 | D/A channel 3, current output
6 | D/A channel 3, voltage output
5 | D/A channel 2, current output
4 | D/A channel 2, voltage output
3 | D/A channel 1, current output
2 | D/A channel 1, voltage output
1 | D/A GROUND (isolated from the rest of the device)

D/A control

Four lines of the EM1000 (located on the NB10x0 network board) control the D/A converter. In the table below, "output" means an output of the EM1000, and "input" means an input of the EM1000:

Line | Function | Corresponding EM1000 I/O | IC1000 cable line
DATA (output) | Serial data | GPIO11 | 23
CLOCK (output) | Serial clock (LOW idle state) | GPIO1 | 3
WR (output) | Data latch strobe (active LOW) | GPIO34 | 26
EN (output) | Output enable: HIGH (or input*) - disabled LOW - enabled | GPIO35 | 24

*GPIO line configured as input (default state)

The D/A converter control cycle consists of the following steps. First, a 16-bit data word is serially clocked into the D/A circuit. Bits 15 and 14 of the data word select the output channel, remaining 14 bits carry desired output value. The word is sent most significant bit first.

Two lines -- CLOCK and DATA -- are used for sending the data word to the D/A converter. Inactive state for the CLOCK line is LOW. Each write transaction consists of 16 clock pulses. With each LOW-to-HIGH transition on the CLOCK line, the state of the DATA line is latched into the D/A converter. The process is illustrated below.

Once all 16 bits have been clocked in, the negative pulse on the WR line sets new data and the new analog value appears on the outputs of the corresponding D/A channel (provided that the EN lines is at low).

The EN line is used for enabling the analog outputs of the D/A converter. The system powers up with EN line pulled HIGH internally. This disables the D/A converter and produces 0V (0mA) on its outputs. Taking the EN line LOW will enable the D/A. Before that, your application should write the desired value into each D/A channel. Failure to do so will result in the unknown voltage (current) output levels once the EN line is set LOW.

Remember that you need to configured all four control lines of the EM1000 as outputs.

Clock speed limitations

The D/A converter is electrically isolated from the rest of the device, so there are opto-couplers on all interface lines. Opto-couplers are relatively slow devices. This imposes a limit on how fast the clock line can be toggled. The minimum clock period is 200us. Both half-periods must be at least 100uS long. The minimum pulse width on the WR line is also 100uS. This means that the new value can be output to the converter in 200uS*16+100=3.3ms.


Relays

The IB1004 + SB1004 has two low-power mechanical relays.

These relays can only handle relatively light loads -- they are rated for 24V/1A. If your load is inductive in nature, then the power the relays can handle may actually be several times lower.

Relay outputs

Relay outputs are on terminal block #4. Both normally closed and normally opened lines are provided for each relay.

Terminal # | Function
9 | Relay 2, normally opened line
8 | Relay 2, normally closed line
7 | Relay 2, common line
6 | Relay 1, normally opened line
5 | Relay 1, normally closed line
4 | Relay 1, common line
3 | Serial port: RX (RS232); TX/RX+ (RS485)
2 | Serial port: TX (RS232); TX/RX- (RS485)
1 | SYSTEM (COMMON) GROUND

Relay control

Two lines of the EM1000 (located on the NB10x0 network board) control the relays. On power up, all EM1000 lines are configured as inputs and pulled up internally, keeping relays off. To turn the relay on, set the corresponding control line LOW. Naturally, you need to configure these GPIO lines as outputs in order to be able to control the relays.

Line | Function | Corresponding EM1000 I/O | IC1000 cable line
RELAY1 (output) | Relay 1 control: HIGH (or input*) - relay off LOW - relay on | GPIO36 | 22
RELAY2 (output) | Relay 2 control: HIGH (or input*) - relay off LOW - relay on | GPIO37 | 20

*GPIO line configured as input (default state)


RS232/485 Port

There is a simple serial port that supports both RS232 and RS485 modes. The port operates through two signal terminals. In the RS232 mode, these are RX and TX, in the RS485 mode -- RX/TX+ and RX/TX-. There is no provision for flow control (RTS and CTS lines are not present), or RS422 interface.

The serial port can be used, for instance, to connect to another IB100x board. In the RS232 mode, the serial port can also be used to update the firmware of the EM1000 module located on the NB10x0 board.

Port lines

Serial port lines are on terminal block #4:

Terminal # | Function
9 | Relay 2, normally opened line
8 | Relay 2, normally closed line
7 | Relay 2, common line
6 | Relay 1, normally opened line
5 | Relay 1, normally closed line
4 | Relay 1, common line
3 | Serial port: TX (RS232); TX/RX+ (RS485)
2 | Serial port: RX (RS232); TX/RX- (RS485)
1 | SYSTEM (COMMON) GROUND

Serial port control

Four lines of the EM1000 module (located on the NB10x0 board) control the serial port:

Line | Function | Corresponding EM1000 I/O | IC1000 cable line
RX (input) | Receive line of the serial port | GPIO8/RX0 | 17
TX (output) | Transmit line of the serial port | GPIO9/TX0 | 19
MODE (output) | Mode selection: HIGH - RS485 LOW (or input*) - RS232 | GPIO44 | 14
DIR (output) | Direction control in RS485 mode: HIGH - output LOW - input | GPIO0/RTS0 | 1

*GPIO line configured as input (default state)

Do not forget to configure the TX, MODE, and DIR lines as outputs. A pull-down resistor on the MODE line ensures that the system boots up with the RS232 port selected.


LED Control

The IB1004 works with a standard LB1001 board and controls the LEDs through 8 general-purpose I/O (GPIO) lines of the EM1000 module (installed on the NB10x0 network board). To turn the LED on, set the corresponding line LOW. Remember to configure all LED control lines as outputs.

For all LED control lines:

HIGH (or input*) - LED off

LOW - LED on

LED #, color (LB1001) | Corresponding EM1000 I/O | IC1000 cable line
#8, red | GPIO24 | 46
#7, green | GPIO25 | 44
#6, red | GPIO26 | 42
#5, green | GPIO27 | 40
#4, red | GPIO28 | 38
#3, green | GPIO29 | 36
#2, red | GPIO30 | 34
#1, green | GPIO31 | 32

*GPIO line configured as input (default state)


Ordering Info and Specifications

Use the following model numbers to order the IB1004 and SB1004 boards. Normally, you will want to order both boards "in parallel":

IB1004-00 | The IB1004 board and LB1001 LED board mounted on the IB1004 and connected to the latter with the LC1000 cable. Also included is the TB1004 test board.
SB1004-00 | The SB1004 supplementary board. Order this board "in parallel" with the IB1004.

Note: the IB1004 and SB1004 plug into each other. No soldering is required to interconnect them.

Hardware specifications

A/D channels | 8 channels, 24-bit resolution
D/A channels | 4 channels, voltage and current output, 14-bit resolution
Relays | 2 relays, 24V/1A
Serial port lines | RS232 mode: RX, TX RS485 mode: RX+/-, TX+/-
Baudrate | Up to 460800bps
Operating temperature | -30 to +80 degrees C
Operating relative humidity | 10-90%
Dimensions | 76x85mm

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


IB1005 and SB1005 (Digital I/O)

Featuring 8 opto-isolated inputs and 6 relay outputs, the IB1005 + SB1005 board combination is perfect for automation, security, access control, and monitoring applications. An additional RS232/485 port further expands product capabilities.

The IB1005 is the main board in the pair, and is connected to an NB10x0 network board by the IB1000 interboard cable. The SB1005 is a supplementary board, it exists because a single IB1005 would not be able to accommodate all required circuitry and terminal blocks. In the board pair, the IB1005 carries isolated digital inputs and the RS232/485, while the SB1005 contains all relays.

The IB1005 and SB1005 are not meant to be used separately and should always be ordered together.

The IB1005 product includes the LB1001 LED board. The IB1005 and the LB1001 come assembled together and interconnected by the LC1000 cable. Therefore, you don't need to order the LB1001 and LC1000 separately when purchasing the IB1005 board.

All I/O lines of the IB1005 + SB1005 are grouped into four terminal blocks (two per board), with 9 terminals in each block. The boards are controlled by the EM1000 module located on the NB10x0 board. More information on specific IB1005 + SB1005 functionality is found in the Detailed Information section.

To simplify testing and evaluation of the product use the TB1005 test board.


Terminal Blocks

The IB1005 and the SB1005 have four terminal blocks between them. There are nine terminals in each block.

· The serial port and sensor input lines are grouped into terminal blocks 1 and 2.
· All relay outputs are on terminal blocks 3 and 4.

Terminal block 1

Terminal # | Function
9 | Sensors 3 and 4, positive line (+)
8 | Sensor 4, negative line (-)
7 | Sensor 3, negative line (-)
6 | Sensors 1 and 2, positive line (+)
5 | Sensor 2, negative line (-)
4 | Sensor 1, negative line (-)
3 | Serial port: RX (RS232); TX/RX- (RS485)
2 | Serial port: TX (RS232); TX/RX+ (RS485)
1 | SYSTEM (COMMON) GROUND

Terminal block 2

Terminal # | Function
9 | Sensor 8, positive line (+)
8 | Sensor 8, negative line (-)
7 | Sensor 7, positive line (+)
6 | Sensor 7, negative line (-)
5 | Sensor 6, positive line (+)
4 | Sensor 6, negative line (-)
3 | Sensor 5, positive line (+)
2 | Sensor 5, negative line (-)
1 | Vin (connected to the power input of the NB10x0)

Terminal block 3

Terminal # | Function
9 | Relay 3, normally closed line
8 | Relay 3, normally opened line
7 | Relay 3, common line
6 | Relay 2, normally closed line
5 | Relay 2, normally opened line
4 | Relay 2, common line
3 | Relay 1, normally closed line
2 | Relay 1, normally opened line
1 | Relay 1, common line

Terminal block 4

Terminal # | Function
9 | Relay 6, normally closed line
8 | Relay 6, normally opened line
7 | Relay 6, common line
6 | Relay 5, normally closed line
5 | Relay 5, normally opened line
4 | Relay 5, common line
3 | Relay 4, normally closed line
2 | Relay 4, normally opened line
1 | Relay 4, common line


Control Lines

The following lines of the EM1000 module (located on the NB10x0 network board) are used to communicate with the IB1005 + SB1005.

In the tables below, "output" means an output of the EM1000, and "input" means an input of the EM1000.

Opto-isolated inputs

For more information see Opto-isolated Inputs.

Line | Function | Corresponding EM1000 I/O | IC1000 cable line
I1 (input) | Data line for input 1 W0&1 input for Wiegand reader 1 Clock input for clock/data reader 1 | GPIO17/ W0&1in1/ cin1 | 35
I2 (input) | Data line for input 2 W1 input for Wiegand reader 1 Data input for clock/data reader 1 | GPIO10/ W1in1/ din1 | 21
I3 (input) | Data line for input 3 W0&1 input for Wiegand reader 2 Clock input for clock/data reader 2 | GPIO18/ W0&1in2/ cin2 | 37
I4 (input) | Data line for input 4 W1 input for Wiegand reader 2 Data input for clock/data reader 2. | GPIO12/ W1in2/ din2 | 25
I5 (input) | Data line for input 5 | GPIO40 | 6
I6 (input) | Data line for input 6 | GPIO41 | 8
I7 (input) | Data line for input 7 | GPIO42 | 10
I8 (input) | Data line for input 8 | GPIO43 | 12
C1 (output) | Channels 1 and 2 mode: LOW - separate use or clock/data i/f HIGH - Wiegand i/f | GPIO1 | 3
C2 (output) | Channels 3 and 4 mode: LOW - separate use or clock/data i/f HIGH - Wiegand i/f | GPIO2 | 5

Relay control

For all relay control lines:

HIGH (or input*) - relay off

LOW - relay on

For more information see Relays.

Line | Function | Corresponding EM1000 I/O | IC1000 cable line
RELAY1 (output) | Relay 1 control | GPIO32 | 30
RELAY2 (output) | Relay 2 control | GPIO33 | 28
RELAY3 (output) | Relay 3 control | GPIO34 | 26
RELAY4 (output) | Relay 4 control | GPIO35 | 24
RELAY5 (output) | Relay 5 control | GPIO36 | 22
RELAY6 (output) | Relay 6 control | GPIO37 | 20

*GPIO line configured as input (default state)

RS232/485 port control

For more information see RS232/485 port.

Line | Function | Corresponding EM1000 I/O | IC1000 cable line
RX (input) | Receive line of the serial port | GPIO8/RX0 | 17
TX (output) | Transmit line of the serial port | GPIO9/TX0 | 19
MODE (output) | Mode selection: HIGH - RS485 LOW (or input*) - RS232 | GPIO44 | 14
DIR (output) | Direction control in RS485 mode: HIGH - output LOW - input | GPIO0/RTS0 | 1

*GPIO line configured as input (default state)

LED control

For all LED control lines:

HIGH (or input*) - LED off

LOW - LED on

For more information see LED Control.

LED #, color (LB1001) | Corresponding EM1000 I/O | IC1000 cable line
#8, red | GPIO24 | 46
#7, green | GPIO25 | 44
#6, red | GPIO26 | 42
#5, green | GPIO27 | 40
#4, red | GPIO28 | 38
#3, green | GPIO29 | 36
#2, red | GPIO30 | 34
#1, green | GPIO31 | 32

*GPIO line configured as input (default state)


Detailed Information

The IB1005 includes the following blocks:

· Opto-isolated inputs (8 in total, 4 can be used to connect two Wiegand or clock/data readers).
· Six high-current mechanical relays (both normally-opened and normally-closed terminals are provided).
· RS232/485 port (RX/TX signals for the RS232, TX/RX+ and TX/RX- for the RS485).
· Control lines for 8 LEDs on the LB1001 board (the board must be ordered separately).


Opto-isolated Inputs

The IB1005 features 8 opto-isolated input channels. Channels 1-4 are combined into two pairs. Channels of each pair have separate negative inputs and common positive inputs. These channels can be activated with voltages as low as 2V and accept voltages of up to 15V. Each channel pair can work as two independent sensor inputs or accept the data from an external Wiegand or clock/data card reader.

Channels 4-8 are independent and have separate negative and positive lines. These channels can be activated with voltage levels as low as 5V and accept voltages as high as 50V.

Sensor Inputs

All inputs are on terminal blocks 1 and 2.

For terminal block 1:

Terminal # | Function
9 | Sensors 3 and 4, positive line (+)
8 | Sensor 4, negative line (-)
7 | Sensor 3, negative line (-)
6 | Sensors 1 and 2, positive line (+)
5 | Sensor 2, negative line (-)
4 | Sensor 1, negative line (-)
3 | Serial port: RX (RS232); TX/RX- (RS485)
2 | Serial port: TX (RS232); TX/RX+ (RS485)
1 | SYSTEM (COMMON) GROUND

For terminal block 2:

Terminal # | Function
9 | Sensor 8, positive line (+)
8 | Sensor 8, negative line (-)
7 | Sensor 7, positive line (+)
6 | Sensor 7, negative line (-)
5 | Sensor 6, positive line (+)
4 | Sensor 6, negative line (-)
3 | Sensor 5, positive line (+)
2 | Sensor 5, negative line (-)
1 | Vin (connected to the power input of the NB10x0)

Working with inputs

The state of inputs is available on 8 general-purpose I/O (GPIO) lines of the EM1000 module (located on the NB10x0 network board). The EM1000 can check GPIO line state through the I/O (io.) object -- see "TIDE and Tibbo BASIC Manual" for details.

Line | Function | Corresponding EM1000 I/O | IC1000 cable line
I1 (input) | Data line for input 1 W0&1 input for Wiegand reader 1 Clock input for clock/data reader 1 | GPIO17/ W0&1in1/ cin1 | 35
I2 (input) | Data line for input 2 W1 input for Wiegand reader 1 Data input for clock/data reader 1 | GPIO10/ W1in1/ din1 | 21
I3 (input) | Data line for input 3 W0&1 input for Wiegand reader 2 Clock input for clock/data reader 2 | GPIO18/ W0&1in2/ cin2 | 37
I4 (input) | Data line for input 4 W1 input for Wiegand reader 2 Data input for clock/data reader 2. | GPIO12/ W1in2/ din2 | 25
I5 (input) | Data line for input 5 | GPIO40 | 6
I6 (input) | Data line for input 6 | GPIO41 | 8
I7 (input) | Data line for input 7 | GPIO42 | 10
I8 (input) | Data line for input 8 | GPIO43 | 12
C1 (output) | Channels 1 and 2 mode: LOW - separate use or clock/data i/f HIGH - Wiegand i/f | GPIO1 | 3
C2 (output) | Channels 3 and 4 mode: LOW - separate use or clock/data i/f HIGH - Wiegand i/f | GPIO2 | 5

When sufficient voltage is applied to the sensor input, the corresponding GPIO line of the EM1000 is turned LOW, otherwise the line is HIGH.

As was explained above, channels 1, 2, 3, and 4 form two input pairs that can optionally accept data from Wiegand or clock/data readers. These channels are wired into the serial ports 1 and 2 of the EM1000. The serial ports of the module have a unique ability to decode the Wiegand and clock/data streams so processing the reader data is very simple. More info can be found in the documentation for the "serial" (ser.) object ("TIDE and Tibbo BASIC Manual").

As the serial object documentation explains, accepting Wiegand data requires additional logic circuit to be connected to the EM1000. This circuit is located on the IB1005 board. Two control lines -- C1 and C2 (one for each input pair) -- enable Wiegand-compatible operation of the channels. For Wiegand readers, set the control line HIGH. For clock/data readers or independent operation of channels of the signal pair, set the line to LOW.

Note that C1 and C2 lines have to be configured as outputs.


Relays

The IB1005 + SB1005 have 6 mechanical relays. These relays are rated for 30VDC/16A or 250VAC/15A. If your load is inductive in nature, then the actual power the relays can handle may be several times lower.

Relay outputs

Relay outputs are on terminal blocks 3 and 4. Both normally closed and normally opened lines are provided for each relay.

For terminal block 3:

Terminal # | Function
9 | Relay 3, normally closed line
8 | Relay 3, normally opened line
7 | Relay 3, common line
6 | Relay 2, normally closed line
5 | Relay 2, normally opened line
4 | Relay 2, common line
3 | Relay 1, normally closed line
2 | Relay 1, normally opened line
1 | Relay 1, common line

For terminal block 4:

Terminal # | Function
9 | Relay 6, normally closed line
8 | Relay 6, normally opened line
7 | Relay 6, common line
6 | Relay 5, normally closed line
5 | Relay 5, normally opened line
4 | Relay 5, common line
3 | Relay 4, normally closed line
2 | Relay 4, normally opened line
1 | Relay 4, common line

Relay control

Six lines of the EM1000 (located on the NB10x0 network board) control the relays. On power up, all EM1000 lines are configured as inputs and pulled up internally, keeping relays off. To turn the relay on, set the corresponding control line LOW. Naturally, each relay line must be configured as output.

For all relay control lines:

HIGH (our input*) - relay off

LOW - relay on

Line | Function | Corresponding EM1000 I/O | IC1000 cable line
RELAY1 (output) | Relay 1 control | GPIO32 | 30
RELAY2 (output) | Relay 2 control | GPIO33 | 28
RELAY3 (output) | Relay 3 control | GPIO34 | 26
RELAY4 (output) | Relay 4 control | GPIO35 | 24
RELAY5 (output) | Relay 5 control | GPIO36 | 22
RELAY6 (output) | Relay 6 control | GPIO37 | 20

*GPIO line configured as input (default state)


RS232/485 Port

There is a simple serial port that supports both RS232 and RS485 modes. The port operates through two signal terminals. In the RS232 mode, these are RX and TX, in the RS485 mode -- RX/TX+ and RX/TX-. There is no provision for flow control (RTS and CTS lines are not present), or RS422 interface.

The serial port can be used, for instance, to connect to another IB100x board. In the RS232 mode, the serial port can also be used to update the firmware of the EM1000 module located on the NB10x0 board.

Serial port lines

Serial port lines are on terminal block 1:

Terminal # | Function
9 | Sensors 3 and 4, positive line (+)
8 | Sensor 4, negative line (-)
7 | Sensor 3, negative line (-)
6 | Sensors 1 and 2, positive line (+)
5 | Sensor 2, negative line (-)
4 | Sensor 1, negative line (-)
3 | Serial port: RX (RS232); TX/RX- (RS485)
2 | Serial port: TX (RS232); TX/RX+ (RS485)
1 | SYSTEM (COMMON) GROUND

Serial port control

Four lines of the EM1000 module (located on the NB10x0 board) control the serial port.

Line | Function | Corresponding EM1000 I/O | IC1000 cable line
RX (input) | Receive line of the serial port | GPIO8/RX0 | 17
TX (output) | Transmit line of the serial port | GPIO9/TX0 | 19
MODE (output) | Mode selection: HIGH - RS485 LOW (or input*) - RS232 | GPIO44 | 14
DIR (output) | Direction control in RS485 mode: HIGH - output LOW - input | GPIO0/RTS0 | 1

*GPIO line configured as input (default state)

Do not forget to configure the TX, MODE, and DIR lines as outputs. A pull-down resistor on the MODE line ensures that the system boots up with the RS232 port selected.


LED Control

The IB1005 works with a standard LB1001 board and controls the LEDs through 8 general-purpose I/O (GPIO) lines of the EM1000 module (installed on the NB10x0 network board). To turn the LED on, set the corresponding line LOW. All LED control lines have to be configured as outputs.

For all LED control lines:

HIGH (or input*) - LED off

LOW - LED on

LED #, color (LB1001) | Corresponding EM1000 I/O | IC1000 cable line
#8, red | GPIO24 | 46
#7, green | GPIO25 | 44
#6, red | GPIO26 | 42
#5, green | GPIO27 | 40
#4, red | GPIO28 | 38
#3, green | GPIO29 | 36
#2, red | GPIO30 | 34
#1, green | GPIO31 | 32

*GPIO line configured as input (default state)


Ordering Info and Specifications

Use the following model numbers to order the IB1005 and SB1005 boards. Normally, you will want to order both boards "in parallel":

IB1005-00 | The IB1005 board and LB1001 LED board mounted on the IB1005 and connected to the latter with the LC1000 cable. Also included is the TB1005 test board.
SB1005-00 | The SB1005 supplementary board. Order this board "in parallel" with the IB1005.

Note: the IB1005 and SB1005 plug into each other. No soldering is required to interconnect them.

Hardware specifications

Opto-isolated inputs | 8 channels: - channels 1-4: 2V-15V input range, can be used to connect card readers - channels 5-8: 5-50V input range
Relays | 6 relays, 30VDC/16A or 250VAC/15A
Serial port lines | RS232 mode: RX, TX RS485 mode: RX+/-, TX+/-
Baudrate | Up to 460800bps
Operating temperature | -30 to +80 degrees C
Operating relative humidity | 10-90%
Dimensions | 76x85mm

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


LB100x LED Boards

The following LED boards are currently supplied as standard.

· LB1000 (for NB10x0 network boards).
· LB1001 (for IB100x interface boards).


LB1000

The LB1000 is a standard LED board supplied with NB10x0 network boards. Table below shows LED arrangement for this board. LED numbers correspond to the numbers shown on the mechanical drawing for the LB1000. LED control is described in the External LED Control topic of the NB1000 documentation.

LED # | Color | Series Resistor value (Ohm) | Function
#8 | Green | 0(1) | Status LED, connected to the SG line of the EM1000(3)
#7 | Red | 0(1) | Status LED, connected to the SR line of the EM1000(3)
#11 | --- | --- | <not installed>
#6 | Green | 220 | Ethernet status LED, connected to the EG line of the EM1000
#5 | Yellow | 220 | Ethernet status LED, connected to the EY line of the EM1000
#10 | --- | --- | <not installed>
#4(2) | Yellow | 220 | Signal strength bar, #1 (the lowest level).
#3(2) | Yellow | 220 | Signal strength bar, #2.
#9(2) | Yellow | 220 | Signal strength bar, #3.
#2(2) | Yellow | 220 | Signal strength bar, #4.
#1(2) | Yellow | 220 | Signal strength bar, #5 (the highest strength).

Note 1. This resistor's value is 0 because there is another resistor connected in series with the EM1000's I/O line and located on the NB10x0 board.

Note 2. This LED is controlled through an additional "LED bar" circuit, described in the External LED Control topic.

Note 3. Further information on status LEDs can be found in Appendix 1: Status LEDs.


LB1001

The LB1001 is a standard LED board supplied with IB100x interface boards. The LEDs on the board are arranged into 4 groups, each group consisting of one green and one red LED. Although the LB1001 connects to IB100x boards, the actual control of the LEDs is effected from the EM1000 module installed on the NB10x0 board. To turn a certain LED on, set the corresponding general-purpose I/O (GPIO) line LOW. The line has to be configured as output. I/O line control is described in detail in the documentation for the "I/O" (io.) object found inside the "TIDE and Tibbo BASIC Manual". These LED's can also be used to play patterns generated by the ("pattern") .pat object. Correct "mapping" is required for this to work -- see object documentation for details.

Table below shows LED arrangement for this board. LED numbers correspond to the numbers shown on the mechanical drawing for the LB1001.

LED # | Color | Resistor value (Ohm) | Function
#8 | Red | 0(1) | Controlled by the GPIO24 of the EM1000 (pin 46 on the interboard connector header).
#7 | Green | 0(1) | Controlled by the GPIO25 of the EM1000 (pin 44 on the interboard connector header).
#11 | --- | --- | <not installed>
#6 | Red | 0(1) | Controlled by the GPIO26 of the EM1000 (pin 42 on the interboard connector header).
#5 | Green | 0(1) | Controlled by the GPIO27 of the EM1000 (pin 40 on the interboard connector header).
#10 | --- | --- | <not installed>
#4 | Red | 0(1) | Controlled by the GPIO28 of the EM1000 (pin 38 on the interboard connector header).
#3 | Green | 0(1) | Controlled by the GPIO29 of the EM1000 (pin 36 on the interboard connector header).
#9 | --- | --- | <not installed>
#2 | Red | 0(1) | Controlled by the GPIO30 of the EM1000 (pin 34 on the interboard connector header).
#1 | Green | 0(1) | Controlled by the GPIO31 of the EM1000 (pin 32 on the interboard connector header).

Note 1. This resistor's value is 0 because there is another resistor connected in series with the EM1000's GPIO line and located on the NB10x0 board.


Cable data

The following standard cables are supplied:

· IC1000 interboard cable
· LC1000 LED board cable


IC1000 Interboard Cable

NB10x0 and IB100x boards are interconnected by a 50-wire cable called the "interboard cable". This cable can be ordered as IC1000. There is a 50-pin header on each board to receive the cable end. The header type is 2x25, pitch=2.54mm. Connector pin assignment is shown below. The IC1000 length is approximately 40mm (as measured between the connectors). This cable is supplied with each NB10x0 board (but not with IB100x boards).

Note 1: indicated pin functions correspond to the pin functions of the EM1000 module (installed on the NB10x0 board). To save space, "GPIO" and "P" were omitted. For example, "17/2.1" actually means "GPIO17/P2.1". "I1" means "INT1".

Note2: not all pin functions are shown. For example, pin #2 also has "W0out/cout0" functionality which is not shown on the diagram above. Refer to EM1000 documentation for complete pin function description.


LC1000 LED Board Cable

The LB100x LED boards connect to the network board ("NB") or interface board ("IB") via the LC1000 cable. There is a connector on the LB100x, as well as "NB" and "IB" boards. Connector pin assignment is shown below. LED numbers correspond to the numbers shown on the mechanical drawing of the LB100x. Pin #1 position of the connector is also shown on the drawing.

Pin # | Function | Description
1 | VCC | 3.3V power from the "NB" ("IB").
2 | VCC | 3.3V power from the "NB" ("IB").
3 | LED8 | Cathode (-) of LED #8.
4 | LED7 | Cathode (-) of LED #7.
5 | LED11 | Cathode (-) of LED #11.
6 | LED6 | Cathode (-) of LED #6.
7 | LED5 | Cathode (-) of LED #5.
8 | LED10 | Cathode (-) of LED #10.
9 | LED4 | Cathode (-) of LED #4.
10 | LED3 | Cathode (-) of LED #3.
11 | LED9 | Cathode (-) of LED #9.
12 | LED2 | Cathode (-) of LED #2.
13 | LED1 | Cathode (-) of LED #1.
14 | GND | System ground.

Important note: For correct operation, a current-limiting resistor must be connected in series with each LED. Most I/O lines of the EM1000 (installed on the NB1000 network board) already have a current-limiting resistor, so the resistor onboard the IB100x is not always necessary. In this case, the 0 Ohm resistor is used. Documentation for specific LB100x boards provides necessary info.


Mechanical data

The following drawings are provided in this section:

· NB10x0 and IB100x board dimensions
· SB100x board dimensions
· LB100x board dimensions


NB10x0 and IB100x Board Dimensions

The NB10x0 and IB100x have the same outline dimensions. Both types of boards also feature identical 50-pin headers for the IC1000 interboard cable, as well as mounting holes for the LB1000 LED board. The only difference is that on the "IB" boards the 50-pin header is on the right, while the LB1000 mounting holes are on the left. On the "NB" boards, the pin header is on the left, while the mounting holes are located on the right.

W | Max. | 76.0 | Board width
H | Aver. | 85.0 | Board height
T | Aver. | 1.6 | Board thickness
g | Min. | 5.0 | No-component zone width
d | Aver. | 3.0 | Mounting hole diameter
m1 | Aver. | 3.0 | Distance to the board mounting hole
m2 | Aver. | 2.5 | Distance to the board mounting hole
m3 | Aver. | 22.0 | Distance to the LB100x mounting hole
m4 | Aver. | 8.5 | Distance to the LB100x mounting hole
m5 | Aver. | 50.3 | Distance to the LB100x mounting hole
m6 | Aver. | 3.2 | LB100x mounting hole dimension
m7 | Aver. | 6.0 | LB100x mounting hole, copper area diameter

Dimensions are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


SB100x Board Dimensions

The supplementary board ("SB") has the same height as the interface board ("IB"). The "SB" is narrower -- its maximum width is limited to 67mm. The limit is due to the interboard connector protruding from the side of the "IB". The "SB" does not have to have the maximum width -- it can be as short as permitted by the design.

W | Max. | 67.0 | Board width
H | Aver. | 85.0 | Board height
T | Aver. | 1.6 | Board thickness
g | Min. | 5.0 | No-component zone height
d | Aver. | 3.0 | Mounting hole diameter
m1 | Aver. | 3.0 | Distance to the board mounting hole
m2 | Aver. | 2.5 | Distance to the board mounting hole
c | Max. | 19.0 | Header & interboard cable connector height
G | Aver. | 18.5 | Gap between the IB100x and SB100x boards*

* This is the standard gap; it will "happen" automatically when the boards are used inside the DS10xx housing.

Dimensions are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


LB100x Board Dimensions

The LB100x LED board accommodates up to 11 LEDs. What LEDs are actually installed depends on the board version. See LB100x LED Boards for description of standard boards offered by Tibbo. The LB100x connects either to an NB10x0 board or IB100x board. The LC1000 flat cable is used for this.

The LB100x can be mounted independently or attached to the "NB" ("IB") board. A custom-made "brass offset" part BP1000 is used for the purpose in the latter case. The BP1000 ensures precise 3.5mm gap between the LB100x and the "NB" ("IB") board.

W | Aver. | 25.0 | Board width
H | Aver. | 75.0 | Board height
T | Aver. | 1.6 | Board thickness
m1 | Aver. | 3.7 | Distance to the board mounting hole
m2 | Aver. | 50.3 | Distance between board mounting holes
m3 | Aver. | 3.0 | Distance to the board mounting hole
m4 | Aver. | 24.6 | Distance from the board mounting hole to the LED edge
m5 | Max. | 12.5 | Distance from the LED edge to the center of the first LED
m6 | Aver. | 5.0 | Distance between LEDs
m7 | Aver. | 2.6 | Distance from the board surface to the LED center
m8 | Max. | 6.5 | LED height with respect to the board surface
G | Aver. | 3.5 | Gap between the LB100x and the bottom side of the NB10x0 (IB100x)
d | Max. | 3.0 | LED diameter

Dimensions are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


DS1206N

Introduction

The DS1206N is a BASIC-programmable board designed primarily for serial-over-IP and serial control applications. Being small enough to fit inside your product, the board offers a rapid development alternative to using modules, which require making new host PCB.

The DS1206N features a multi-channel serial port. The board has a single serial port connector and is priced as a single-port product, yet it packs four independent serial channels. Have no use for those DSR and DTR lines? Turn them into RX and TX of an additional serial channel. Don't want CTS and RTS either? That's one more channel! In total, there are 15 different configurations to choose from.

The board is supplied in three versions offering various serial port and power options (see below).

The DS1206N is fully supported by TIDE software and a dedicated DS1206 platform that covers all hardware facilities of the board (see "TIDE and Tibbo BASIC Manual"). This product ships preloaded with a fully functional serial-over-IP application. Written in Tibbo BASIC, the application is compatible with Tibbo Device Server Toolkit software, comes with full source codes, and can be modified by the user.

Available models

The board is supplied in three modifications.

The DS1206N-RS is, essentially, a DS1206 device without a housing. The board has a proper RS232 port (RS232 transceiver IC and DB9M connector), as well as the power regulator ("12V"-to-3.3V). There is also a power switch that controls "12V" power output on pin 9 of the DB9M connector.

The DS1206N-TM is different from the "-RS" version in that it has a TTL serial port and no power switch. The port is accessible through a 12-pin connector on the PCB. The power regulator of the board can be used to supply 3.3V power to the attached serial device as well.

Finally, the DS1206N-TS is like the "-TM" version but has no "12V"-to-3.3V power regulator. Instead, an attached serial device is supposed to provide stabilized 3.3V power to the board.

Available models and their features | DS1206N-RS (RS232) | DS1206N-TM (TTL master) | DS1206N-TS (TTL slave)
Setup button | YES
Status LEDs | YES
RS232 transceiver & DB9M connector | YES | NO
TTL interface connector | NO | YES
Power switch | YES | NO
Power jack and "12V"-to-3.3V regulator | YES |  | NO

Hardware features

· Superior upgrade to the EM1202EV board.
· Based on a high-performance purpose-built 88-MHz T1000 ASIC.
· 10/100BaseT auto-MDIX Ethernet port (automatic detection of "straight" and "cross" cables).
· Up to 3.5 serial channels:

- DS1206N-RS: RS232 port (DB9M connector);

- DS1206N-TM and "-TS": TTL serial port (pin header);

- Baudrates of up to 921,600bps;

- None/even/odd/mark/space parity modes;

- 7/8 bits/character modes;

- Full-duplex mode with optional flow control;

- DS1206N-TM and "-TS": half-duplex mode with direction control;

- Flexible mapping with 15 different options, such as:

- A single channel: RX, TX, CTS, RTS, DSR, and DTR lines;

- 3.5 channels: RX, TX, RX2, TX2, RX3, TX3, and RX4 lines.

- DS1206N-RS: optional "12V" power output on DB9M connector (software-controllable);

- DS1206N-TM: optional "12V" power input from the serial port (instead of supplying power through the power jack).

· 512KB or 1024KB flash memory for firmware, application, and data storage.
· 2KB EEPROM for data storage.
· Four LEDs:

- Green and red status LEDs on top of the device;

- Link and speed Ethernet status LEDs on the RJ45 jack.

· Software-controlled onboard PLL to select the clock frequency of the device: 11.0592MHz with PLL off, 88.4736MHz with PLL on.
· Power:

- DS1206N-RS and "-TM": onboard regulator, 10-24V input range (12V nominal);

- DS1206N-TS: direct 3.3V input (must be regulated to +/- 5%).

· Board dimensions: 52.6x38.0mm.
· Firmware and Tibbo BASIC application are upgradeable through the serial port or network.
· Tibbo BASIC application can be debugged through the network and no additional debugging hardware, such as in-circuit emulator, is required.
· Also available as a DS1206 (DS1206N board with housing).

Programming features

· Variable Types: Byte, char, integer (word), short, dword, long, real, string, plus ser-defined arrays and structures.
· Function Groups: Strings functions (21 in total!), date/time conversion functions, and hash calculation functions (md5 and sha1).
· Platform objects:

- Sock — socket communications (up to 16 UDP, TCP, and HTTP sessions);

- Net — controls Ethernet port;

- Ser — in charge of serial channels;

- Io — handles I/O lines, ports, and interrupts;

- Fd — manages flash memory file system and direct sector access;

- Stor — provides access to the EEPROM;

- Romfile — facilitates access to resource files (fixed data);

- Pat — "plays" patterns on green and red status LEDs;

- Button — monitors the setup button;

- Sys — in charge of general device functionality.


DS1206N Hardware

Click on one of the links provided below to learn more about the DS1206N:

· Power arrangement
· Ethernet port
· Multi-channel Serial Port
· Flash and EEPROM Memory
· Status LEDs
· Setup button


Power Arrangement

The DS1206N-RS and "-TM" devices have "12V"-to-3.3V switching regulator onboard. Conventionally, the power is supplied through the power jack. The Power Jack of the DS1206N accepts "small" power connectors with 3.5mm diameter. Use APR-P0011, APR-P0012, or APR-P0013 power adaptor supplied by Tibbo or similar adaptor with 12V nominal output voltage. Adaptor current rating should be at least 500mA. On the power jack, the ground is "on the outside", as shown on the figure below.

Alternatively, the DS1206N-RS can be powered through pin 9 of the DB9M (RS232) connector, while the DS1206N-TM can be powered through pin 2 of the TTL interface connector. Two internal diodes combine power jack and pin 9 (pin 2) inputs into a single line, which goes to the internal regulator of the DS1206N.

On the DS1206N-RS, pin 9 of the DB9M connector can also be used to provide "12V" power to an attached serial device. "12V" actually means "input power on the power jack", which is not necessarily stabilized. The power line of the jack passes through a software-controlled switch and is then connected to pin 9 through a Schottky diode (shown on the diagram below). Therefore, the voltage on pin 9 is close to the input voltage on the power jack.

Tibbo serial-over-IP application supplied with the DS1206N has a dedicated "PS" ("Power on pin 9") setting to control the power switch. To turn the power switch on from within your Tibbo BASIC application, enable (configure as output) line PL_IO_NUM8_PWROUT and then set this line to HIGH. Additional programming information can be found in "TIDE and Tibbo BASIC Manual" (see i.o object and DS1206 platform documentation).

If you want to use pin 9 to power an attached serial device, then you must power the DS1206N-RS itself through the power jack. We know you understand this, but we still had to mention it.

The DS1206N-TS board does not have "12V"-to-3.3V regulator at all. 3.3V power required for board operation must be supplied by the external device through pin 1 of the TTL interface connector.

The DS1206N-TM and "-TS" boards do not have the power switch.


Ethernet Port

Ethernet port of the DS1206N is of 10/100BaseT type.

Connector is of RJ45 type, pin assignment is as follows:

#1 | TX+
#2 | TX-
#3 | RX+
#4 | <No connection>
#5 | <No connection>
#6 | RX-
#7 | <No connection>
#8 | <No connection>

The Ethernet port of the DS1206N incorporates two Ethernet status LEDs.


Multi-channel Serial Port

The DS1206N has four serial ports internally. The DS1206N-RS has an RS232 port with DB9M connector, while "-TM" and "-TS" devices have TTL serial port available through a TTL interface connector, which is a standard pin header with 2mm pitch.

The DS1206N-RS implements three outputs and four inputs. Each of the three outputs can be used as a TX line of a serial port, or as a control output such as RTS or DTR. Each of the four input lines can be used as an RX line of a serial port, or as a control input such as CTS or DSR.

With three outputs and four inputs, the DS1206N can be said to offer 3.5 serial "channels". We say "3.5 channels" and not "four channels" because one channel will only have RX line and no TX line (remember, there are four inputs but only three outputs).

TTL interface connector pin assignment is as follows:

Pin | Name | DS1206N-TM | DS1206N-TS
#1 | 3.3V | Output to external device | Input from external device
#2 | Power | Power input/output | Not used
#3 | GND | Ground
#4 | RST | Reset input, active low, use open collector driving circuit
#5 | MD | Setup line input, active low, use open collector driving circuit
#6-12 |  | Lines of TTL serial port, see mapping table below

For more information on serial ports and I/O lines of the DS1206N see ser. and io. object manuals ("TIDE and Tibbo BASIC Manual").

Serial-over-IP application offered by Tibbo defines 15 "mapping options", or ways in which available I/O lines are utilized. These are presented in the table below:

Mapping option | Available signals | Pins on the DB9M connector of the DS1206N-RS |  |  |  |  |  |  | Missing line
 |  | #2 | #3 | #8 | #7 | #6 | #4 | #1
Option 0 | RX/TX/CTS/RTS/DSR/DTR | RX | TX | CTS | RTS | DSR | DTR | --- | ---
Option 1 | RX/TX/CTS/RTS/DSR/DTR + RX/tx | RX | TX | CTS | RTS | DSR | DTR | RX4 | tx4
Option 2 | RX/TX/CTS/RTS + RX/TX + RX/tx | RX | TX | CTS | RTS | RX3 | TX3 | RX4 | tx4
Option 3 | RX/TX/CTS/RTS + RX/TX/CTS/rts | RX | TX | CTS | RTS | RX3 | TX3 | CTS3 | rts3
Option 4 | RX/TX/CTS/RTS + RX/TX/DSR/dtr | RX | TX | CTS | RTS | RX3 | TX3 | DSR3 | dtr3
Option 5 | RX/TX/DSR/DTR + RX/TX + RX/tx | RX | TX | RX2 | TX2 | DSR | DTR | RX4 | tx4
Option 6 | RX/TX/DSR/DTR + RX/TX/CTS/rts | RX | TX | RX2 | TX2 | DSR | DTR | CTS2 | rts2
Option 7 | RX/TX/DSR/DTR + RX/TX/DSR/dtr | RX | TX | RX2 | TX2 | DSR | DTR | DSR2 | dtr2
Option 8 | RX/TX + RX/TX + RX/TX + RX/tx | RX | TX | RX2 | TX2 | RX3 | TX3 | RX4 | tx4
Option 9 | RX/TX/CTS/rts + RX/TX + RX/TX | RX | TX | RX2 | TX2 | RX3 | TX3 | CTS | rts
Option 10 | RX/TX/DSR/dtr + RX/TX + RX/TX | RX | TX | RX2 | TX2 | RX3 | TX3 | DSR | dtr
Option 11 | RX/TX/CTS/RTS + RX/tx/CTS/RTS | RX | TX | CTS | RTS | CTS4 | RTS4 | RX4 | tx4
Option 12 | RX/TX/CTS/RTS + RX/tx/DSR/DTR | RX | TX | CTS | RTS | DSR4 | DTR4 | RX4 | tx4
Option 13 | RX/TX/DSR/DTR + RX/tx/CTS/RTS | RX | TX | CTS4 | RTS4 | DSR | DTR | RX4 | tx4
Option 14 | RX/TX/DSR/DTR + RX/tx/DSR/DTR | RX | TX | DSR4 | DTR4 | DSR | DTR | RX4 | tx4
Mapping option | Available signals | #12 | #11 | #10 | #9 | #8 | #7 | #6 | Missing line
 |  | Pins on the TTL connector of the DS1206N-TM and "-TS"

"Available signals" column shows a particular combination of I/O lines for each option. For example, option 0 defines the standard serial port arrangement with RX, TX, CTS, RTS, DSR, and DTR lines. Option 2 gives you one channel with RX, TX, CTS, and RTS lines, one more channel with just RX and TX lines, and yet another channel with a single RX line. The TX line is "missing" because, once again, there are only three outputs available. This is why this line is shown in grey lowercase (tx).

Notice that on the DS1206N, pin 9 of the RS232 port can be used to power the DS1206 or provide power to an attached serial device. See Power Arrangement for details.


Flash and EEPROM Memory

The DS1206N has 512K or 1024KBytes of flash memory and 2KBytes of EEPROM memory.

The first 64KBytes of flash memory are used to store the TiOS firmware. When you are performing a firmware upgrade it is this memory you are saving the firmware binary into.

The rest of this flash memory is available to your Tibbo BASIC application and its data. Whatever memory space is left after the compiled application is loaded can be used as a flash disk (see fd. object documentation in the "TIDE and Tibbo BASIC Manual").

The EEPROM is almost fully available to your application, save for a small 8-byte area called "special configuration area". The EEPROM is accessed through the stor. object (see "TIDE and Tibbo BASIC Manual"). Details on the special configuration area are provided in the Platform-dependent Programming Information section inside the DS1206 platform documentation (same manual).


Mechanical Dimensions

L | Max. | 52.6 | Board length
W | Max. | 38.0 | Board width
l | Aver. | 2.6 | Distance from the front edge of the PCB to the front surface of the RJ45 jack, power jack, setup button
H | Max. | 17.2 | Board height with components installed on the top side of the board
t | Aver. | 1.6 | PCB thickness
d1 | Aver. | 3.6 | Mounting hole diameter
d2 | Aver. | 5.0 | LED diameter
d3 | Max. | 3.5 | Setup button diameter
m1 | Aver. | 26.0 | Horizontal distance between the mounting holes (first pair)
m2 | Aver. | 31.0 | Horizontal distance between the mounting holes (second pair)
m3 | Aver. | 14.0 | Distance from the front edge of the PCB to the first pair mounting holes
m4 | Aver. | 45.0 | Distance from the front edge of the PCB to the second pair of mounting holes
n1 | Aver. | 11.0 | PCB outline dimension
n2 | Aver. | 29.0 | PCB outline dimension
n3 | Aver. | 40.5 | Distance from the front edge of the PCB to the LEDs
n4 | Aver. | 47.0 | Distance from the front edge of the PCB to the horizontal centerline of the TTL interface connector (present on the DS1202N-TM and "-TS" only)
n5 | Aver. | 50.1 | PCB outline dimension
n6 | Aver. | 33.0 | PCB outline dimension
n7 | Aver. | 9.0 | Horizontal distance between LEDs
n8 | Aver. | 15.0 | Distance from the vertical centerline of the PCB to the vertical centerline of the power jack (present on the DS1206N-RS and "-TM" only)
n9 | Max. | 5.1 | Power jack width (the power jack is present on the EM1206N-RS and "-TM" only)
n10 | Aver. | 14.5 | Distance from the vertical centerline of the PCB to the vertical centerline of the setup button
h1 | Max. | 7.5 | Power jack height (the power jack is present on the DS1206N-RS and "-TM" only)
h2 | Aver. | 5.5 | Distance from the bottom surface of the PCB to the center of the setup button
h3 | Max. | 2.5 | Height of the tallest component on the bottom side of the PCB
h4 | Aver. | 6.2 | Distance from the bottom surface of the PCB to the centerline of the DB9M connector (present on the DS1206N-RS only)
p | Aver. | 2.0 | TTL pin header pin pitch (present on the DS1206N-TM and "-TS" only)

Dimensions are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


Ordering Info and Specifications

Device numbering scheme is as follows:

DS1206N numbering system

· "-RS" version: "true" RS232 port on the DB9M connector, power jack and "12V"-to-3.3V power regulator, optional "12V" power on pin 9 of the DB9M (software-controllable).
· "-TM" version: TTL serial port on the pin header connector, power jack and "12V"-to-3.3V power regulator.
· "-TS" version: TTL serial port on the pin header connector, direct 3.3V power input.

Examples of valid model numbers

Model number | Description
DS1206N-512K-RS-00 | DS1206N device with 512KBytes of flash memory, "-RS" version
DS1206N-1024K-TM-00 | DS1206N device with 1MB of flash memory, "-TM" version

Hardware specifications

Ethernet interface | 10/100BaseT Ethernet, Auto-MDIX
Serial ports | One serial port with 3.5 serial channels (four inputs and three outputs), optional "12V" power output on pin 9 DS1206N-...-RS: RS232 port on the DB9M connector DS1206N-...-TM, DS1206N-...-TS: TTL serial port on the pin header connector
UART capabilities | Baudrates up to 921'600bps; none/even/odd/mark/space parity and 7/8 bits/character.
Clock frequency | 11.0592MHz with PLL off 88.4736MHz with PLL on
Flash memory | 512KBytes or 1024KBytes, entire memory minus 64KB is available to store Tibbo BASIC application and data
EEPROM memory | 2048 bytes, 2040 bytes available to store application data
Supply voltage range | DS1206N-...-RS, DS1206N-...-TM: DC 10-24V (12V nominal) DS1206N-...-TS: DC 3.3V (+/- 5%)
Operating temperature | -5 to +70 degrees C
Operating relative humidity | 10-90%
Board dimensions | 52.6x38.0mm

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


EM1202EV

Introduction

The EM1202EV is a BASIC-programmable board designed primarily for serial-over-IP and serial control applications. Being small enough to fit inside your product, the board offers a rapid development alternative to using modules, which require making new host PCB. The EM1202EV can also be used to evaluate and test the EM1202 module it is based on.

The EM1202EV features a multi-channel serial port. The board has a single serial port connector and is priced as a single-port product, yet it packs four independent serial channels. Have no use for those DSR and DTR lines? Turn them into RX and TX of an additional serial channel. Don't want CTS and RTS either? That's one more channel! In total, there are 15 different configurations to choose from.

The board is supplied in three versions offering various serial port and power options (see below).

The EM1202EV is fully supported by TIDE software and a dedicated DS1202 platform that covers all hardware facilities of the board (see "TIDE and Tibbo BASIC Manual"). The EM1202 platform can be used with the board as well. This product ships preloaded with a fully functional serial-over-IP application. Written in Tibbo BASIC, the application is compatible with Tibbo Device Server Toolkit software, comes with full source codes, and can be modified by the user.

Available models

The board is supplied in three modifications.

The EM1202EV-RS is, essentially, a DS1202 device without its housing. The board has a proper RS232 port (RS232 transceiver IC and DB9M connector), a power jack and a power regulator ("12V"-to-3.3V), a pair of status LEDs on top of the board, and a setup button.

The EM1202EV-TM is different from the "-RS" version in that it has a TTL serial port and no status LEDs on top of the board. The port is accessible through a 12-pin connector on the PCB. The power regulator of the board can be used to supply 3.3V power to the attached serial device as well.

Finally, the DS1206N-TS is like the "-TM" version but has no power jack and no "12V"-to-3.3V power regulator. Instead, an attached serial device is supposed to provide stabilized 3.3V power to the board.

Available models and their features | EM1202EV-RS (RS232) | EM1202EV-TM (TTL master) | EM1202EV-TS (TTL slave)
Setup button | YES
Status LEDs (on top of the board) | YES | NO
RS232 transceiver & DB9M connector | YES | NO
TTL interface connector | NO | YES
Power jack and "12V"-to-3.3V regulator | YES |  | NO

Hardware features

· Based on the EM1202 BASIC-programmable embedded module.
· 10/100BaseT auto-MDIX Ethernet port (automatic detection of "straight" and "cross" cables).
· Up to 3.5 serial channels:

- EM1202EV-RS: RS232 port (DB9M connector);

- EM1202EV-TM and "-TS": TTL serial port (pin header);

- Baudrates of up to 921,600bps;

- None/even/odd/mark/space parity modes;

- 7/8 bits/character modes;

- Full-duplex mode with optional flow control;

- EM1202EV-TM and "-TS": half-duplex mode with direction control;

- Flexible mapping with 15 different options, such as:

- A single channel: RX, TX, CTS, RTS, DSR, and DTR lines;

- 3.5 channels: RX, TX, RX2, TX2, RX3, TX3, and RX4 lines.

· 1024KB flash memory for firmware, application, and data storage.
· 2KB EEPROM for data storage.
· Up to six LEDs:

- EM12-2EV-RS: Green and red status LEDs on top of the device;

- Green and red status LEDs on the RJ45 jack;

- Link and speed Ethernet status LEDs on the RJ45 jack.

· Software-controlled onboard PLL to select the clock frequency of the device: 11.0592MHz with PLL off, 88.4736MHz with PLL on.
· Power:

- EM1202EV-RS and "-TM": onboard regulator, 10-24V input range;

- EM1202EV-TS: direct 3.3V input (must be regulated to +/- 5%).

· Board dimensions: 52.6x38.0mm.
· Firmware and Tibbo BASIC application are upgradeable through the serial port or network.
· Tibbo BASIC application can be debugged through the network and no additional debugging hardware, such as in-circuit emulator, is required.
· Also available as a DS1202 (EM1202EV-RS board with housing).

Programming features

· Variable Types: Byte, char, integer (word), short, dword, long, real, string, plus ser-defined arrays and structures.
· Function Groups: Strings functions (21 in total!), date/time conversion functions, and hash calculation functions (md5 and sha1).
· Platform objects:

- Sock — socket communications (up to 16 UDP, TCP, and HTTP sessions);

- Net — controls Ethernet port;

- Ser — in charge of serial channels;

- Io — handles I/O lines, ports, and interrupts;

- Fd — manages flash memory file system and direct sector access;

- Stor — provides access to the EEPROM;

- Romfile — facilitates access to resource files (fixed data);

- Pat — "plays" patterns on green and red status LEDs;

- Button — monitors the setup button;

- Sys — in charge of general device functionality.


EM1202EV Hardware

Click on one of the links provided below to learn more about the EM1202EV:

· Power arrangement
· Ethernet port
· Multi-channel Serial Port
· Flash and EEPROM Memory
· Status LEDs
· Setup button


Power Arrangement

The EM1202EV-RS and "-TM" devices have "12V"-to-3.3V switching regulator onboard. The power is supplied through the power jack. The power jack of the EM1202EV accepts "small" power connectors with 3.5mm diameter. Use APR-P0011, APR-P0012, or APR-P0013 power adaptor supplied by Tibbo or similar adaptor with 12V nominal output voltage. Adaptor current rating should be at least 500mA. On the power jack, the ground is "on the outside", as shown on the figure below.

Stabilized 3.3V power used by the EM1202EV-RS and "-TM" is also available on pin 12 of the TTL interface connector. This can be used to provide power to an attached serial device.

The EM1202EV-TS board does not have "12V"-to-3.3V regulator at all. 3.3V power required for board operation must be supplied by the external device through pin 12 of the TTL interface connector.


Ethernet Port

Ethernet port of the EM1202EV is of 10/100BaseT type.

Connector is of RJ45 type, pin assignment is as follows:

#1 | TX+
#2 | TX-
#3 | RX+
#4 | <No connection>
#5 | <No connection>
#6 | RX-
#7 | <No connection>
#8 | <No connection>

The Ethernet port of the EM1202EV incorporates four LEDs (two status LEDs and two Ethernet status LEDs). The EM1202EV-RS has another pair of status LEDs located on top of the board. Two status LED pairs work in parallel.


Multi-channel Serial Port

The EM1202EV has four serial ports internally. The EM1202EV-RS has an RS232 port with DB9M connector, while "-TM" and "-TS" devices have TTL serial port available through a TTL interface connector, which is a standard pin header with 2mm pitch.

The EM1202EV implements three outputs, four inputs, and one "spare" input (CD). Each of the three outputs can be used as a TX line of a serial channel, or as a control output such as RTS or DTR. Input lines can be used as an RX line of a serial channel, or as a control input such as CTS or DSR. The spare input cannot work as an RX line. This input is not used by the serial-over-IP application supplied by Tibbo and will be largely omitted from further discussion. Your Tibbo BASIC application can always use this extra input if you require it.

With three outputs and four inputs, the EM1202EV can be said to offer 3.5 serial "channels". We say "3.5 channels" and not "four channels" because one channel will only have RX line and no TX line (remember, there are four inputs but only three outputs).

DB9M connector pin assignment:

Pin | Name | EM1202EV-RS
#1 | CD | Spare input*
#2-4, 6-9 |  | Lines of the RS232 port, see mapping table below
#5 | GND | Ground

*Not used in Tibbo serial-over-IP application. Your Tibbo BASIC program can use this line if needed.

TTL interface connector pin assignment:

Pin | Name | EM1202EV-TM | EM1202EV-TS
#1 | CD | Spare input*
#2-8 |  | Lines of TTL serial port, see mapping table below
#9 | MD | Setup line input, active low, use open collector driving circuit
#10 | RST | Reset input, active low, use open collector driving circuit
#11 | GND | Ground
#12 | 3.3V | Output to external device | Input from external device

*Not used in Tibbo serial-over-IP application. Your Tibbo BASIC program can use this line if needed.

Serial-over-IP application offered by Tibbo defines 15 "mapping options", or ways in which available I/O lines are utilized ("spare" input is not used or shown). These are presented in the table below:

Mapping option | Available signals | Pins on the DB9M connector of the EM1202EV-RS |  |  |  |  |  |  | Missing line
 |  | #2 | #3 | #8 | #7 | #6 | #4 | #9
Option 0 | RX/TX/CTS/RTS/DSR/DTR | RX | TX | CTS | RTS | DSR | DTR | --- | ---
Option 1 | RX/TX/CTS/RTS/DSR/DTR + RX/tx | RX | TX | CTS | RTS | DSR | DTR | RX4 | tx4
Option 2 | RX/TX/CTS/RTS + RX/TX + RX/tx | RX | TX | CTS | RTS | RX3 | TX3 | RX4 | tx4
Option 3 | RX/TX/CTS/RTS + RX/TX/CTS/rts | RX | TX | CTS | RTS | RX3 | TX3 | CTS3 | rts3
Option 4 | RX/TX/CTS/RTS + RX/TX/DSR/dtr | RX | TX | CTS | RTS | RX3 | TX3 | DSR3 | dtr3
Option 5 | RX/TX/DSR/DTR + RX/TX + RX/tx | RX | TX | RX2 | TX2 | DSR | DTR | RX4 | tx4
Option 6 | RX/TX/DSR/DTR + RX/TX/CTS/rts | RX | TX | RX2 | TX2 | DSR | DTR | CTS2 | rts2
Option 7 | RX/TX/DSR/DTR + RX/TX/DSR/dtr | RX | TX | RX2 | TX2 | DSR | DTR | DSR2 | dtr2
Option 8 | RX/TX + RX/TX + RX/TX + RX/tx | RX | TX | RX2 | TX2 | RX3 | TX3 | RX4 | tx4
Option 9 | RX/TX/CTS/rts + RX/TX + RX/TX | RX | TX | RX2 | TX2 | RX3 | TX3 | CTS | rts
Option 10 | RX/TX/DSR/dtr + RX/TX + RX/TX | RX | TX | RX2 | TX2 | RX3 | TX3 | DSR | dtr
Option 11 | RX/TX/CTS/RTS + RX/tx/CTS/RTS | RX | TX | CTS | RTS | CTS4 | RTS4 | RX4 | tx4
Option 12 | RX/TX/CTS/RTS + RX/tx/DSR/DTR | RX | TX | CTS | RTS | DSR4 | DTR4 | RX4 | tx4
Option 13 | RX/TX/DSR/DTR + RX/tx/CTS/RTS | RX | TX | CTS4 | RTS4 | DSR | DTR | RX4 | tx4
Option 14 | RX/TX/DSR/DTR + RX/tx/DSR/DTR | RX | TX | DSR4 | DTR4 | DSR | DTR | RX4 | tx4
Mapping option | Available signals | #6 | #5 | #4 | #3 | #7 | #8 | #1 | Missing line
 |  | Pins on the TTL connector of the EM1202EV-TM and "-TS"

"Available signals" column shows a particular combination of I/O lines for each option. For example, option 0 defines the standard serial port arrangement with RX, TX, CTS, RTS, DSR, and DTR lines. Option 2 gives you one channel with RX, TX, CTS, and RTS lines, one more channel with just RX and TX lines, and yet another channel with a single RX line. The TX line is "missing" because, once again, there are only three outputs available. This is why this line is shown in grey lowercase (tx).


Additional Information on Serial Port Lines

This topic contains information related to programming of the EM1202EV. It assumes that you are familiar with Tibbo BASIC and the concept of "platforms". Everything you need to know regarding this can be found in "TIDE and Tibbo BASIC Manual".

You can create Tibbo BASIC applications for the EM1202EV using two different platforms -- the "DS1202" platform and "EM1202" platform. The DS1202 platform can be used because the EM1202EV is, essentially, a DS1202 device without the plastic housing. The EM1202 platform can be used because the board is based on the EM1202 module.

Generally speaking, the EM1202 platform offers "more". It addresses every hardware faculty of the EM1202. The DS1202 platform is much more limited and only includes features that can be used when the EM1202 module is mounted on the EM1202EV board (inside the DS1202 device).

The biggest difference between the two platforms is in how the I/O lines are wired. The EM1202 platform defines 32 I/O lines. Half of these are not used on the EM1202EV, and the remaining lines are interconnected. Each line of the serial port (save for the "spare" line discussed previously) is connected to two GPIO lines of the EM1202. This was done to ensure more flexible mapping (see Multi-Channel Serial Port). Care should be taken to avoid enabling both outputs of the same serial port line simultaneously! This can permanently damage the EM1202. We suggest that you use GPIO8/P1.0/RX0 - GPIO14/P1.6/RX3 for actual input/output and use GPIO16/P2.0/INT0 - GPIO19/P2.3/INT3 as interrupt inputs only.

The DS1202 platform "looks" at the same hardware differently and defines fewer I/O lines. Each of the physical line pair is represented by a single GPIO line. GPIO lines of the EM1202 that are unused are not defined at all.

GPIO lines of the EM1202 platform -- two lines are connected to each serial port line, except in the case of the "spare" input |  | GPIO lines of the DS1202 platform | DB9M pin and its conventional function ("-RS") | TTL connector pin ("-TS", "-TM")
GPIO8/P1.0/RX0 | GPIO16/P2.0/INT0 | PL_IO_NUM_0_RX0_INT0 | #2 (RX input) | #6
GPIO9/P1.1/TX0 | GPIO20/P2.4/INT4 | PL_IO_NUM_1_TX0_INT4 | #3 (TX output) | #5
GPIO10/P1.2/RX1 | GPIO17/P2.1/INT1 | PL_IO_NUM_2_RX1_INT1 | #8 (CTS input) | #4
GPIO11/P1.3/TX1 | GPIO21/P2.5/INT5 | PL_IO_NUM_3_TX1_INT5 | #7 (RTS output) | #3
GPIO12/P1.4/RX2 | GPIO18/P2.2/INT2 | PL_IO_NUM_4_RX2_INT2 | #6 (DSR input) | #7
GPIO13/P1.5/TX2 | GPIO22/P2.6/INT6 | PL_IO_NUM_5_TX2_INT6 | #4 (DTR output) | #8
GPIO14/P1.6/RX3 | GPIO19/P2.3/INT3 | PL_IO_NUM_6_RX3_INT3 | #9 (RI input) | #2
--- | GPIO23/P2.7/INT7* | PL_IO_NUM_7_INT7 | #1 (CD input)* | #1*

* Spare input (see above).


Flash and EEPROM Memory

The EM1202EV has 1024KBytes of flash memory and 2KBytes of EEPROM memory.

The first 64KBytes of flash memory are used to store the TiOS firmware. When you are performing a firmware upgrade it is this memory you are saving the firmware binary into.

The rest of this flash memory is available to your Tibbo BASIC application and its data. Whatever memory space is left after the compiled application is loaded can be used as a flash disk (see fd. object documentation in the "TIDE and Tibbo BASIC Manual").

The EEPROM is almost fully available to your application, save for a small 8-byte area called "special configuration area". The EEPROM is accessed through the stor. object (see "TIDE and Tibbo BASIC Manual"). Details on the special configuration area are provided in the Platform-dependent Programming Information section inside the EM1202 and DS1202 platform documentation (same manual).


Mechanical Dimensions

L | Max. | 52.6 | Board length
W | Max. | 38.0 | Board width
l | Aver. | 2.6 | Distance from the front edge of the PCB to the front surface of the RJ45 jack, power jack, setup button
H | Max. | 17.2 | Board height with components installed on the top side of the board
t | Aver. | 1.6 | PCB thickness
d1 | Aver. | 3.6 | Mounting hole diameter
d2 | Aver. | 5.0 | LED diameter (these LEDs are present on the EM1202EV-RS only)
d3 | Max. | 3.5 | Setup button diameter
m1 | Aver. | 26.0 | Horizontal distance between the mounting holes (first pair)
m2 | Aver. | 31.0 | Horizontal distance between the mounting holes (second pair)
m3 | Aver. | 14.0 | Distance from the front edge of the PCB to the first pair mounting holes
m4 | Aver. | 45.0 | Distance from the front edge of the PCB to the second pair of mounting holes
n1 | Aver. | 11.0 | PCB outline dimension
n2 | Aver. | 29.0 | PCB outline dimension
n3 | Aver. | 40.5 | Distance from the front edge of the PCB to the LEDs (present on the EM1202EV-RS only)
n4 | Aver. | 47.0 | Distance from the front edge of the PCB to the horizontal centerline of the TTL interface connector (present on the EM1202EV-TM and "-TS" only)
n5 | Aver. | 50.1 | PCB outline dimension
n6 | Aver. | 33.0 | PCB outline dimension
n7 | Aver. | 9.0 | Horizontal distance between LEDs (present on the EM1202EV-RS only)
n8 | Aver. | 15.0 | Distance from the vertical centerline of the PCB to the vertical centerline of the power jack (present on the EM1202EV-RS and "-TM" only)
n9 | Max. | 5.1 | Power jack width (the power jack is present on the EM1202EV-RS and "-TM" only)
n10 | Aver. | 14.5 | Distance from the vertical centerline of the PCB to the vertical centerline of the setup button
h1 | Max. | 7.5 | Power jack height (the power jack is present on the EM1202EV-RS and "-TM" only)
h2 | Aver. | 5.5 | Distance from the bottom surface of the PCB to the center of the setup button
h3 | Max. | 2.5 | Height of the tallest component on the bottom side of the PCB
h4 | Aver. | 6.2 | Distance from the bottom surface of the PCB to the centerline of the DB9M connector (present on the EM1202EV-RS only)
p | Aver. | 2.0 | TTL connector pin pitch (connector present on the EM1202EV-TM and "-TS" only)

Dimensions are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


Ordering Info and Specifications

Device numbering scheme is as follows:

EM1202EV numbering system

· "-RS" version: "true" RS232 port on the DB9M connector, power jack and "12V"-to-3.3V power regulator, status LEDs on top of the device.
· "-TM" version: TTL serial port on the pin header connector, power jack and "12V"-to-3.3V power regulator.
· "-TS" version: TTL serial port on the pin header connector, direct 3.3V power input.

Examples of valid model numbers

Model number | Description
EM1202EV-RS-01 | EM1202EV device, "-RS" version
EM1202EV-TM-01 | EM1202EV device, "-TM" version

Hardware specifications

Ethernet interface | 10/100BaseT Ethernet, Auto-MDIX, magnetics not built-in
Serial ports | One serial port with 3.5 serial channels (four inputs and three outputs) DS1206N-...-RS: RS232 port on the DB9M connector DS1206N-...-TM, DS1206N-...-TS: TTL serial port on the pin header connector
UART capabilities | Baudrates up to 921'600bps; none/even/odd/mark/space parity and 7/8 bits/character.
Clock frequency | 11.0592MHz with PLL off 88.4736MHz with PLL on
Flash memory | 1024KBytes, entire memory minus 64KB is available to store Tibbo BASIC application and data
EEPROM memory | 2048 bytes, 2040 bytes available to store application data
Supply voltage range | DS1206N-...-RS, DS1206N-...-TM: DC 10-24V (12V nominal) DS1206N-...-TS: DC 3.3V (+/- 5%)
Operating temperature | -5 to +70 degrees C
Operating relative humidity | 10-90%
Board dimensions | 52.6x38.0mm

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


EM1206EV

The EM1206EV Evaluation Board offers a convenient way to test the EM1206 BASIC-programmable Ethernet module.

The board features the following components:

· The EM1206 and RJ203 modules (assembled together and soldered into the EM1206EV board).
· Connector for a wireless add-on module, such as the GA1000 Wi-Fi device (purchased separately).
· Power jack and a switching power regulator.
· Multi-channel RS232 port with three RS232 outputs and four RS232 inputs.
· Expansion connector with GND, 3.3V (Vcc), 12V (Vin), and 8 TTL I/O lines.
· Eight yellow LEDs to indicate the status of I/O lines (see RS232 port and Expansion Connector topic).
· Four jumpers to select between RS232 port and expansion connector (see RS232 port and Expansion Connector topic).
· Two buttons: setup (connected to the MD line of the EM1206), and reset (connected to the RST line).
· Green and red status LEDs (connected to SG and SR lines of the EM1206). Further information on status LEDs can be found in Appendix 1: Status LEDs.
· Buzzer (connected to the CO line of the EM1206).
· Supercapacitor (backup power source) for the RTC of the EM1206.

Board structure is further illustrated by this block diagram:


Wireless Add-on Connector

This connector is used to plug in an optional wireless add-on, such as the GA1000 Wi-Fi module, as well as other add-on modules that may be released by Tibbo in the future.

The connector has 10 pins, as shown on the drawing below. Apart from the ground and Vcc (3.3V) lines, there are eight I/O lines that are connected directly to port 1 (GPIO lines 8-15) of the EM1206.

Pin | EM1206 line | GA1000 line
#1 | GND | GND
#2 | Vcc (3.3V) | Vcc (3.3V)
#3 | GPIO15/P1.7 | CS
#4 | GPIO10/P1.2 | ---
#5 | GPIO13/P1.5 | DO
#6 | GPIO9/P1.1 | ---
#7 | GPIO11/P1.3 | RST
#8 | GPIO8/P1.0 | ---
#9 | GPIO12/P1.4 | DI
#10 | GPIO14/P1.6 | CLK

It should be noted that GPIO lines 8-15 can be used for any desired I/O purpose, not just to control a wireless add-on board. You can use this connector for your own control purposes.


Main and Backup Power

The power jack of the EM1206EV accepts "small" power connectors, 3.5mm in diameter. Use APR-P0011, APR-P0012, or APR-P0013 power adaptor supplied by Tibbo or a similar adaptor with 12V nominal output voltage. Adaptor current rating should be at least 500mA. On the power jack, the ground is "on the outside", as shown on the figure below.

Alternatively, you can power the board through the Vin line on the expansion connector. Two onboard diodes combine power jack and Vin inputs into a single line, which goes to the switching regulator. Clean 3.3V output produced by the regulator is used to power the EM1206EV board itself, the EM1206 module, and optionally an add-on board plugged into the wireless add-on connector. This 3.3V power is available on the expansion connector as well.

The following drawing illustrates this power arrangement:

The EM1206 module features an RTC and a dedicated VCCB input for providing backup power when the EM1206EV is off. On the EM1206EV, the backup power comes from a supercapacitor located on the bottom side of the board. The supercapacitor charges almost instantly and, in the absence of main power, supports the RTC for about a week.

Notice that the supercapacitor is not connected to the Vcc line directly. The VCCB pin "expects" the backup power to have a nominal voltage of 2.5V. See the Real-time Counter topic of the EM1206 manual for details.


Multi-channel RS232 Port and Expansion Connector

The EM1206 module has four serial ports (four pairs of RX and TX lines). Each of those lines can also be used as general-purpose I/O. Hence, each line can serve as a CTS, RTS, DSR, or DTR line; or play another role which is unrelated to the function of the serial port.

The I/O lines of the EM1206 module are bi-directional: each line can be programmed to work as an output or input line. On the RS232 port of the EM1206EV, however, each line has a fixed direction defined by the RS232 transceiver IC. The IC used on the EM1206EV board implements three outputs and four inputs. Therefore, only seven I/O lines of the EM1206 are connected to the RS232 port of the EM1206EV board.

Out of these seven lines, each of the three outputs can be used as a TX line of a serial port, or as a control output such as RTS, DTR, etc. Each of the four input lines can be used as an RX line of a serial port, or as a control input such as CTS, DSR, CD, etc. It can be said that the RS232 port of the EM1206EV offers 3.5 serial "channels". We say "3.5 channels" and not "four channels" because one channel will only have RX line and no TX line (remember, there are four inputs but only three outputs).

Note that all four inputs of the serial port are connected to the EM1206 module through jumpers. Jumpers are necessary to select between the RS232 port inputs and expansion connector terminals. Putting a jumper "up" selects an input from the RS232 transceiver, putting a jumper "down" selects an expansion connector line.

All eight lines are available on the expansion connector as TTL signals. When the expansion connector is used, any of these eight lines can be used as an input or output.

You can conveniently see the state of I/O lines on a bank of yellow LEDs. An LED is ON when a corresponding TTL line is HIGH. Notice that the RS232 transceiver IC inverts the signal on each line. For example, if the GPIO1/P0.1/TX/INT1 pin of the EM1206 is HIGH then the TX pin on the DB9M collector is LOW.

For more information on serial ports and I/O lines of the EM1206 see ser. and io. object manuals ("TIDE and Tibbo BASIC Manual").

Serial-over-IP application offered by Tibbo defines 15 "mapping options", or ways to utilize the available I/O lines. These are presented in the table below:

Mapping option | Available signals | Pins on the DB9M connector |  |  |  |  |  |  | Missing line
 |  | #2 | #3 | #8 | #7 | #6 | #4 | #1
Option 0 | RX/TX/CTS/RTS/DSR/DTR | RX | TX | CTS | RTS | DSR | DTR | --- | ---
Option 1 | RX/TX/CTS/RTS/DSR/DTR + RX/tx | RX | TX | CTS | RTS | DSR | DTR | RX4 | tx4
Option 2 | RX/TX/CTS/RTS + RX/TX + RX/tx | RX | TX | CTS | RTS | RX3 | TX3 | RX4 | tx4
Option 3 | RX/TX/CTS/RTS + RX/TX/CTS/rts | RX | TX | CTS | RTS | RX3 | TX3 | CTS3 | rts3
Option 4 | RX/TX/CTS/RTS + RX/TX/DSR/dtr | RX | TX | CTS | RTS | RX3 | TX3 | DSR3 | dtr3
Option 5 | RX/TX/DSR/DTR + RX/TX + RX/tx | RX | TX | RX2 | TX2 | DSR | DTR | RX4 | tx4
Option 6 | RX/TX/DSR/DTR + RX/TX/CTS/rts | RX | TX | RX2 | TX2 | DSR | DTR | CTS2 | rts2
Option 7 | RX/TX/DSR/DTR + RX/TX/DSR/dtr | RX | TX | RX2 | TX2 | DSR | DTR | DSR2 | dtr2
Option 8 | RX/TX + RX/TX + RX/TX + RX/tx | RX | TX | RX2 | TX2 | RX3 | TX3 | RX4 | tx4
Option 9 | RX/TX/CTS/rts + RX/TX + RX/TX | RX | TX | RX2 | TX2 | RX3 | TX3 | CTS | rts
Option 10 | RX/TX/DSR/dtr + RX/TX + RX/TX | RX | TX | RX2 | TX2 | RX3 | TX3 | DSR | dtr
Option 11 | RX/TX/CTS/RTS + RX/tx/CTS/RTS | RX | TX | CTS | RTS | CTS4 | RTS4 | RX4 | tx4
Option 12 | RX/TX/CTS/RTS + RX/tx/DSR/DTR | RX | TX | CTS | RTS | DSR4 | DTR4 | RX4 | tx4
Option 13 | RX/TX/DSR/DTR + RX/tx/CTS/RTS | RX | TX | CTS4 | RTS4 | DSR | DTR | RX4 | tx4
Option 14 | RX/TX/DSR/DTR + RX/tx/DSR/DTR | RX | TX | DSR4 | DTR4 | DSR | DTR | RX4 | tx4
Mapping option | Available signals | RX | TX | RX2/ CTS | TX2/ RTS | RX3/ DSR | TX3/ DTR | RX4 | TX4
 |  | Terminal blocks of the expansion connector (as marked on the EM1206EV)

"Available signals" column shows a particular combination of I/O lines for each option. For example, option 0 defines the standard serial port arrangement with RX, TX, CTS, RTS, DSR, and DTR lines. Option 2 gives you one channel with RX, TX, CTS, and RTS lines, one more channel with just RX and TX lines, and yet another channel with a single RX line. The TX line is "missing" because, once again, there are only three outputs available on the RS232 port. This is why this line is shown in grey lowercase (tx). This line, of course, is present and available on the expansion connector.


EM120/EM200-EV

The EM120/200-EV Evaluation Board offers a convenient way of testing the EM120 (which is no longer supported as a programmable device) and EM200 embedded modules. The board features the following components:

· A socket for EM120 or EM200 installation

· Power jack and a switching power regulator (12VDC-->5VDC, adaptor current rating must be no less than 500mA)

· RJ45 connector and 10/100BaseT Ethernet Magnetics (EM120 and EM200 do not have built-in magnetics)

· DB9M RS232 connector and RS232 transceiver (supported signals are RX, TX, RTS, CTS, DTR, DSR)

· Setup button (connected to the MD line of EM120/EM200)

· Two Ethernet LEDs and two status LEDs (connected to LED lines of EM120/200). Further information on status LEDs can be found in Appendix 1: Status LEDs.

· Five additional LEDs connected to lines P0, P1, P6-8 of the EM120/EM200

· 15-pin expansion connector provides access to EM120/EM200's serial and general-purpose I/O pins (therefore, all I/O lines on this connector are of TTL type)


Power Jack

Power Jack of the EM120/EM200-EV accepts "large" power connectors with 5.5mm diameter. Use APR-1014, APR-1015A, or APR-1018A power adaptor supplied by Tibbo or similar adaptor with 12V nominal output voltage. Adaptor current rating should be at least 500mA. On the power jack, the ground is "on the outside", as shown on the figure below.


Ethernet Port Pin Assignment

RJ45 Ethernet connector has the following pin assignment:

#1 | TX+
#2 | TX-
#3 | RX+
#4 | <No connection>
#5 | <No connection>
#6 | RX-
#7 | <No connection>
#8 | <No connection>


RS232 Port Pin Assignment

DB9M RS232 connector has the following pin assignment:

#1 | <No connection>
#2 | RX (input)
#3 | TX (output)
#4 | DTR (output)
#5 | Ground
#6 | DSR (input)
#7 | RTS (output)
#8 | CTS (input)
#9 | <No connection>


Expansion Connector Pin Assignment

15-pin expansion connector has the following pin assignment:

P0 | Connected to pin P0 of EM120/EM200
P1 | Connected to pin P1 of EM120/EM200
P6 | Connected to pin P6 of EM120/EM200
P7 | Connected to pin P7 of EM120/EM200
P8 | Connected to pin P8 of EM120/EM200
GND | Ground
VCC | +5V from the EM120/EM200-EV board. Available "spare" current about 50mA
RST | Reset (active high) from the EM120/EM200-EV board. The signal is generated by an onboard reset IC. The same signal is applied to pin RST of EM120/EM200
MD | Connected to the download/setup button on the EM120/EM200-EV board. The signal is connected to pin MD of EM120/EM200
DTR | Connected to pin P3(DTR) of EM120/EM200
RTS | Connected to pin P5(RTS) of EM120/EM200
TX | Connected to pin TX of EM120/EM200
RX | Connected to pin RX of EM120/EM200
CTS | Connected to pin P4(CTS) of EM120/EM200
DSR | Connected to pin P2(DSR) of EM120/EM200

Output signals that are present both on the DB9M and expansion connectors (DTR, RTS, TX) need not be switched. So, for example, the TX (output) line from the EM120/EM200 is connected to the RS232 transceiver IC and to the expansion connector. For input signals (RX, CTS, DSR) there must be a way to disconnect the RS232 transceiver IC from the EM120/EM200. Three jumpers (combined with pins RX, CTS, DSR of the expansion connector) serve this purpose.

For example, when the RX jumper is closed the RX pin of the EM120/EM200 receives a signal from the RS232 transceiver. When the jumper is opened you can use the RX pin on the expansion connector to supply a TTL RX signal from your own external board. Figure below illustrates this.

Maximum load for all CMOS-type lines (P0, P1, ... RX, TX...) is 10mA.


Development Systems

The following development systems are currently being offered by Tibbo:

· EM1000EV
· EM1000TEV
· EM500EV


EM1000EV

The EM1000-EV Evaluation System offers a convenient way of testing the EM1000 BASIC-programmable embedded module. The board features the following components:

· Metal base.
· The NB1000 network board with the EM1000 module (EM1000-512K-ST) installed on a socket.
· The IB1000 interface board with four RS232 ports.
· The IC1000 interboard cable interconnecting the NB1000 and the IB1000.
· The LB1000 LED board, which is connected to the NB1000 by the LC1000 LED board cable.
· The LB1001 LED board, which is connected to the IB1000 by the LC1000 cable.

The EM1000-EV requires 12VDC/0.5A power adaptor.


EM1000TEV

The EM1000-TEV development system has been designed to aid you in developing data terminals, data collection devices, and control equipment based on the EM1000 embedded module. Hence, the abbreviation: "TEV" stands for "terminal evaluation".

The EM1000-TEV includes the following boards:

· TEV-MB0 motherboard with EM1000-512K-ST module. The EM1000 can optionally have a GA1000 Wi-Fi slave module installed on top of it.
· TEV-KB0 keypad board with 16 keys and 4 LEDs.
· TEV-LBx display board. Three different display boards are currently supplied:

- TEV-LB0 (shown): carries 128x64, black/white WINSTAR WG12864A LCD panel (SAMSUNG S6B0108 controller);

- TEV-LB1: carries 128x96, 4-bit RITDISPLAY RGS13128096 OLED panel (SOLOMON SSD1329 controller);

- TEV-LB2: carries 176x220 AMPIRE AM176220 TFT panel (HIMAX HX8309 controller).

· TEV-IBx interface boards. Four boards can be installed at the same time, and two board kinds are currently supplied:

- TEV-IB0: RS232/422/485 serial port board (each EM1000-TEV system has two of them);

- TEV-IB1: 3 x opto-input/ 3 x relay output board (each EM1000-TEV system has two of them). Opto-inputs can optionally be used to connected a Wiegand or clock/data reader.

You can choose what display board will be installed on your EM1000-TEV. See Ordering Info for details.

The EM1000-TEV is supplied with a sophisticated Tibbo BASIC "terminal" demo application that demonstrates the use of all hardware facilities of this development system. The application implements a hypothetical data collection terminal complete with onscreen setup menus, browser interface, event log, etc. The latest version of the application can be obtained from Tibbo website.


TEV-MB0

The TEV-MB0 is a motherboard that has the EM1000 module (EM1000-512K-ST) installed on it. The EM1000 is installed on a socket. Schematic diagram of the TEV-MB0 board can be found on Tibbo website.

The TEV-MB0 motherboard also features the following:

· A switching regulator with 5V output. 5V power is provided on all connectors to other boards of the EM1000-TEV system.
· A switching regulator with 3.3V output. 3.3V power is provided on all connectors to other boards of the EM1000-TEV system and also powers the EM1000.
· MD button and jumper. Connected to the MD input of the EM1000. See Appendix 2: Setup Button (MD line) for details.
· RESET button. This is a master reset for the EM1000 module.
· Status LEDs -- for details see Appendix 1: Status LEDs.
· U/S jumper. Leave it opened.
· PLL jumper. Powering up with this jumper closed causes the EM1000 to run with the PLL off. For normal operation leave this jumper opened.


TEV-KB0

The TEV-KB0 board carries 16 keys and 4 green LEDs. The keys are arranged as a 4x4 matrix, with 4 scan lines and 4 return lines. Each scan line additionally controls one green LED. Schematic diagram of the TEV-KP0 board can be found on Tibbo website.

TEV-LBx Board Connector

The TEV-KB0 board is connected to the TEV-MB0 motherboard through a 2x12-pin connector. Each two pins of the connector are combined together for better electrical contact. Therefore, the connector effectively has 12 lines.

Pin # | Function | Keypad
1 | VIN (12V) |
2 | 5V |
3 | 3.3V |
4 | GND |
5 | GPIO24* | Scan1, LED1
6 | GPIO25* | Scan2, LED2
7 | GPIO26* | Scan3, LED3
8 | GPIO27* | Scan4, LED4
9 | GPIO28* | Return1
10 | GPIO29* | Return2
11 | GPIO30* | Return3
12 | GPIO31* | Return4

* I/O pins of the EM1000 module

Required initialization code in Tibbo BASIC application

This section assumes that you are familiar with Tibbo BASIC and TIDE software. These are documented in the "TIDE and Tibbo BASIC Manual".

For correct board operation, click Project-> Settings, and select "EM1000" or "EM1000G" platform. Additionally, click Customize to open a Customize Platform dialog. In the dialog, double-click the Keypad (kp.) Object line and choose "Enabled".

The following initialization code should also be added to your project:

kp.scanlinesmapping="24,25,26,27"

kp.returnlinesmapping="28,29,30,31"

io.num=PL_IO_NUM_24

io.enabled=YES

io.num=PL_IO_NUM_25

io.enabled=YES

io.num=PL_IO_NUM_26

io.enabled=YES

io.num=PL_IO_NUM_27

io.enabled=YES

kp.enabled=YES

All key-related events are served in the event handler for the on_kp() event. The key_code argument carries the code of the key. Keycodes of each key are indicated in parentheses on the drawing above. For example, key <5> has the code of 12Hex.

Each scan line of the keypad also controls one LED. To turn the LED on, set the corresponding scan line LOW. This will not affect the operation of the keypad.


TEV-LBx Boards

The TEV-LBx boards carry display panels. Three boards are currently supplied by Tibbo:

· TEV-LB0: carries 128x64, black/white WINSTAR WG12864A LCD panel (SAMSUNG S6B0108 controller).
· TEV-LB1: carries 128x96, 4-bit RITDISPLAY RGS13128096 OLED panel (SOLOMON SSD1329 controller).
· TEV-LB2: carries 176x220 AMPIRE AM176220 TFT panel (HIMAX HX8309 controller).

You can choose what display board will be installed on your EM1000-TEV. See Ordering Info for details.

TEV-LBx Board Connector

The TEV-LBx boards are connected to the TEV-MB0 motherboard through a 2x20-pin connector. Each two pins of the connector are combined together for better electrical contact. Therefore, the connector effectively has 20 lines.

Pin # | Function
1 | VIN (12V)
2 | 5V
3 | 3.3V
4 | GND
5 | GPIO48*
6 | GPIO47*
7 | GPIO46*
8 | GPIO39/P4.7*
9 | GPIO38/P4.6*
10 | GPIO37/P4.5*
11 | GPIO36/P4.4*
12 | GPIO35/P4.3*
13 | GPIO34/P4.2*
14 | GPIO33/P4.1*
15 | GPIO32/P4.0*
16 | GPIO44*
17 | GPIO43*
18 | GPIO42*
19 | GPIO41*
20 | GPIO40*

* I/O pins of the EM1000 module


TEV-LB0

The TEV-LB0 board carries a 128x64, black/white WINSTAR WG12864A LCD panel. This panel is based on a SAMSUNG S6B0108 controller (there are two controllers on one panel). The WG12864A does not have the contrast control, so the contrast control circuit is added externally. Additionally, there is a control line for the LCD panel's backlight. The image displayed on the panel is not visible unless the backlight is turned on.

Related datasheets, as well as the schematic diagram for the TEV-LB0 board can be found on Tibbo website.

Interconnection between the EM1000 and the panel/ contrast control/ backlight control

Pin #(1) | EM1000 I/O line | Panel
5 | GPIO48 | CTRST_SET(2)
6 | GPIO47 | BL(3)
7 | GPIO46 | EN
8 | GPIO39/P4.7 | D7
9 | GPIO38/P4.6 | D6
10 | GPIO37/P4.5 | D5
11 | GPIO36/P4.4 | D4
12 | GPIO35/P4.3 | D3, CTRST3(2)
13 | GPIO34/P4.2 | D2, CTRST2(2)
14 | GPIO33/P4.1 | D1, CTRST1(2)
15 | GPIO32/P4.0 | D0, CTRST0(2)
16 | GPIO44 | RST
17 | GPIO43 | D/I
18 | GPIO42 | R/W
19 | GPIO41 | CS2
20 | GPIO40 | CS1

(1) Pin number on the TEV-LB0 connector.

(2) The line of the contrast control circuit, not the LCD panel itself.

(3) Backlight control line.

Required initialization code in Tibbo BASIC application

This section assumes that you are familiar with Tibbo BASIC and TIDE software. These are documented in the "TIDE and Tibbo BASIC Manual".

For correct panel operation, click Project-> Settings, and select "EM1000" or "EM1000G" platform. Additionally, click Customize to open a Customize Platform dialog. In the dialog, double-click the Display Panel Type line and choose "Samsung S6B0108 (Winstar WG12864A)".

The following initialization code should also be added to your project:

lcd.iomapping="44,46,40,41,43,42,4" 'RST,EN,CS1,CS2,DI,RW,data_bus

io.num=PL_IO_NUM_46

io.enabled=YES

io.num=PL_IO_NUM_44

io.enabled=YES

io.num=PL_IO_NUM_40

io.enabled=YES

io.num=PL_IO_NUM_41

io.enabled=YES

io.num=PL_IO_NUM_42

io.enabled=YES

io.num=PL_IO_NUM_43

io.enabled=YES

lcd.width=128

lcd.height=64

lcd.rotated=NO

lcd.inverted=NO

lcd.enabled=YES

set_lcd_contrast(11)

The set_lcd_contrast() procedure should be called after the panel initialization. The procedure sets the contrast level in 16 steps -- the contrast control hardware only has 4 data lines. Therefore, the contrast level of 16 is equal to the contrast level of 0.

Here is the suggested code for this function:

Sub Set_lcd_contrast(level As Byte)

'Contrast control shares the data bus with the LCD. Initialize LCD first,

'then set the contrast (before LCD initialization the bus may be driven

'by the LCD)

'enable port, output data

io.portnum=PL_IO_PORT_NUM_4

io.portenabled=255

io.portstate=level

'generate strobe for the data register (on the LCD PCB)

io.num=PL_IO_NUM_48

io.enabled=YES

io.state=HIGH

io.state=LOW

'disable port

io.portenabled=0

End Sub

Use the following code to turn on the backlight:

io.num=PL_IO_NUM_47 'backlight

io.enabled=YES

io.state=LOW


TEV-LB1

The TEV-LB1 board carries a 128x96, 4-bit RITDISPLAY RGS13128096 OLED panel. This panel is based on a SOLOMON SSD1329 controller.

Related datasheets, as well as the schematic diagram for the TEV-LB1 board can be found on Tibbo website.

Interconnection between the EM1000 and the panel

Pin #(1) | EM1000 I/O line | Panel
5 | GPIO48 | ---
6 | GPIO47 | ---
7 | GPIO46 | ---
8 | GPIO39/P4.7 | D7
9 | GPIO38/P4.6 | D6
10 | GPIO37/P4.5 | D5
11 | GPIO36/P4.4 | D4
12 | GPIO35/P4.3 | D3
13 | GPIO34/P4.2 | D2
14 | GPIO33/P4.1 | D1
15 | GPIO32/P4.0 | D0
16 | GPIO44 | RST
17 | GPIO43 | D/C
18 | GPIO42 | R/W
19 | GPIO41 | E
20 | GPIO40 | CS

(1) Pin number on the TEV-LB1 connector.

Required initialization code in Tibbo BASIC application

This section assumes that you are familiar with Tibbo BASIC and TIDE software. These are documented in the "TIDE and Tibbo BASIC Manual".

For correct panel operation, click Project-> Settings, and select "EM1000" or "EM1000G" platform. Additionally, click Customize to open a Customize Platform dialog. In the dialog, double-click the Display Panel Type line and choose "Solomon SSD1329 (Ritdisplay RGS13128096)".

The following initialization code should also be added to your project:

lcd.iomapping="44,43,42,41,40,4" 'RST,DC,WR,RD,CS,data_bus

'(W is marked "R/W" on the schematic diagram, RD is marked "E")

io.num=PL_IO_NUM_40

io.enabled=YES

io.num=PL_IO_NUM_41

io.enabled=YES

io.num=PL_IO_NUM_42

io.enabled=YES

io.num=PL_IO_NUM_43

io.enabled=YES

io.num=PL_IO_NUM_44

io.enabled=YES

lcd.width=128

lcd.height=96

lcd.rotated=NO

lcd.inverted=NO

lcd.enabled=YES


TEV-LB2

The TEV-LB2 board carries a 176x220 AMPIRE AM176220 TFT panel. This panel is based on a HIMAX HX8309 controller. There is also a control line for panel's backlight. The image displayed on the panel is not visible unless the backlight is turned on.

Related datasheets, as well as the schematic diagram for the TEV-LB2 board can be found on Tibbo website.

Interconnection between the EM1000 and the panel/ backlight control

Pin #(1) | EM1000 I/O line | Panel
5 | GPIO48 | ---
6 | GPIO47 | BL(2)
7 | GPIO46 | ---
8 | GPIO39/P4.7 | D7
9 | GPIO38/P4.6 | D6
10 | GPIO37/P4.5 | D5
11 | GPIO36/P4.4 | D4
12 | GPIO35/P4.3 | D3
13 | GPIO34/P4.2 | D2
14 | GPIO33/P4.1 | D1
15 | GPIO32/P4.0 | D0
16 | GPIO44 | RST
17 | GPIO43 | DC
18 | GPIO42 | WR
19 | GPIO41 | RD
20 | GPIO40 | CS

(1) Pin number on the TEV-LB2 connector.

(2) Backlight control line.

Required initialization code in Tibbo BASIC application

This section assumes that you are familiar with Tibbo BASIC and TIDE software. These are documented in the "TIDE and Tibbo BASIC Manual".

For correct panel operation, click Project-> Settings, and select "EM1000" or "EM1000G" platform. Additionally, click Customize to open a Customize Platform dialog. In the dialog, double-click the Display Panel Type line and choose "Himax HX8309 (Ampire AM176220)".

The following initialization code should also be added to your project:

lcd.iomapping="44,43,42,41,40,4" 'RST,DC,WR,RD,CS,data_bus

io.num=PL_IO_NUM_44

io.enabled=YES

io.num=PL_IO_NUM_43

io.enabled=YES

io.num=PL_IO_NUM_42

io.enabled=YES

io.num=PL_IO_NUM_41

io.enabled=YES

io.num=PL_IO_NUM_40

io.enabled=YES

lcd.width=176

lcd.height=220

lcd.rotated=NO

lcd.inverted=NO

lcd.enabled=YES

Use the following code to turn on the backlight:

io.num=PL_IO_NUM_47

io.enabled=YES

io.state=LOW


TEV-IBx Boards

The TEV-IBx are interface boards. Two boards are currently supplied by Tibbo:

· TEV-IB0: RS232/422/485 serial port board (each EM1000-TEV system has two of them);
· TEV-IB1: 3 x opto-input/ 3 x relay output board (each EM1000-TEV system has two of them). Opto-inputs can optionally be used to connected a Wiegand or clock/data reader.

TEV-IBx Board Connector

The TEV-IBx boards are connected to the TEV-MB0 motherboard through a 2x10-pin connector. Each two pins of the connector are combined together for better electrical contact. Therefore, the connector effectively has 10 lines.

Each EM1000-TEV system has four interface boards and each board is controlled through one of the four serial ports of the EM1000 module.

Pin # | Port 1 | Port 2 | Port 3 | Port 4
1 | VIN (12V)
2 | 5V
3 | 3.3V
4 | GND
5 | GPIO8/RX0* | GPIO10/RX1* | GPIO12/RX2* | GPIO14/RX3*
6 | GPIO9/TX0* | GPIO11/TX1* | GPIO13/TX2* | GPIO15/TX3*
7 | GPIO16/INT0/CTS0* | GPIO17/INT1/CTS1* | GPIO18/INT2/CTS2* | GPIO19/INT3/CTS3*
8 | GPIO0/RTS0* | GPIO1/RTS1* | GPIO2/RTS2* | GPIO3/RTS3*
9 | GPIO20/INT4/DSR0* | GPIO21/INT5/DSR1* | GPIO22/INT6/DSR2* | GPIO23/INT7/DSR3*
10 | GPIO4/DTR0* | GPIO5/DTR1* | GPIO6/DTR2* | GPIO7/DTR3*

* I/O pins of the EM1000 module. Not all pin functions are shown. See EM1000 documentation for full description.


TEV-IB0

The TEV-IB0 implements one RS232/422/485 serial port. The port is built around SIPEX SP334 multi-protocol transceiver IC. A small PIC10F200 microcontroller from MICROCHIP is also used. This microcontroller replaces discreet logic that would be needed to control the SP334 in different operating modes. Related datasheets, assembly program for the microcontroller, as well as the schematic diagram for the TEV-IB0 board can be found on Tibbo website.

Two switches are provided on the board for protocol selection. Switch 1 selects between RS232 and RS422/485 signal levels. Switch 2 selects half-duplex or full-duplex mode of operation. Note that these switches only control the operation of the SP334. Serial ports of the EM1000 must be correctly preset for desired communication mode as well.

For your convenience, each TEV-IB0 board is supplied with a TB100 terminal block adaptor.

DB-9M connector pin assignment

Pin # | RS232 mode | RS422 mode | RS485 mode
1 | --- | RTS- (output) | ---
2 | RX (input) | RX- (input) | RX- (input)
3 | TX (output) | TX+ (output) | TX+ (output)
4 | DTR (output) | TX- (output) | TX- (output)
5 | SYSTEM GROUND | SYSTEM GROUND | SYSTEM GROUND
6 | DSR (input) | RX+ (input) | RX+ (input)
7 | RTS (output) | RTS+ (output) | ---
8 | CTS (input) | CTS+ (input) | ---
9 | --- | CTS- (input) | ---

Required initialization code in Tibbo BASIC application

This section assumes that you are familiar with Tibbo BASIC and TIDE software. These are documented in the "TIDE and Tibbo BASIC Manual".

Correct preset of serial ports falls outside the scope of this manual. This section will only remind you that you need to set a correct serial port mode matching the mode selected by the switches of the TEV-IB0. For RS232 or RS422 mode, set ser.interface=PL_SER_SI_FULLDUPLEX. For the RS485 mode set ser.interface=PL_SER_SI_HALFDUPLEX.

Do not forget that all lines of the EM1000 are configured as inputs by default. Any line that should work as an output should be configured as such. This is done through the "I/O" (io.) object. The only exception is the TX line that becomes an output automatically once the serial port is enabled.


TEV-IB1

The TEV-IB1 board contains three relays and three optically isolated inputs. Common, normally closed, and normally opened lines of each relay are available on the terminal block. Six status LEDs located on the board indicate the state of relays and opto-inputs.

The relays can switch loads of up to 24V/1A. This rating is for non-inductive loads only! For inductive loads, the maximum allowed current falls to about 200mA. Status LEDs 4-6 indicate the state of relays. An LED will be ON when a corresponding relay is activated.

Each optically isolated input has a pair of (+) and (-) contacts with a 330 Ohm series resistor and a LED of the photo-couple between them. The input is activated at a differential voltage of around 4V, and can accept input voltages as high as 24V. Both (+) and (-) inputs are isolated from the rest of the system. Status LEDs 1-3 indicate the state of inputs. An LED will be ON when the current is flowing through a corresponding input and the input is "triggered".

You can use inputs 1-3 to connect to external sensors. Alternatively, inputs 1 and 2 can be used to attach a Wiegand or clock/data card reader. See below for details.

Related EM1000 I/O lines

Pin #(1) | EM1000 I/O line(2) | Function
1 | TX | Relay1(3)
2 | RTS | Relay2(3)
3 | DTR | Relay3(3)
4 | RX | Input1(4)
5 | CTS | Input2(4)
6 | DSR | Input3(4)

(1) Pin number on the TEV-IB1 connector.

(2) There are four ports, so lines are independent for each port. For example, "TX" means "TX0" for port 1, "TX1" for port 2, etc.

(3) Set GPIO line of the EM1000 LOW to activate the relay (do not forget to configure this line as an output).

(4) The GPIO line of the EM1000 will be LOW when the current is flowing through the input.

Terminal block

Terminal #(1) | Function
1 | Relay1, common
2 | Relay1, normally closed
3 | Relay1, normally opened
4 | Relay2, common
5 | Relay2, normally closed
6 | Relay2, normally opened
7 | Relay3, common
8 | Relay3, normally closed
9 | Relay3, normally opened
10 | Input1, positive line (+)
11 | Input1, negative line (-)
12 | Input2, positive line (+)
13 | Input2, negative line (-)
14 | Input3, positive line (+)
15 | Input3, negative line (-)

Connecting a card reader

Ability to handle a Wiegand or clock/data reader output is a unique feature of the serial ports of the EM1000. For more information, see "TIDE and Tibbo BASIC Manual" ("Serial" (ser.) object documentation).

When connecting a clock/data reader, attach the reader's DATA output to the positive line of the input 1 of the TEV-IB1 board. Attach the CLOCK output to the positive line of the input 2. Combine negative lines of inputs 1 and 2 together and connect them to the ground line of the reader. Leave JP4 jumper opened.

When connecting a Wiegand reader, attach the reader's W0 output to the positive line of the input 1 of the TEV-IB1 board. Attach the W1 output to the positive line of the input 2. Combine negative lines of inputs 1 and 2 together and connect them to the ground line of the reader. Close the jumper JP4.

Most Wiegand readers have open-collector outputs, which means you may need to install pull-up resistors on their W0 and W1 outputs.

The function of the JP4 is to combine the signals W0 and W1 -- this is required for the EM1000's serial port operation in Wiegand mode.

Jumpers JP1-3 should be left open.


Ordering Info

The EM1000-TEV has several versions available. The numbering scheme is as follows:

EM1000-TEV numbering system

The following is included into each EM1000-TEV:

· The TEV-MB0 board with the EM1000-512K-ST or EM1000-1024K-ST module (see EM1000 Ordering Info for details).
· Additionally, the GA1000 Wi-Fi module and antenna are installed if option "G" is specified.
· The TEV-KB0 keypad board.
· The TEV-LBx display board of your choice.
· Two TEV-IB0 boards, installed on ports 1 and 2.
· Two TEV-IB1 boards, installed on ports 3 and 4.
· Two TB100 terminal block adaptors.
· One 12V/1A power adaptor.
· One WAS-1499 "straight" Ethernet cable. Good for crossover connections as well, since the EM1000 supports Auto-MDIX.
· One WAS-P0005(B) serial cable. Can be used for firmware upgrades through the serial port.

Additionally, any board or accessory from the EM1000-TEV system can be purchased separately.

Examples of valid model numbers

Model number | Description
EM1000-TEV-512K-L0 | EM1000-TEV with the "512K" EM1000 module and the TEV-LB0 display board
EM1000-TEV-1024K-G-L2 | EM1000-TEV with the "1024K" EM1000 module, the GA1000 Wi-Fi slave module and antenna, and the TEV-LB2 display board


EM500EV

The EM500EV Evaluation System offers a convenient way of testing the EM500 BASIC-programmable Embedded module. The EM500EV consists of two boards:

· EM500EV-MB0 motherboard with EM500 module.
· EM500EV-IB0 RS232 interface board.

Tibbo BASIC offers a fully functional serial-over-IP application that can be tested on the EM500EV. Written in Tibbo BASIC, the application is compatible with Tibbo Device Server Toolkit software, comes with complete source code, and can be modified by the user.


EM500EV-MB0

The EM500EV-MB0 motherboard comes with the EM500 module (installed on a socket). A schematic diagram of the EM500EV-MB0 board can be found on Tibbo website.

It is physically possible to plug the EM500 module into the EM500EV-MB0 in reverse. However, it will not plug in fully, and when you turn it on when plugged in incorrectly, it may be damaged. The module only goes in fully when inserted in the proper orientation.

The TEV-MB0 motherboard also features the following:

· A power jack and a switching regulator with 3.3V output. This 3.3V power is supplied to the EM500 and is also provided on the interface board connector (see below).
· An MD button, which is connected to the MD input of the EM500.
· Green and red dual-function status LEDs. The term "dual-function" refers to the fact that these LEDs are also used for Ethernet link status indication.

Interface board interface

The EM500EV-IB0 RS232 interface board is connected to the EM500EV-MB0 through a 16-pin connector. Connector pin assignment is as follows:

Pin # | Function
1 | Vcc output (3.3V)
2 | GND
3 | RX (1)
4 | TX (1)
5 | GPIO0/P0.0/INT0 (1)
6 | GPIO1/P0.1/INT1 (1)
7 | GPIO2/P0.2 (1)
8 | GPIO3/P0.3 (1)
9 | GPIO4/P0.4 (1)
10 | GPIO5/P0.5 (1)
11 | GPIO6/P0.6 (1)
12 | GPIO7/P0.7 (1)
13 | MD (1)
14 | RST (1)
15 | GND
16 | VIN (12V)

(1) Directly connected to the corresponding pin of the EM500.


EM500EV-IB0

The EM500EV-IB0 RS232 interface board implements one RS232 serial port. The port is built around SIPEX SP3243 RS232 transceiver IC. RS232 interface lines are available on a standard DB-9M connector:

Pin # (DB-9M) | R232 line (DB-9M) | EM500 control line
1 | CD (input) | GPIO4/P0.4
2 | RX (input) | RX
3 | TX (output) | TX
4 | DTR (output) | GPIO3/P0.3
5 | SYSTEM GROUND |
6 | DSR (input) | GPIO1/P0.1/INT1
7 | RTS (output) | GPIO2/P0.2
8 | CTS (input) | GPIO0/P0.0/INT0
9 | --- |


Ordering Info

The EM500EV comes in a single configuration:

EM500EV numbering system

The following is included into each EM500EV:

· The EM500EV-MB0 motherboard with the EM500 module on a socket.
· The EM500EV-IB0 RS232 interface boards.
· One 12V/0.5A power adaptor.

No cables are supplied with the EM500EV. Such cables can be purchased separately.


External Controllers

The following external controllers and controller families are currently being offered by Tibbo:

· DS1206
· DS1202
· DS10xx Family


DS1206

Introduction

The DS1206 is a miniature BASIC-programmable controller designed primarily for serial-over-IP and serial control applications.

The DS1206 features a multi-channel serial port. The device has a single DB9M connector and is priced as a single-port product, yet it packs four independent serial channels. Have no use for those DSR and DTR lines? Turn them into RX and TX of an additional serial channel. Don't want CTS and RTS either? That's one more channel! In total, there are 15 different configurations to choose from.

Another feature of the DS1206 is software-controlled power output on pin 9 of the RS232 port, so you can power an attached serial device directly through the DS1206. Alternatively, the DS1206 itself can be powered through this pin.

The DS1206 is fully supported by TIDE software and a dedicated DS1206 platform that covers all hardware facilities of the device (see "TIDE and Tibbo BASIC Manual"). This product ships preloaded with a fully functional serial-over-IP application. Written in Tibbo BASIC, the application is compatible with Tibbo Device Server Toolkit software, comes with full source codes, and can be modified by the user.

Hardware features

· Superior upgrade to the DS203 and DS1202 devices.
· Based on high-performance purpose-built 88-MHz T1000 ASIC.
· 100BaseT auto-MDIX Ethernet port (automatic detection of "straight" and "cross" cables).
· Up to 3.5 serial channels on a single RS232 connector:

- Baudrates of up to 921,600bps;

- None/even/odd/mark/space parity modes;

- 7/8 bits/character modes;

- Optional flow control;

- Flexible mapping with 15 different options, such as:

- A single channel: RX, TX, CTS, RTS, DSR, and DTR lines;

- 3.5 channels: RX, TX, RX2, TX2, RX3, TX3, and RX4 lines.

- Optional "12V" power output on pin 9 of the DB9M connector (software-controllable);

- Optional "12V" power input from pin 9 of the DB9M connector (instead of supplying power through the power jack).

· 512KB or 1024KB flash memory for firmware, application, and data storage.
· 2KB EEPROM for data storage.
· Four LEDs:

- Green and red status LEDs on top of the device;

- Link and speed Ethernet status LEDs on the RJ45 jack.

· Software-controlled onboard PLL to select the clock frequency of the device: 11.0592MHz with PLL off, 88.4736MHz with PLL on.
· Supply voltage range: 10-24V (12V nominal).
· Dimensions: 60x47x30mm.
· Firmware and Tibbo BASIC application are upgradeable through the serial port or network.
· Tibbo BASIC application can be debugged through the network and no additional debugging hardware, such as in-circuit emulator, is required.
· Also available as DS1206N (board without housing).

Programming features

· Variable Types: Byte, char, integer (word), short, dword, long, real, string, plus ser-defined arrays and structures.
· Function Groups: Strings functions (21 in total!), date/time conversion functions, and hash calculation functions (md5 and sha1).
· Platform objects:

- Sock — socket communications (up to 16 UDP, TCP, and HTTP sessions);

- Net — controls Ethernet port;

- Ser — in charge of serial channels;

- Io — handles I/O lines, ports, and interrupts;

- Fd — manages flash memory file system and direct sector access;

- Stor — provides access to the EEPROM;

- Romfile — facilitates access to resource files (fixed data);

- Pat — "plays" patterns on green and red status LEDs;

- Button — monitors the setup button;

- Sys — in charge of general device functionality.


DS1206 Connectors and Controls

Click on one of the links provided below to learn more about the DS1206:

· Power arrangement
· Ethernet port
· Multi-channel RS232 port
· Flash and EEPROM Memory
· Status LEDs
· Setup button


Power Arrangement

Normally, the DS1206 is powered through its power jack.

The power jack of the DS1206 accepts "small" power connectors with 3.5mm diameter. Use APR-P0011, APR-P0012, or APR-P0013 power adaptor supplied by Tibbo or similar adaptor with 12V nominal output voltage. Adaptor current rating should be at least 500mA. On the power jack, the ground is "on the outside", as shown on the figure below.

Alternatively, the DS1206 can be powered through a pin 9 of the DB9M (RS232) connector. Two internal diodes combine power jack and pin 9 inputs into a single line, which goes to the internal regulator of the DS1206.

The pin 9 of the RS232 port can also be used to provide "12V" power to an attached serial device. Many small serial devices, such as barcode scanners, accept power on pin 9 of their DB9 connectors.

"12V" actually means "input power on the power jack", which is not necessarily stabilized. The power line of the jack passes through a software-controlled switch and is then connected to pin 9 of the RS232 port through a Schottky diode (shown on the diagram below). Therefore, the voltage on pin 9 is close to the input voltage on the power jack. Also, the maximum current an attached serial device can source depends on the maximum output power of the power adaptor (power supply) plugged into the power jack (minus the power consumed by the DS1206 itself).

Tibbo serial-over-IP application supplied with the DS1206 has a dedicated "PS" ("Power on pin 9") setting to control the power switch. To turn the power switch on from within your Tibbo BASIC application, enable (configure as output) line PL_IO_NUM8_PWROUT and then set this line to HIGH. Additional programming information can be found in "TIDE and Tibbo BASIC Manual" (see i.o object and DS1206 platform documentation).

If you want to use pin 9 of the DB9M connector to power an attached serial device, then you must power the DS1206 itself through the power jack. We know you understand this, but we still had to mention it.


Ethernet Port

Ethernet port of the DS1206 is of 10/100BaseT type.

The connector is of RJ45 type, pin assignment is as follows:

#1 | TX+
#2 | TX-
#3 | RX+
#4 | <No connection>
#5 | <No connection>
#6 | RX-
#7 | <No connection>
#8 | <No connection>

The Ethernet port of the DS1206 incorporates two Ethernet status LEDs.


Multi-channel RS232 Port

The DS1206 features a multi-channel RS232 port. Internally, the DS1206 has four independent serial ports, and each of those ports can potentially have its own RX, TX, CTS, RTS, DSR, and DTR lines. Physically, the RS232 port of the DS1206 has three output lines and four input lines. Flexible mapping allows you to choose how these inputs and outputs will be used.

The serial-over-IP application supplied with the DS1206 defines 15 mapping options. These are presented in the table below:

Mapping option | Available signals | Pins on the DB9M connector |  |  |  |  |  |  | Missing line
 |  | #2 | #3 | #8 | #7 | #6 | #4 | #1
Option 0 | RX/TX/CTS/RTS/DSR/DTR | RX | TX | CTS | RTS | DSR | DTR | --- | ---
Option 1 | RX/TX/CTS/RTS/DSR/DTR + RX/tx | RX | TX | CTS | RTS | DSR | DTR | RX4 | tx4
Option 2 | RX/TX/CTS/RTS + RX/TX + RX/tx | RX | TX | CTS | RTS | RX3 | TX3 | RX4 | tx4
Option 3 | RX/TX/CTS/RTS + RX/TX/CTS/rts | RX | TX | CTS | RTS | RX3 | TX3 | CTS3 | rts3
Option 4 | RX/TX/CTS/RTS + RX/TX/DSR/dtr | RX | TX | CTS | RTS | RX3 | TX3 | DSR3 | dtr3
Option 5 | RX/TX/DSR/DTR + RX/TX + RX/tx | RX | TX | RX2 | TX2 | DSR | DTR | RX4 | tx4
Option 6 | RX/TX/DSR/DTR + RX/TX/CTS/rts | RX | TX | RX2 | TX2 | DSR | DTR | CTS2 | rts2
Option 7 | RX/TX/DSR/DTR + RX/TX/DSR/dtr | RX | TX | RX2 | TX2 | DSR | DTR | DSR2 | dtr2
Option 8 | RX/TX + RX/TX + RX/TX + RX/tx | RX | TX | RX2 | TX2 | RX3 | TX3 | RX4 | tx4
Option 9 | RX/TX/CTS/rts + RX/TX + RX/TX | RX | TX | RX2 | TX2 | RX3 | TX3 | CTS | rts
Option 10 | RX/TX/DSR/dtr + RX/TX + RX/TX | RX | TX | RX2 | TX2 | RX3 | TX3 | DSR | dtr
Option 11 | RX/TX/CTS/RTS + RX/tx/CTS/RTS | RX | TX | CTS | RTS | CTS4 | RTS4 | RX4 | tx4
Option 12 | RX/TX/CTS/RTS + RX/tx/DSR/DTR | RX | TX | CTS | RTS | DSR4 | DTR4 | RX4 | tx4
Option 13 | RX/TX/DSR/DTR + RX/tx/CTS/RTS | RX | TX | CTS4 | RTS4 | DSR | DTR | RX4 | tx4
Option 14 | RX/TX/DSR/DTR + RX/tx/DSR/DTR | RX | TX | DSR4 | DTR4 | DSR | DTR | RX4 | tx4

"Available signals" column shows a particular combination of I/O lines for each option. For example, option 0 defines the standard serial port arrangement with RX, TX, CTS, RTS, DSR, and DTR lines. Option 2 gives you one channel with RX, TX, CTS, and RTS lines, one more channel with just RX and TX lines, and yet another channel with a single RX line. The TX line is "missing" because, once again, there are only three outputs available. This is why this line is shown in grey lowercase (tx).

Notice that on the DS1206, pin 9 of the RS232 port can be used to power the DS1206 or provide power to an attached serial device. See Power Arrangement for details.

Additional programming information regarding serial ports can be found in "TIDE and Tibbo BASIC Manual".


Flash and EEPROM Memory

The DS1206 has 512KBytes or 1024KBytes of flash memory and 2KBytes of EEPROM memory.

The first 64KBytes of flash memory are used to store the TiOS firmware. When you are performing a firmware upgrade it is this memory you are saving the firmware binary into.

The rest of this flash memory is available to your Tibbo BASIC application and its data. Whatever memory space is left after the compiled application is loaded can be used as a flash disk (see fd. object documentation in the "TIDE and Tibbo BASIC Manual").

The EEPROM is almost fully available to your application, save for a small 8-byte area called "special configuration area". The EEPROM is accessed through the stor. object (see "TIDE and Tibbo BASIC Manual"). Details on the special configuration area are provided in the Platform-dependent Programming Information section inside the DS1206 platform documentation (same manual).


Ordering Info and Specifications

Device numbering scheme is as follows:

DS1206 numbering system

Examples of valid model numbers

Model number | Description
DS1206-512K-00 | DS1206 device with 512KBytes of flash memory
DS1206-1024K-00 | DS1206 device with 1MB of flash memory

Hardware specifications

Ethernet interface | 10/100BaseT Ethernet, Auto-MDIX, magnetics not built-in
Serial ports | One RS232 port (DB9M) with 3.5 serial channels (four inputs and three outputs)
UART capabilities | Baudrates up to 921'600bps; none/even/odd/mark/space parity and 7/8 bits/character.
Clock frequency | 11.0592MHz with PLL off 88.4736MHz with PLL on
Flash memory | 512KBytes or 1024KBytes, entire memory minus 64KB is available to store Tibbo BASIC application and data
EEPROM memory | 2048 bytes, 2040 bytes available to store application data
Supply voltage range | DC 10-24V (12V nominal)
Operating temperature | -5 to +70 degrees C
Operating relative humidity | 10-90%
Mechanical dimensions | 60x47x30mm
Carton dimensions | 125x95x52mm
Gross weight | 110g

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


DS1202

Introduction

The DS1202 is a miniature BASIC-programmable controller designed primarily for serial-over-IP and serial control applications.

The DS1202 features a multi-channel serial port. The device has a single DB9M connector and is priced as a single-port product, yet it packs four independent serial channels. Have no use for those DSR and DTR lines? Turn them into RX and TX of an additional serial channel. Don't want CTS and RTS either? That's one more channel! In total, there are 15 different configurations to choose from.

The DS1202 is fully supported by TIDE software and a dedicated DS1202 platform that covers all hardware facilities of the device (see "TIDE and Tibbo BASIC Manual"). This product ships preloaded with a fully functional serial-over-IP application. Written in Tibbo BASIC, the application is compatible with Tibbo Device Server Toolkit software, comes with full source codes, and can be modified by the user.

Hardware features

· Superior upgrade to the DS203 devices.
· Based on the EM1202 BASIC-programmable embedded module.
· 100BaseT auto-MDIX Ethernet port (automatic detection of "straight" and "cross" cables).
· Up to 3.5 serial channels on a single RS232 connector:

- Baudrates of up to 921,600bps;

- None/even/odd/mark/space parity modes;

- 7/8 bits/character modes;

- Optional flow control;

- Flexible mapping with 15 different options, such as:

- A single channel: RX, TX, CTS, RTS, DSR, and DTR lines;

- 3.5 channels: RX, TX, RX2, TX2, RX3, TX3, and RX4 lines.

· 1024KB flash memory for firmware, application, and data storage.
· 2KB EEPROM for data storage.
· Six LEDs:

- Green and red status LEDs on top of the device;

- Green and red status LEDs on the RJ45 jack;

- Link and speed Ethernet status LEDs on the RJ45 jack.

· Software-controlled onboard PLL to select the clock frequency of the device: 11.0592MHz with PLL off, 88.4736MHz with PLL on.
· Supply voltage range: 10-24V (12V nominal).
· Dimensions: 60x47x30mm.
· Firmware and Tibbo BASIC application are upgradeable through the serial port or network.
· Tibbo BASIC application can be debugged through the network and no additional debugging hardware, such as in-circuit emulator, is required.
· Also available as a EM1202EV (board without housing).

Programming features

· Variable Types: Byte, char, integer (word), short, dword, long, real, string, plus ser-defined arrays and structures.
· Function Groups: Strings functions (21 in total!), date/time conversion functions, and hash calculation functions (md5 and sha1).
· Platform objects:

- Sock — socket communications (up to 16 UDP, TCP, and HTTP sessions);

- Net — controls Ethernet port;

- Ser — in charge of serial channels;

- Io — handles I/O lines, ports, and interrupts;

- Fd — manages flash memory file system and direct sector access;

- Stor — provides access to the EEPROM;

- Romfile — facilitates access to resource files (fixed data);

- Pat — "plays" patterns on green and red status LEDs;

- Button — monitors the setup button;

- Sys — in charge of general device functionality.


DS1202 Connectors and Controls

Click on one of the links provided below to learn more about the DS1202:

· Power arrangement
· Ethernet port
· Multi-channel RS232 port
· Flash and EEPROM memory
· Status LEDs
· Setup button


Power Arrangement

The DS1202 is powered through its power jack. The power jack of the DS1202 accepts "small" power connectors with 3.5mm diameter. Use APR-P0011, APR-P0012, or APR-P0013 power adaptor supplied by Tibbo or similar adaptor with 12V nominal output voltage. Adaptor current rating should be at least 500mA. On the power jack, the ground is "on the outside", as shown on the figure below.


Ethernet Port

Ethernet port of the DS1202 is of 10/100BaseT type.

Connector is of RJ45 type, pin assignment is as follows:

#1 | TX+
#2 | TX-
#3 | RX+
#4 | <No connection>
#5 | <No connection>
#6 | RX-
#7 | <No connection>
#8 | <No connection>

The Ethernet port of the DS1202 incorporates four LEDs (two status LEDs and two Ethernet status LEDs). The DS1202 has another pair of status LEDs located on top of the board. Two status LED pairs work in parallel.


Multi-Channel RS232 Port

The DS1202 has four serial ports internally. The RS232 port of the DS1202 implements three outputs, four inputs, and one "spare" input (CD). Each of the three outputs can be used as a TX line of a serial channel, or as a control output such as RTS or DTR. Input lines can be used as an RX line of a serial channel, or as a control input such as CTS or DSR. The spare input cannot work as an RX line. This input is not used by the serial-over-IP application supplied by Tibbo and will be largely omitted from further discussion. Your Tibbo BASIC application can always use this extra input if you require it.

With three outputs and four inputs, the DS1202 can be said to offer 3.5 serial "channels". We say "3.5 channels" and not "four channels" because one channel will only have RX line and no TX line (remember, there are four inputs but only three outputs).

Mapping option | Available signals | Pins on the DB9M connector of the DS1202-RS |  |  |  |  |  |  | Missing line
 |  | #2 | #3 | #8 | #7 | #6 | #4 | #9
Option 0 | RX/TX/CTS/RTS/DSR/DTR | RX | TX | CTS | RTS | DSR | DTR | --- | ---
Option 1 | RX/TX/CTS/RTS/DSR/DTR + RX/tx | RX | TX | CTS | RTS | DSR | DTR | RX4 | tx4
Option 2 | RX/TX/CTS/RTS + RX/TX + RX/tx | RX | TX | CTS | RTS | RX3 | TX3 | RX4 | tx4
Option 3 | RX/TX/CTS/RTS + RX/TX/CTS/rts | RX | TX | CTS | RTS | RX3 | TX3 | CTS3 | rts3
Option 4 | RX/TX/CTS/RTS + RX/TX/DSR/dtr | RX | TX | CTS | RTS | RX3 | TX3 | DSR3 | dtr3
Option 5 | RX/TX/DSR/DTR + RX/TX + RX/tx | RX | TX | RX2 | TX2 | DSR | DTR | RX4 | tx4
Option 6 | RX/TX/DSR/DTR + RX/TX/CTS/rts | RX | TX | RX2 | TX2 | DSR | DTR | CTS2 | rts2
Option 7 | RX/TX/DSR/DTR + RX/TX/DSR/dtr | RX | TX | RX2 | TX2 | DSR | DTR | DSR2 | dtr2
Option 8 | RX/TX + RX/TX + RX/TX + RX/tx | RX | TX | RX2 | TX2 | RX3 | TX3 | RX4 | tx4
Option 9 | RX/TX/CTS/rts + RX/TX + RX/TX | RX | TX | RX2 | TX2 | RX3 | TX3 | CTS | rts
Option 10 | RX/TX/DSR/dtr + RX/TX + RX/TX | RX | TX | RX2 | TX2 | RX3 | TX3 | DSR | dtr
Option 11 | RX/TX/CTS/RTS + RX/tx/CTS/RTS | RX | TX | CTS | RTS | CTS4 | RTS4 | RX4 | tx4
Option 12 | RX/TX/CTS/RTS + RX/tx/DSR/DTR | RX | TX | CTS | RTS | DSR4 | DTR4 | RX4 | tx4
Option 13 | RX/TX/DSR/DTR + RX/tx/CTS/RTS | RX | TX | CTS4 | RTS4 | DSR | DTR | RX4 | tx4
Option 14 | RX/TX/DSR/DTR + RX/tx/DSR/DTR | RX | TX | DSR4 | DTR4 | DSR | DTR | RX4 | tx4

"Available signals" column shows a particular combination of I/O lines for each option. For example, option 0 defines the standard serial port arrangement with RX, TX, CTS, RTS, DSR, and DTR lines. Option 2 gives you one channel with RX, TX, CTS, and RTS lines, one more channel with just RX and TX lines, and yet another channel with a single RX line. The TX line is "missing" because, once again, there are only three outputs available. This is why this line is shown in grey lowercase (tx).


Flash and EEPROM Memory

The DS1202 has 1024KBytes of flash memory and 2KBytes of EEPROM memory.

The first 64KBytes of flash memory are used to store the TiOS firmware. When you are performing a firmware upgrade it is this memory you are saving the firmware binary into.

The rest of this flash memory is available to your Tibbo BASIC application and its data. Whatever memory space is left after the compiled application is loaded can be used as a flash disk (see fd. object documentation in the "TIDE and Tibbo BASIC Manual").

The EEPROM is almost fully available to your application, save for a small 8-byte area called "special configuration area". The EEPROM is accessed through the stor. object (see "TIDE and Tibbo BASIC Manual"). Details on the special configuration area are provided in the Platform-dependent Programming Information section inside the DS1202 and EM1202 platform documentation (same manual).


Ordering Info and Specifications

The DS1202 has one model in circulation: DS1202-01.

Hardware specifications

Ethernet interface | 10/100BaseT Ethernet, Auto-MDIX, magnetics not built-in
Serial ports | One RS232 port (DB9M) with 3.5 serial channels (four inputs and three outputs)
UART capabilities | Baudrates up to 921'600bps; none/even/odd/mark/space parity and 7/8 bits/character.
Clock frequency | 11.0592MHz with PLL off 88.4736MHz with PLL on
Flash memory | 1024KBytes, entire memory minus 64KB is available to store Tibbo BASIC application and data
EEPROM memory | 2048 bytes, 2040 bytes available to store application data
Supply voltage range | DC 10-24V (12V nominal)
Operating temperature | -5 to +70 degrees C
Operating relative humidity | 10-90%
Mechanical dimensions | 60x47x30mm
Carton dimensions | 125x95x52mm
Gross weight | 110g

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


DS10xx

The DS10xx is a family of BASIC-programmable industrial controllers.

The DS10xx is a universal platform that is well suited for a variety of control applications. The functionality of the device depends on a Tibbo BASIC application created (loaded) by the user.

All devices of the DS10xx family share a number of common features.

Internally, each device contains two main boards: an NB10x0 network board ("NB") with the EM1000 module on it, and an IB100x interface boards ("IB") that implements required I/O functionality of the device. These boards are interconnected by an IC1000 cable. Some interface boards also carry a second "supplementary" board ("SB"). Additionally, there are two LED boards -- LB1000 and LB1001. The LB1000 is attached to the NB10x0, the LB1001 -- to the IB100x.

At the moment, the DS10xx family includes the following devices:

· DS1000 (4 RS232 ports);
· DS1002 (4 RS232/422/485 ports);
· DS1003 (4 isolated RS232/422/485 ports);
· DS1004 (8 analog inputs, 4 analog outputs, RS232/485 port, 2 relays);
· DS1005 (8 opto-isolated inputs, 6 relays, RS232/485 port);

If none of standard DS10xx devices suit your needs, you are welcome to create your very own controller with exactly the set of I/Os required for your project. You can also subcontract the design and manufacturing of your custom "IB" board to Tibbo.

When used with the included waterproof cover, all devices of the DS10xx family are dust and water-proof to IP68.

Programming features

· Variable Types: Byte, char, integer (word), short, dword, long, real, string, plus ser-defined arrays and structures.
· Function Groups: Strings functions (21 in total!), date/time conversion functions, and hash calculation functions (md5 and sha1).
· Platform objects:

- Sock — socket communications (up to 16 UDP, TCP, and HTTP sessions);

- Net — controls Ethernet port;

- Ser — in charge of serial channels;

- Io — handles I/O lines, ports, and interrupts;

- Rtc — keeps track of date and time;

- Fd — manages flash memory file system and direct sector access;

- Stor — provides access to the EEPROM;

- Romfile — facilitates access to resource files (fixed data);

- Pat — "plays" patterns on green and red status LEDs;

- Beep — generates buzzer patterns;

- Button — monitors the setup button;

- Sys — in charge of general device functionality.


Common Features of the DS10xx Family

This section describes all common features of the DS10xx family:

· Secondary cover
· DIN rail mounting


Secondary Cover

All DS10xx devices are dust- and water-proof to IP68 when used with a properly installed secondary cover. The diagram above shows the procedure of waterproofing any DS10xx device. Shown on the diagram are devices with terminal blocks (DS1004, DS1005). Other devices in the DS10xx series have DB9 connectors (see DS1000, DS1002, DS1003). Tibbo offers a TB1000 terminal block adaptor that "converts" DB9 connector into terminal blocks. The TB1000 is compatible with the secondary cover.


DIN Rail Mounting

All DS10xx devices are supplied with the DMK1000 DIN rail mounting kit. Mounting holes on the back of the device allow you to attach the DIN rail mounting bracket horizontally or vertically.


DS1000, DS1002, DS1003 (4 Serial Ports)

The DS1000, DS1002, and DS1003 BASIC-programmable controllers offer four serial ports. The difference between these three controller models as in the type of serial ports provided:

· The DS1000 has 4 simple RS232 serial ports;
· The DS1002 has 4 non-isolated universal RS232/422/485 serial ports;
· The DS1003 has 4 electrically isolated RS232/422/485 serial ports;

The DS1000, DS1002, and DS1003 devices are based on the following internal boards:

· The NB1000 network board with the EM1000 module installed on it and the LB1000 LED board attached.
· The IB1000, IB1002, or IB1003 serial port board (for the DS1000, DS1002, and DS1003 respectively) with the LB1001 LED board attached.

See each board's documentation for detailed functionality description. Follow these quick links to often needed information:

· Right (network) side of the device:

- Power jack, terminals, and power regulator;

- Ethernet jack;

- Ethernet LEDs, M (mode) and R (reset) buttons;

- "Right side" LEDs;

- Buzzer control.

· Left (interface) side of the device:

- Pin assignment and control of serial ports;

- "Left side" LEDs.


 Ordering Info and Specifications

Ordering Info and Specifications

Model number | Description
DS1000-01 | DS1000 controller
DS1002-01 | DS1002 controller
DS1003-01 | DS1003 controller

Hardware specifications

Network board | NB1000 + LB1000
Interface board | DS1000: IB1000 + LB1001 DS1002: IB1002 + LB1001 DS1003: IB1003 + LB1001
Supply voltage range | DC 10-18VDC (12VDC nominal)
Operating temperature | -30 to +80 degrees C
Operating relative humidity | 10-90%
Mechanical dimensions | 91x104x99mm
Carton dimensions | 203x160x110mm

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


DS1004 (Analog I/O)

The DS1004 BASIC-programmable controller features eight A/D inputs, four D/A outputs with both voltage and current outputs, two low-power relays, and one RS232/485 port.

The DS1004 is based on the following internal boards:

· The NB1000 network board with the EM1000 module installed on it and the LB1000 LED board attached.
· The IB1004 analog I/O board with the LB1001 LED board attached.

See each board's documentation for detailed functionality description. Follow these quick links to often needed information:

· Right (network) side of the device:

- Power jack, terminals, and power regulator;

- Ethernet jack;

- Ethernet LEDs, M (mode) and R (reset) buttons;

- "Right side" LEDs;

- Buzzer control.

· Left (interface) side of the device:

- Terminal blocks and control lines;

- A/D converter;

- D/A converter;

- Relays;

- RS232/485 port;

- "Left side" LEDs.


Ordering Info and Specifications

Model number | Description
DS1004-01 | DS1004 controller

Hardware specifications

Network board | NB1000 + LB1000
Interface board | IB1004 + SB1004 + LB1001
Supply voltage range | DC 10-18VDC (12VDC nominal)
Operating temperature | -30 to +80 degrees C
Operating relative humidity | 10-90%
Mechanical dimensions | 91x104x99mm
Carton dimensions | 203x160x110mm

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


DS1005 (Digital I/O)

The DS1005 BASIC-programmable controller features eight opto-isolated digital inputs, six high-power relays, and one RS232/485 port.

The DS1005 is based on the following internal boards:

· The NB1000 network board with the EM1000 module installed on it and the LB1000 LED board attached.
· The IB1005 digital I/O board with the LB1001 LED board attached.

See each board's documentation for detailed functionality description. Follow these quick links to often needed information:

· Right (network) side of the device:

- Power jack, terminals, and power regulator;

- Ethernet jack;

- Ethernet LEDs, M (mode) and R (reset) buttons;

- "Right side" LEDs;

- Buzzer control.

· Left (interface) side of the device:

- Terminal blocks and control lines;

- Opto-isolated inputs;

- Relays;

- RS232/485 port;

- "Left side" LEDs.


Ordering Info and Specifications

Model number | Description
DS1005-01 | DS1005 controller

Hardware specifications

Network board | NB1000 + LB1000
Interface board | IB1005 + SB1005 + LB1001
Supply voltage range | DC 10-18VDC (12VDC nominal)
Operating temperature | -30 to +80 degrees C
Operating relative humidity | 10-90%
Mechanical dimensions | 91x104x99mm
Carton dimensions | 203x160x110mm

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


Companion Products

The following companion products are currently being offered by Tibbo:

· GA1000 (Wi-Fi add-on module)
· RJ203 (jack/magnetics module)


GA1000

Introduction

The GA1000 Wi-Fi add-on module further expands the scope of potential applications for Tibbo BASIC-programmable modules by adding 802.11b/g communications capability to the already powerful hardware mix. The GA1000 can be used with these Tibbo devices: EM1000, EM1202, EM1206, EM500.

The module utilizes an SPI interface and only requires five GPIOs to control. This can be reduced to four if two NAND gates are used to generate reset signal. On the EM500, the number is even down to three lines! For more information, see Connecting GA1000 to Tibbo Devices.

The GA1000 is fully supported by TIDE software (see "TIDE and Tibbo BASIC Manual", wln. object). For convenient testing and evaluation Tibbo offers EM1206EV, EM1000TEV and EM1000EV development systems.

Please note that the GA1000 is a slave device and cannot be used on its own. This add-on will only work together a BASIC-programmable Tibbo module.

Hardware features

· Superior upgrade to the now obsolete WA1000 module.
· Implements 802.11b/g Wi-Fi standard.
· Compatible with EM1000, EM1202, EM1206, and EM500 modules.
· Requires 3-5 GPIO lines to control.
· Chip antenna onboard, coaxial connector for external antenna.
· Red status LED for scan/link indication.
· Max. power: 280 mA (max) @ 3.3V.
· Dimensions: 42.0x19.0x6.7mm.


I/O Pin Assignment and Pin Functions

I/O pin assignment

Pin # | Function | Description
1 | GND | System ground.
2 | VCC | Positive power input, 3.3V nominal, +/- 5%.
3 | CS | Chip select, active LOW (input*).
4 | N.C. | No connection.
5 | DI | SPI port, data in (input*, must be connected to DO of Tibbo module).
6 | N.C. | No connection.
7 | RST | Reset, active LOW (input*).
8 | N.C. | No connection.
9 | DO | SPI port, data out (output*, must be connected to DI of Tibbo module).
10 | CLK | SPI port, clock (input*).

* Of the GA1000.


Connecting GA1000 to Tibbo Devices

GA1000 interface

The GA1000 communicates with Tibbo devices through an SPI interface. Your device will control the GA1000 through five GPIO lines:

· CS -- SPI bus, chip select (active low);
· CLK -- SPI bus, clock;
· DI -- SPI bus, data in (must be connected to the GA1000's DO);
· DO -- SPI bus, data out (must be connected to the GA1000's DI);
· RST -- reset (active low). This line can be eliminated -- see below for details.

On the EM1000, EM1202, and EM1206, do not forget to configure CS, CLK, DO, and RST as outputs. DI must be configured as input. The wln. object won't do this automatically. GPIO configuration is not necessary on the EM500, whose lines are bidirectional.

Providing hardware reset

The wln. object directly controls CS, CLK, DI, and DO lines. Your application, however, must take care of the proper hardware reset for the GA1000. There are two methods for doing this:

· Use a dedicated GPIO line to act as the RST line of the GA1000 interface (shown on diagram A below).
· Use 2 NAND gates to combine CS and CLK signals and produce the reset signal for the GA1000 (shown on diagram B). This approach takes advantage of the fact that during SPI communications, CLK line will never be LOW while the CS line is HIGH. Schematic diagram on figure B generates reset when CS=HIGH and CLK=LOW. This way you save one GPIO line of your programmable module.

Tibbo devices differ in whether the CS, CLK, DI, and DO lines are remappable. On the EM1000, EM1202, and EM1206, you can choose any set of GPIOs to control the GA1000. On the EM500 where remapping isn't provided, you just have to use "prescribed" GPIO lines.

Special case -- the EM500

Diagram C shows the recommended way of connecting the GA1000 to the EM500 module. GPIO lines are a precious commodity on the EM500 -- there are only eight of them available. As seen on the diagram C, you can get away with using only three lines to control the GA1000 (against the standard five lines). One line is saved by producing the reset out of CS and CLK lines. The second line is saved because EM500's bidirectional GPIOs allow interconnecting DI and DO. The EM500 does not allow remapping of GA1000 lines, so GPIO line assignment shown below cannot be changed.


Status LED

The GA1000 has a single red status LED:

· During scanning (see wln.scan*), the LED blinks.
· When the GA1000 is associated with an access point (see wln.associate*), the LED is ON.
· When the GA1000 is in ad-hoc mode and has another peer connected to it, the LED is ON as well.
· In all other cases, the LED is off.

*See "TIDE and Tibbo BASIC Manual", .wln object documentation.


Mechanical Dimensions

L | Max. | 42.1 | Module length.
W | Max. | 19.1 | Module width.
H | Max. | 6.7 | Module height.
I | Min. | 4.0 | Pin length.
w | Min | 11.7 | Horizontal cutout dimension.
h | Min. | 4.5 | Vertical cutout dimension.
d1 | Aver. | 4.5 | Horizontal distance from the centerline of the module to the center of the mounting hole.
d2 | Aver. | 35.0 | Vertical distance from the edge of the board to the center of the mounting hole.
d3 | Min. | 2.1 | Mounting hole diameter
d4 | Aver. | 2.5 | Vertical distance from the edge of the board to the center of the first row of pins of the connector
p | Aver. | 2.54 | Pin pitch

Dimensions are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


Ordering Info and Specifications

The GA1000 has only one version available: GA1000-00. The module can be ordered separately as GA1000. A set consisting of the EM1000 and GA1000 modules can also be ordered using the "EM1000G" ordering code (see Specifications and Ordering Info for the EM1000). The GA1000 also works with EM1202 and EM1206 devices.

Specifications

Wireless interface | 802.11b/g
Interface type | SPI
Nominal power supply voltage (VCC pin) | DC 3.3V, +/- 5%
Operating current (VCC pin) | Post-reset, before boot: ~65mA; Fully functional, no data transmission: ~200mA; During data transmission: ~280mA.
Operating temperature | -20 to +70 degrees C
Operating relative humidity | 10-90%
Mechanical dimensions (excl. leads) | 42x19x6.7mm
Packaging | Tray, 30 modules/tray.

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


RJ203 Jack/Magnetics Module

Patent pending

The RJ203 is an "Ethernet front-end" module that contains 10/100BaseT Ethernet magnetics and a standard RJ45 jack. Module's magnetics are designed to work with Davicom's DM9000B Ethernet controller.

Unique patent-pending design of the module minimizes module's footprint and allows you to put other components required on your host board under the RJ203, thus saving valuable host board space. Moreover, translucent housing of the RJ203's face enables you to place status LEDs directly on the host board and have these LEDs visible through the front face of the RJ203.

There are two ways in which you can utilize the RJ203 in your design:

· You can interface the RJ203 to the DM9000B IC located, together with the CPU and other necessary components, directly on your host PCB.
· Alternatively, you can use the RJ203 in combination with the EM203 Ethernet-to-serial module (documented in the "Serial-over-IP Solutions Manual") or EM1206 BASIC-programmable Ethernet module. These modules fit right "under" the RJ203, thus taking (virtually) no additional space on the host PCB.


Interface Pads

The RJ203 has a single row or interface pins.

#1 | RX+ | Output | Ethernet port, positive line of the differential input signal pair
#2 | RX- | Output | Ethernet port, negative line of the differential input signal pair
#3 | AVCC | Input | "Clean" 1.8V power output for magnetics circuitry
#4 | --- | --- | ---
#5 | --- | --- | ---
#6 | GND |  | Ground
#7 | TX+ | Input | Ethernet port, positive line of the differential output signal pair
#8 | TX- | Input | Ethernet port, negative line of the differential output signal pair


Interfacing the RJ203 to the DM9000B

The RJ203 module interfaces directly to the DAVICOM's DM9000B Ethernet controller. The following table details the interconnection between the DM9000A and the interface pads of the RJ203:

DM9000B | RJ203
RX+ (#3) | RX+ (#1)
RX- (#4) | RX- (#2)
TX+ (#7) | TX+ (#7)
TX- (#8) | TX- (#8)
RXVDD (#2), TXVDD (#9) | AVCC (#3)

Don't forget to connect grounds too!

Additional passive components, such as resistors and capacitors must also be placed near the DM9000B and connected to RX and TX lines. For detailed information see the DM9000B datasheet.

To take full advantage of the unique space-saving design of the RJ203, place the DM9000B (and/or any other components as you see fit) under the module. The housing of the module has a substantial recess area under the RJ45 jack. This area can be utilized to accommodate various board components. Moreover, the housing of the RJ203 is made of a translucent material, so you can also place necessary status LEDs within the recess area and in the proximity to the front wall of the RJ203. This way, your status LEDs will be visible through the translucent front face of the RJ203. Four to six LEDs can easily fit along that front wall.


Using the RJ203 With the EM203 and Other Modules

The RJ203 can also be used in combination with the EM203 Ethernet-to-serial module (documented in the "Serial-over-IP Solutions Manual") or EM1206 BASIC-programmable Ethernet module.

Connector pins of the EM203 and EM1206 are designed to mate with interface pads of the RJ203. The EM203 (EM1206) fits "under" the RJ203 and partially within the recess area provided by the RJ203. This recess area is formed by a translucent housing of the RJ203. When the EM203 (EM1206) is combined with the RJ203, the status LEDs of the EM203 (EM1206) become positioned close to the translucent front wall of the RJ203 and remain visible through the front face of the RJ203.

Detailed mechanical information can be found in the Mechanical Dimensions: RJ203+EM203 and Mechanical Dimensions: RJ230+EM1206 topic.


Mechanical Dimensions: RJ203

L | Max. | 31.0 | Length
W | Max. | 20.0 | Width
H | Max. | 15.5 | Height
l | Aver. | 5.5 | Clearance between the installation surface and the bottom of the RJ203's board
w1 | Max. | 19.0 | Width at the face excluding mounting stands
w2 | Max. | 18.1 | Board width
M | Min. | 1.9 | Mounting stand and tail height
t1 | Aver. | 2.5 | Mounting stand diameter
t2 | Aver. | 1.5 | Solder tail width
t3 | Aver. | 0.25 | Solder tail thickness
p | Aver. | 1.27 | Connector pad pitch
s1 | Aver. | 28.1 | Distance from device face to the pad row
s2 | Aver. | 17.4 | Distance from the second pad row to the vertical centerline of solder tails
s3 | Aver. | 21.4 | Distance from the second pad row to the vertical centerline of mounting stands
h1 | Aver. | 17.5 | Distance between the horizontal centerlines of mounting stands
h2 | Aver. | 18.5 | Distance between the horizontal centerlines of solder tails
C | Min. | 4.4 | Clearance from the installation surface to the top wall of the recess area of the housing

Dimensions are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


Mechanical Dimensions: RJ203+EM203

L | Max. | 31.0 | Length
W | Max. | 20.0 | Width
H | Max. | 15.5 | Height
l | Min. | 4.0 | Connector pin length
w1 | Max. | 19.0 | Width at the face excluding mounting stands
w2 | Max. | 18.1 | Board width
M | Min. | 1.9 | Mounting stand and tail height
t1 | Aver. | 2.5 | Mounting stand diameter
t2 | Aver. | 1.5 | Solder tail width
t3 | Aver. | 0.25 | Solder tail thickness
p | Aver. | 1.27 | Connector pin pitch
s1 | Aver. | 29.7 | Distance from the face to the connector pins
s2 | Aver. | 19.0 | Distance from connector pins to the vertical centerline of solder tails
s3 | Aver. | 23.0 | Distance from connector pins to the vertical centerline of mounting stands
h1 | Aver. | 17.5 | Distance between the horizontal centerlines of mounting stands
h2 | Aver. | 18.5 | Distance between the horizontal centerlines of solder tails

Dimensions are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


Mechanical Dimensions: RJ203+EM1206

L | Max. | 34.4 | Length
W | Max. | 20.0 | Width
H | Max. | 15.5 | Height
l | Min. | 4.0 | Connector pin length
w1 | Max. | 19.0 | Width at the face excluding mounting stands
w2 | Max. | 18.1 | Board width
M | Min. | 1.9 | Mounting stand and tail height
t1 | Aver. | 2.5 | Mounting stand diameter
t2 | Aver. | 1.5 | Solder tail width
t3 | Aver. | 0.25 | Solder tail thickness
p | Aver. | 1.27 | Connector pin pitch
s1 | Aver. | 33.1 | Distance from the face to the connector pins of the main connector
s2 | Aver. | 22.2 | Distance from the connector pins of the main connector to the vertical centerline of solder tails
s3 | Aver. | 26.25 | Distance from the connector pins of the main connector to the vertical centerline of mounting stands
s4 | Aver. | 28.35 | Distance from the connector pins of the main connector to the connector pins of the additional connector
h1 | Aver. | 17.5 | Distance between the horizontal centerlines of mounting stands
h2 | Aver. | 18.5 | Distance between the horizontal centerlines of solder tails

Dimensions are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


Ordering Info and Specifications

The RJ203 has a single model available -- the RJ203-00.

Ordering RJ and EM module combinations

The RJ203 can also be ordered in combination with the EM203 (documented in the "Serial-over-IP Solutions Manual") or EM1206 module. To receive the RJ203 and EM203 pre-assembled together, please specify "RJ203+EM203" on your order if you wish to receive the EM203 with the "serial-to-Ethernet" firmware preloaded, or "RJ203+EM203-P" if you wish to receive the EM203 with the TiOS firmware preloaded. To receive the RJ203 and EM1206 pre-assembled together, please specify "RJ203+EM1206" on your order.

Specifications

Jack type | Standard RJ45 Ethernet jack
Magnetics type | 10/100BaseT, designed to work with DAVICOM DM9000B Ethernet controller
Operating temperature | -20 to +70 degrees C
Operating relative humidity | 10-90%
Mechanical dimensions (excl. leads) | 31.0x20.0x15.5 mm
Packaging | RJ203 devices and RJ203+EM1206 module combination: tray, 30 modules/tray RJ203+EM203 module combination: tube, 10 modules/tube

All specifications are subject to change without notice and are for reference only. Tibbo assumes no responsibility for any errors which may appear in this Manual, and does not make any commitment to update the information contained herein.


Accessories

The following accessories are currently being offered by Tibbo:

· WAS-P0004(B) DS-to-device serial cable
· WAS-P0005(B) DS-to-PC serial cable
· WAS-1499 "straight" Ethernet cable (DS-to-hub cable)
· WAS-1498 "crossover" Ethernet cable (DS-to-device cable)
· 12VDC Power Adaptors
· TB100 Terminal Block Adaptor
· TB1000 Terminal Block Adaptor
· TB1004 Test Board
· TB1005 Test Board


WAS-P0004(B) DS-to-Device Serial Cable

WAS-P0004(B) is a female-male serial cable that can be used to connect Tibbo Device Server or Board to the serial port of your device.

DB9M (Male) | DB9F (Female)
#2 | #2
#3 | #3
#4 | #4
#5 | #5
#6 | #6
#7 | #7
#8 | #8

The cable is of blue color, approximately 1.5m long.


WAS-P0005(B) DS-to-PC Serial Cable

WAS-P0005(B) is a female-female serial cable that can be used to connect Tibbo Device Server or Evaluation Board to the COM port of your PC.

DB9F (Female) | DB9F (Female)
#2 | #3
#3 | #2
#4 | #6
#5 | #5
#6 | #4
#7 | #8
#8 | #7

The cable is of green color, approximately 1.5m long.


WAS-1499 'Straight' Ethernet Cable

WAS-1499 can be used to connect Tibbo Device Server or Evaluation Board to an Ethernet hub.

Side A | Side B
#1 (pair 1) | #1
#2 (pair 1) | #2
#3 (pair 2) | #3
#6 (pair 2) | #6

The cable is of blue color, approximately 1.5m long.


WAS-1498 'Crossover' Ethernet Cable

WAS-1498 can be used to connect Tibbo Device Server or Evaluation Board directly to some other Ethernet device (i.e. Ethernet port of the PC). This is a so called "crossover" cable that can interconnect two Ethernet devices without a hub.

Side A | Side B
#1 (pair 1) | #3
#2 (pair 1) | #6
#3 (pair 2) | #1
#6 (pair 2) | #2

The cable is of green color, approximately 1.5m long.


12VDC Power Adaptors

The following adaptor models are now offered:

Products | Specifications | US | Europe | UK
EM120/200-EV | 12VDC/0.5A, non-switching, "large" connector (5.5mm) | APR-1014 | APR-1015A | APR-1018A
EM1000-EV EM1000-TEV DS1000 family | 12VDC/1A, switching, "small" connector (3.5mm) | APR-P0008 | APR-P0009 | APR-P0010
DS1202, DS1206, DS1026N, EM1202EV | 12VDC/0.5A, switching, "small" connector (3.5mm) | APR-P0011 | APR-P0012 | APR-P0013


TB100 Terminal Block Adaptor

The TB100 Terminal Block Adaptor attaches to the DB9M connector. The TB100 provides a convenient way of wiring RS422 and RS485 lines to the serial port of a Tibbo device. The wires are inserted into the terminal contacts and the terminals are then tightened using a screwdriver.

The following table details terminal block contact functions in RS232, RS422, and RS485 modes of operation. The table assumes that the TB100 is connected to a Tibbo device with universal serial port that has DB9M connector.

 | RS232 | RS422 | RS485
#2 | <No connection> | RTS- (output) | <No connection>
#7 | RX (input) | RX- (input) | RX- (input)
#8 | TX (output) | TX+ (output) | TX+ (output)
#9 | DTR (output) | TX- (output) | TX- (output)
#10 | Ground | Ground | Ground
#6 | DSR (input) | RX+ (input) | RX+ (input)
#1 | RTS (output) | RTS+ (output) | <No connection>
#3 | CTS (input) | CTS+ (input) | <No connection>
#4 | <No connection> | CTS- (input) | <No connection>

Although Tibbo devices support half-duplex RS485 communications, TX and RX lines remain independent on these devices even in the RS485 mode. In order to arrange a two-wire half-duplex RS485 bus you need to externally connect RX+ to TX+ and RX- to TX-. On the TB100 this is conveniently done by closing (putting to ON position) two switches- SW1 and SW2. These are located on the back of the TB100.

Additionally, the TB100 provides termination circuits typically needed at the end of long RS422 or RS485 lines. There are four identical terminators that can be switched on and off individually using four switches located on the back of the TB100. The following table details which line pairs the terminators can be connected to:

SW3 | CTS+/CTS-
SW4 | RTS+/RTS-
SW5 | RX+/RX-
SW6 | TX+/TX-

Schematic diagram for one of the terminators is shown on figure below.

If you are using RS485 mode (SW1 and SW2 are closed) and you want to terminate the RS485 bus, then you only need to close either SW5 or SW6. Having both switches closed will effectively add two termination circuits to the same bus!


TB1000 Terminal Block Adaptor

The TB1000 terminal block adaptor is designed to be used with DS1000, DS1002, and DS1003 devices (or IB1000, IB1002, and IB1003 boards). This adaptor "converts" DB9 connectors of the DS1000, DS1002, and DS1003 into 9-terminal blocks of "spring clamp" type. These are convenient for attaching wires, which is very useful for industrial installations.

Each terminal of the terminal block connects directly to a pin on the DB9 connector. Pin numbers on DB9 connectors and terminal blocks match exactly. Therefore, terminal assignment on each terminal block is as follows:

Terminal # | RS232 mode | RS422 mode | RS485 mode
1 | --- | RTS- (output) | ---
2 | RX (input) | RX- (input) | RX- (input)
3 | TX (output) | TX+ (output) | TX+ (output)
4 | DTR (output) | TX- (output) | TX- (output)
5 | SYSTEM GROUND | SYSTEM GROUND | SYSTEM GROUND
6 | DSR (input) | RX+ (input) | RX+ (input)
7 | RTS (output) | RTS+ (output) | ---
8 | CTS (input) | CTS+ (input) | ---
9 | --- | CTS- (input) | ---

DS1002 and DS1003 devices have universal serial ports that can additionally work in RS422 and RS485 modes. Proper signal termination may be required when longer cables are used in these modes. The TB1000 have four switch blocks, one for each port. Each switch block includes four switches. When closed, each switch connects a termination circuit between the "+" and "-" signals in a signal pair:

Switch # within the block | Signal pair
1 | CTS+/CTS-
2 | RTS+/RTS-
3 | RX+/RX-
4 | TX+/TX-

The TB1000 can be additionally secured on the DS10xx device using four screws (included). This terminal block adaptor is also compatible with the "secondary cover", also known as "waterproof cover".


TB1004 Test Board

The TB1004 test board is provided for the convenience of evaluating the DS1004 controller (IB1004 + SB1004 boards). The board is basically a loopback, feeding D/A outputs into A/D inputs of the DS1004. Schematic diagram of the test board's connections is shown below:

Voltage outputs of D/A channels 1-4 are connected directly to A/D inputs 1-4, and also to four red LEDs 1-4. The brightness of these LEDs is proportional to the voltage on D/A outputs. Obviously, LEDs will only work for positive output voltages and will stay off for negative voltages. Thus, LEDs provide indication only for 1/2 of the D/As' output range.

Current outputs of D/A channels are not used at all and can't be tested with the TB1004 board.

A/D inputs 4-8 are wired into the circuit through four adjustable resistors R1-4. Voltage for these resistors comes from the D/A output 4. Therefore, the voltages on central taps of R1-4 are a fraction of the current output of D/A 4.


TB1005 Test Board

The TB1005 test board is provided for the convenience of evaluating the DS1005 controller (IB1005 + SB1005 boards). The board is basically a loopback, feeding relay outputs into sensor inputs of the DS1004. Schematic diagram of the test board's connections is shown below:

Relays 1-6 are wired into sensor inputs 1-6. They commutate "Vin", which is the voltage from the power source for the DS1005. When a relay is activated, this voltage is applied to a corresponding sensor input.

There are eight sensor inputs but only six relays. Remaining sensor inputs 7 and 8 are controlled by two buttons which play the same role as the relays. Push a button and a corresponding sensor input is triggered.


Appendix 1: Status LEDs

Status LEDs

BASIC-programmable devices supplied by Tibbo have a pair of green and red status LEDs and/or control lines for connecting such LEDs externally. Particular status LED arrangement is product-specific, but these LEDs and/or their control lines are always implemented in one way or another.

Status LEDs have multiple functions:

· When the device is in the serial upgrade mode, these LEDs indicate the status of firmware upload process.
· When the device is under TiOS firmware control and Tibbo BASIC application is not running, these LEDs show current Tibbo BASIC application status.
· When the Tibbo BASIC application is running, status LEDs are under the control of the .pat object (see "TIDE and Tibbo BASIC Manual").

The following table summarizes predefined status LED blinking (flashing) patterns:

Serial upgrade mode
 | Green LED blinks slowly | File upload completed successfully.
 | One long and one short "blink" of red LED | Communications error encountered during the serial file transfer.
 | One long and two short "blinks" of red LED | FLASH memory failure.
Normal operation, Tibbo BASIC application not running
 | Fast-blinking GRGRGR... pattern | TiOS firmware not loaded or corrupted.
 | Fast-blinking BBBB... pattern (B= red and green together) | Tibbo BASIC application loaded but cannot run due to insufficient variable (RAM) memory
 | Fast-blinking G-G-G-... pattern | Tibbo BASIC application loaded but not running.
 | Fast-blinking R-R-R-... pattern | Tibbo BASIC application not loaded or corrupted.

Ethernet status LEDs

Most Tibbo devices also have a pair of green and yellow Ethernet status LEDs and/or control lines for connecting such LEDs externally.

Ethernet status LEDs indicate the following:

· Link/Data LED (green) is turned on when "live" Ethernet cable is plugged into the device. The LED blinks whenever an Ethernet packet is received.
· 100BaseT LED (yellow) is turned on when the device links with the hub at 100Mb. The LED is off when the link is established at 10Mb.

The EM500 and EM500EV devices do not have Ethernet status LEDs and the function of Ethernet state indication is performed by the status LEDs (status LED control lines) of these devices. These so-called dual-function status LEDs indicate the device state through familiar blinking (flashing) patterns, while LED brightness indicates the physical link state.

When "live" Ethernet cable is not plugged into the device, flashing patterns displayed by the status LEDs are "dimmed". That is, LEDs turn on at around 20% of their nominal brightness. When a "live" Ethernet cable is plugged into the device, flashing patterns are displayed at full brightness.

With this method of Ethernet status indication, there is no way to determine whether the link is established at 10 or 100Mb. This aspect, however, is of little importance these days because the majority of network hubs on the market are of the 100BaseT type.


Appendix 2: Setup (MD) Button (Line)

Tibbo boards* and external controllers have a button called "setup" or "MD" button ("MD" abbreviation stands for "mode"). Tibbo modules have an MD pin for connecting an external button.

The setup button (line) has three functions:

· When a Tibbo BASIC application is running, it can use the button for its own purposes (see "TIDE and Tibbo BASIC Manual", button. object).
· When the device is password-protected, keeping the button pressed while accessing the device from TIDE allows to bypass the password. This is the way to reset the password on the device.
· When the device is powered up (exits from the hardware reset) with the button pressed (line pulled low), it enters a firmware upgrade mode in which new TiOS firmware, possibly with compiled Tibbo BASIC application attached, can be uploaded into the device. If the device is powered up with the setup button not pressed (line not pulled low), the device starts the execution of the TiOS firmware (if loaded).

* This only applies to boards that carry a Tibbo module or directly incorporate BASIC-programmable hardware (such as the T1000 ASIC).


Update history

 Top Previous

30MAY2011 release

· Expanded and corrected GA1000 documentation:

- Many small corrections throughout;

- Correction in I/O Pin Assignment and Pin Functions (of the GA1000): DI and DO pins were shown incorrectly (swapped);

- One new Connecting GA1000 to Tibbo Devices topic.

· Expanded and corrected EM500 documentation:

- Many small corrections throughout;

- Flash and EEPROM Memory topic now provides information on connecting external flash IC for fd. object.

- I/O Pin Assignment and Pin Functions contains information about attaching external flash IC and GA1000.

25MAY2011 release

· Corrected a part number in EM1206 Ordering Info and Specifications.

16MAY2011 release

· Edited EM500 manual: provided details on how an external flash IC can be connected to the EM500.

21MAR2011 release

· Removed all references to WA1000. This legacy module is no longer supported.

8MAR2011 release

· Replaced references to obsolete WA1000 with GA1000, updated part numbers and links.

16FEB2011 release

· Updated list of power adaptors.

14FEB2011 release

· Corrected typographical error in PSU part numbers (APR instead of ARP)

04JAN2011 release

· Updated image on EM1000TEV topic to reflect use of GA1000 component.

03DEC2010 release

· Added pin diameter for EM500, EM1206, EM1202, EM200, EM1000

20JUL2010 release

· Documented EM500EV.
· Reworked Appendix1: Status LEDs topic.
· Reworked Appendix2: Setup Button (MD line) topic, also renamed it to "Setup (MD) Button (Line)".

------

22JUN2010 release

· Corrected various documentation errors, including incorrect model numbers in DS1000, DS1002, DS1003 (4 Serial Ports) topic.

------

17JUN2010 release

· Clarified and expanded External LED Control topic for NB1000.

------

15JUN2010 release

· Fixed incorrect reference to Winstar LCD model number (replaced WG12864F with WG12864A)
· Fixed GA1000 max. power consumption.
· Fixed lines 6 and 7 in EM1206 I/O Pin Assignment and Pin Functions

------

01JUN2010 release

· Updated Module Comparison Table.
· Documented EM500.

------

01FEB2010 release

· Updated NB10x0 and IB100x Boards section (new IB1004 + SB1004, IB1005 + SB1005 devices). Almost every pre-existing topic has also been edited.
· Updated DS10xx Family section -- again, almost every topic has been edited.
· Documented TB1000, TB1004, and TB1005 accessories.

------

29JUL2009 release

· Documented the following products: EM1206, EM1206EV, GA1000, DS1206, DS1206N, DS1202, and EM1202EV.
· Edited cover pages for EM1000 and EM1202 products.
· Edited Ordering Info and Specifications for EM1000 and EM1202 devices.
· Created Appendix 1: Status LEDs and Appendix 2: Setup Button (MD line) topics, added links to these new topics from each product's manual.
· Edited I/O Pin Assignment and Pin Functions topics of EM1000 and EM1202 modules.

------

Initial release

· Revamped DS1000 description. It now includes DS1001 and DS1002 devices. Content is totally new -- the manual simply refers to the NB1000 and IB1000-2 docs.
· Documented IB1004 and DS1004 devices.
· Documented IB1005 and DS1005 devices.

The Programmable Hardware Manual is a spin-off of the Tibbo Document System Manual. Original split was performed on 09JUN2008.