Анализатор проекта и обозреватель

В TIDE есть анализатор проекта, который постоянно просматривает проект по мере редактирования. Его задача - «составлять каталог»: отслеживать ваши процедуры (функции), переменные, константы и так далее.

Анализатор гораздо терпимее компилятора: он старается пропустить то, чего не понимает.

Ниже перечислены некоторые заметные возможности, которые анализатор даёт TIDE:

Кнопка Preferences в TIDE.Примечание: поведение анализатора настраивается в диалоге TIDE Preferences (File > TIDE Preferences > Editor > General, Tibbo BASIC, Tibbo C)

Обозреватель проекта

Снимок экрана панели Browser-Project в TIDE с пояснениями.

Плоды трудов анализатора отображаются на панели Browser-Project (View > Browser-Project). Эта панель незаменима для навигации по проекту, а также для знакомства с ресурсами (объектами, системными функциями и т. д.), которые предлагает выбранная платформа.

Обозреватель файла

Снимок экрана панели Browser-File в TIDE с пояснениями.

Есть также панель Browser-File (View > Browser > File), которая очень удобна для навигации по текущему редактируемому файлу.

Телепортация по [CTRL]+щелчок

Снимок экрана функции телепортации в TIDE с пояснениями.

[CTRL]+щелчок на процедуре, переменной, константе и т. п. в исходном коде: вы телепортируетесь к определению этого элемента.

[CTRL]+наведение мыши на процедуру открывает окно дерева вызовов - то же, что показывается в обозревателе проекта.

Автодополнение

Снимок экрана функции автодополнения в TIDE с пояснениями

Анализатор показывает список подсказок по мере набора.

Подсказки

Снимок экрана всплывающей подсказки в TIDE.

Наводите мышь на элементы, чтобы получить всплывающие подсказки «quick info»; их можно показывать даже для ваших собственных процедур (функций).

Автоматическая вставка фрагментов кода

Снимок экрана функции автоматической вставки фрагментов кода в TIDE с пояснениями.

Стандартные конструкции языка достраиваются за вас автоматически.

Универсальный поиск

Снимок экрана функции универсального поиска в TIDE.

Наша гордость! Введите что угодно и оцените глубину предлагаемых элементов и действий!

Думаете, всё очевидно? Попробуйте:

  • Ввести имя файла из вашего проекта
  • Набрать номер строки

Разделители процедур

Снимок экрана разделителей в TIDE с пояснениями.

TIDE рисует разделительную линию после процедур и некоторых других конструкций, чтобы код легче читался.

Эту функцию можно отключить отдельно для Tibbo BASIC и C - см. диалог TIDE Preferences (File > TIDE Preferences > Editor > Tibbo BASIC, Tibbo C).

Если разделители процедур установлены в режим smart, «автоматическую» линию можно переопределить, добавив строку комментария, содержащую три или более повторяющихся символа (и, при желании, пробелы).

Неважно, какой символ вы используете, если один и тот же символ повторяется не менее трёх раз и в этом комментарии нет других символов (кроме пробелов), как показано ниже.

Исходный материал Tibbo обновлён 12 сентября 2022Оригинал на docs.tibbo.com · Сообщить об ошибке